This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Centos 7 support
#11
RE: Centos 7 support
Resumed working on centos 7 install:

First issue install is epel repos used by old installer will fail on 3 packages php-imap / php-mbstring ( required for roundcube/phmyadmin) and php-suhosin.

The old installer will fail as no packages will be installed.

Nigel figured that out and setup using epel 7 Beta.

Epel 7 official repo is already there:

wget http://dl.fedoraproject.org/pub/epel/7/x...noarch.rpm

yum -ivh epel-release-7-1.noarch.rpm

All services look ok BUT apache is still not working for an unkown reason here.

Should add also new suhosin and compile it manually as we used to.

Notice install won't work with yum install mysql and all related tools as we have here mariaDB instead. Redhat moved off mySQL to mariaDB, will check if it would trigger some path changes here, doesn't see to have impact as mariadb admin tools have the same names.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#12
RE: Centos 7 support
Apache was working, but I couldn't connect to a machine 4 meters away from me.
***Retail***
SCPH-39002, Running FCMB, HDD-OSD, Mini-OPL.
SCPH-30002 RSW (Automobile Collection Snow White)
SCPH-10000 x2
SCPH-15000
SCPH-18000 x2
DESR-7700
SCPH-2040X x2
Linux Kit
PSBBN V0.20, V0.30
HDD Utility V1.00, V1.01

***Dev***
DTL-H30102 Running FCMB, HDD-OSD, Mini-OPL.
DTL-H20400 - Boxed
Reply
Thanks given by:
#13
RE: Centos 7 support
It's the same here looks firewalled. I'm able to grab a page using lynx browser.

I will fix apache and there seem new command lines for firewall not bad at all.

Will fix this not a big issue. will reset my VM to snapshot and reinstall again.

Got it

http://www.tejasbarot.com/2014/08/02/rhe...-iptables/

Installer disable iptables but we have a new firewall here and we should add

service firewalld stop
chkconfig firewalld stop...

That's it and now I can see my little big apache working fine on remote machines it was obvious firewall was there Nigel.
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#14
RE: Centos 7 support
Some warning to fix... same in ubuntu.

Sep 17 19:36:39 centos7.local httpd[19993]: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/zpanel/configs/apache/httpd-vhosts.conf:9
Sep 17 19:36:39 centos7.local httpd[19993]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using centos7.local. Set the 'ServerName' directive globally

Still checking to get apache working fine...

LoadModule suexec_module modules/mod_suexec.so

SuExec is enabled by default that's great but we have to disable it currently.

Would be neat to support it.


PHP 5.4.16 (cli) (built: Aug  6 2014 13:12:28)
Copyright © 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright © 1998-2013 Zend Technologies
   with Suhosin v0.9.37-dev, Copyright © 2007-2014, by SektionEins GmbH

It's not the main issue currently....

Error AH01630
fixed
http://httpd.apache.org/docs/2.4/upgrading.html

Sentora running currently on centos 7... Need to review the security and if there is some bugs here.

We need mainly to change apache hook to support 2.4 over
Require all granted

That will replace

Order Allow,Deny
Allow from all

Those cause an issue here.

5050 already had to handle it in ubuntu and same patched the hook manually using:
sed -i 's|Order allow,deny|Require all granted|I' /etc/zpanel/panel/modules/apache_admin/hooks/OnDaemonRun.hook.php
sed -i '/Allow from all/d' /etc/zpanel/panel/modules/apache_admin/hooks/OnDaemonRun.hook.php

That should do the trick but then need to be applied after each update. We need to patch the apache hook.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#15
RE: Centos 7 support
Beta testers? Guinea pigs?

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#16
RE: Centos 7 support
Notice installer is slow when cloning despite my dsl.

Better we set using the tagged release

https://github.com/sentora/sentora-core/.../1.0.0.zip ( wget & extract ).

We could later allow either beta ( latest ) or last-stable in advanced mode...

Fixed os test and will focus on major release instead of only testing 6.5 .6.4 6.3 6.2 or 7.1 later... will test 6 & 7 then go.

Must add instructions for centos 6 mysql || centos 7 mariadb would be fine & test back on centos 6.x



M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#17
RE: Centos 7 support
5050

6.x and 7.x support focus on major release test.

Code:
# Ensure the installer is launched and can only be launched on CentOs 6.x/ centos 7.x Supported
BITS=$(uname -m | sed 's/x86_//;s/i[3-6]86/32/')
if [ -f /etc/centos-release ]; then
 OS="CentOs"
 VERFULL=$(cat /etc/centos-release | sed 's/^.*release //;s/ (Fin.*$//')
 VER=${VERFULL:0:1}
else
 OS=$(uname -s)
 VER=$(uname -r);
fi
echo "Detected : $OS  $VER  $BITS"
#warning
the last version of centos and 6.x
if [[ "$OS" = "CentOs" ]] && ( [[ "$VER" = "6" ]] || [[ "$VER" = "7" ]] ) ; then
echo "Ok."
if "$VER"== "7"; then
dbserver="mariadb"
fi

else
 echo "Sorry, this installer only supports the installation of Sentora on CentOS 6.x./7.x"
 exit 1;
fi

added 3 variables:

Code:
panelpath="/etc/zpanel"
paneldata="/var/zpanel"
dbserver="mysql"


M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#18
RE: Centos 7 support
I've tried checking for Version 7 and it just throws me an error.

I tried ALL available variables.
***Retail***
SCPH-39002, Running FCMB, HDD-OSD, Mini-OPL.
SCPH-30002 RSW (Automobile Collection Snow White)
SCPH-10000 x2
SCPH-15000
SCPH-18000 x2
DESR-7700
SCPH-2040X x2
Linux Kit
PSBBN V0.20, V0.30
HDD Utility V1.00, V1.01

***Dev***
DTL-H30102 Running FCMB, HDD-OSD, Mini-OPL.
DTL-H20400 - Boxed
Reply
Thanks given by:
#19
RE: Centos 7 support
I made the fix in the code Nigel.

It works for me and I can detect 7.0 or only 7. As centos os release have now a longer number 7.0.xxx so I used to select first 3 characters or first to do the trick.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by: Nigel
#20
RE: Centos 7 support
(09-19-2014, 07:54 PM)Me.B Wrote: I made the fix in the code Nigel.

It works for me and I can detect 7.0 or only 7. As centos os release have now a longer number 7.0.xxx so I used to select first 3 characters or first to do the trick.

M B

Man I f***ked around for ages trying to get that working. Angry
***Retail***
SCPH-39002, Running FCMB, HDD-OSD, Mini-OPL.
SCPH-30002 RSW (Automobile Collection Snow White)
SCPH-10000 x2
SCPH-15000
SCPH-18000 x2
DESR-7700
SCPH-2040X x2
Linux Kit
PSBBN V0.20, V0.30
HDD Utility V1.00, V1.01

***Dev***
DTL-H30102 Running FCMB, HDD-OSD, Mini-OPL.
DTL-H20400 - Boxed
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
Why is there no support for debian? kevwebbie 2 469 05-22-2024, 01:50 AM
Last Post: kevwebbie
Ubuntu 12.04 end of support Me.B 2 7 ,749 04-19-2017, 05:09 AM
Last Post: Me.B
How can i install Sentora on my Centos 6 64b vps ? Adam 1 6 ,790 01-21-2017, 09:40 AM
Last Post: worksmarter

Forum Jump:


Users browsing this thread: 2 Guest(s)