This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

PHP not working
#1
PHP not working
I reinstalled PHP now websites are not working, Help me restore php
Reply
Thanks given by:
#2
RE: PHP not working
Why you did that?

What error are you getting?

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#3
RE: PHP not working
i did it because i thought it would be good to have a new version of php
im getting php codes instead of nice html
for ex: while($itemNewDiscount=mysql ....

first i upgraded to PHP 5.5 then some scripts got broken, then went back to 5.3 but its not working now
Reply
Thanks given by:
#4
RE: PHP not working
It was a very bad idea...

When you modify Zpanel/sentora you are at your own !!!

Likely apache is not using php again did you check back apache config as it's a total mess.

Did you install all php requirements? Suhosin? As it's not only about php.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#5
RE: PHP not working
no suhosin installed Sad

help me solve this little problem then i will reinstall it from the start

how do i get this line working in fresh CentOS
bash <(curl -Ss https://raw.github.com/sentora/sentora-i...staller.sh)

the sh download script is broken
Reply
Thanks given by:
#6
RE: PHP not working
(09-05-2014, 09:23 PM)vprocopan Wrote: help me solve this little problem then i will reinstall it from the start

Reinstalling is how you will resolve this. A fresh install will fix everything. Trying to 'solve' it is way too complicated as config files and many other things are not working.
-TGates - Project Council

SEARCH the Forums or read the DOCUMENTATION before posting!
Support Sentora and Donate: HERE

Find my support or modules useful? Donate to TGates HERE
Developers and code testers needed!
Contact TGates for more information
Reply
Thanks given by:
#7
RE: PHP not working
It needs a lot of work to be fixed, unless you know what you do and check step by step errors to manually install back all the stuff you broke ( suhosin, php lib/dependency, php.ini setup ).

So as Tom advised best is to do a new fresh install.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#8
RE: PHP not working
what do i have to copy besides hostdata folder to the new server?
Reply
Thanks given by:
#9
RE: PHP not working
you need to copy your DB's & emails ( if you had emails setup ).

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by:
#10
RE: PHP not working
should i wait for a working link to sh file from the download page or install zpanel for now

I managed to get it working guys, php.ini had short_open_tags off and it seemed to me that php was not working at all until programmers figured it out that actually php was working it was this setting's problem. thanks for the support.
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
Add on Domains not working but Main domain works luckyviet 2 5 ,771 03-18-2020, 07:38 PM
Last Post: AanaNahum
working on single domain bahabi 1 4 ,496 08-27-2019, 12:06 AM
Last Post: TGates
DNS Stopped Working hthiers 3 7 ,006 05-10-2019, 06:00 AM
Last Post: hthiers

Forum Jump:


Users browsing this thread: 3 Guest(s)