This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

FTP accouunt setting problem of Sentora
FTP accouunt setting problem of Sentora

My ftp account was created on domain home directory. 

After having some difficulties to access to ftp I could connect to my domain ftp account with WinSCP but ended up with this error message. 

Server sent passive reply with unroutable address xXX.xX.xX.XX(My server private IP), using host address instead.

Timeout detected. (data connection)
Could not retrieve directory listing
Error listing directory '/'. 

This could be Amazon AWS instance problem but Sentora also updates and maintain a lot different path and directory permission form regular Linux.  This might be also Sentora issue.

I have also tried to test it from  and got this result.

Error: Server returned unroutable private IP address in PASV reply
  • Make sure the server is configured to allow passive mode connections.
  • If the server is behind a NAT router, make sure the server knows its external IP address.
  • The range of ports used for passive mode must be opened in all involved firewalls.
  • The range of ports used for passive mode must be forwarded by all involved NAT routers.
  • Try uninstalling all firewalls and plug your computer directly into your modem, thus bypassing the router.
This might be my WinSCP Setting problem but don't what..

I tried to use FilleZilla and did not work. 

Can you help me out?

Somehow it worked on FilleZilla.

I only changed

FilleZilla Edit menu, Preference, FTP, Active mode , deselect "Don't use external IP for internal ...(D)"

After my WordPresss installation, it did not work anymore ...

Error: Connection got closed prematurely


And newly migrated WP site has database connection problem as well.

Error establishing a database connection

Sentora seems to have ftp related configuration and permission issues.
Thanks given by:
RE: FTP accouunt setting problem of Sentora
Check firewall and open ports.

PASV will fail if ports used for PASV mode are not open.

MySQL require 3306 open for localhost at least. For remote access you need to allow user for that.

No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Thanks given by:
RE: FTP accouunt setting problem of Sentora
Huh I have installed Sentora on both CentOS and Ubuntu (various versions) and FTP always worked. So, it leads me to believe it is your network or FTP client being misconfigured.
-TGates - Project Council

SEARCH the Forums or read the DOCUMENTATION before posting!
Support Sentora and Donate: HERE

Find my support or modules useful? Donate to TGates HERE
Developers and code testers needed!
Contact TGates for more information
Thanks given by:
RE: FTP accouunt setting problem of Sentora
yes sentora will work with filezilla
Thanks given by:

Possibly Related Threads…
Thread Author Replies Views Last Post
Ftp connection problem after update BatuhanK 0 3 ,124 04-02-2020, 09:45 PM
Last Post: BatuhanK
Problem of connecting to ftp vladaniel 2 8 ,241 03-07-2018, 06:49 AM
Last Post: Me.B
FTP Authentication Problem sathish2009 1 7 ,163 07-04-2017, 04:36 PM
Last Post: sathish2009

Forum Jump:

Users browsing this thread: 1 Guest(s)