This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

SenCrypt Trouble-shooting
[Solved] SenCrypt Trouble-shooting
If you are having issues with SenCrypt creating certificates for your domains:
(I will be adding to this guide as new ideas to test are learned.)

The DNS has to be just right or the Let's Encrypt verification won't be able to read the challenge.

  1. Verify that the challenge folder was made. (The challenge file will be deleted if successful)
    1. /etc/sentora/panel/.well-known/acme-challenge/ (Sentora domain)
    2. /var/sentora/hostdata/zadmin/public_html/mach-hosting_com/.well-known/acme-challenge/ (Normal domain)

  2. Verify the SSL information was saved.
    1. /var/sentora/hostdata/zadmin/ssl/sencrypt/letsencrypt/_account/
      • public.pem
      • private.pem
    2. /var/sentora/hostdata/zadmin/ssl/sencrypt/letsencrypt/panel.domain.tld/ (Sentora)
    3. /var/sentora/hostdata/zadmin/ssl/sencrypt/letsencrypt/domain.tld/ (Normal domain)
      • cert.pem
      • chain.pem
      • fullchain.pem
      • last.csr
      • private.pem
      • public.pem

  3. Verify the certificates contain data.
    (...29 lines removed...)
    -----END CERTIFICATE-----

I had an issue with using a domain as a shared domain. I could access the site, but Let's Encrypt couldn't access the challenge verification. I had it added in my GoDaddy and Sentora. I had to remove it from GoDaddy and used just my Sentora DNS and it worked.

So, you need to check how your DNS is setup and try different settings to see which one works and edit all your domains to use the same setup.

Start a new thread if you need help.
-TGates - Project Council

SEARCH the Forums or read theĀ DOCUMENTATION before posting!
Support Sentora and Donate: HERE

Find my support or modules useful? Donate to TGates HERE
Developers and code testers needed!
Contact TGates for more information
Thanks given by:

Possibly Related Threads…
Thread Author Replies Views Last Post
sencrypt privacy error zustudios 5 1 ,040 05-09-2024, 08:31 AM
Last Post: TGates
sencrypt ssl error zustudios 7 2 ,379 02-12-2024, 10:19 AM
Last Post: TGates

Forum Jump:

Users browsing this thread: 1 Guest(s)