This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Sub-Domain not Working with CloudFlare DNS
#1
Sub-Domain not Working with CloudFlare DNS
Greetings,

In Short my Problem is:
Sub Domain does not work with CloudFlare enabled. Works without CloudFlare Enabled.


Here are the details:
I'm using CloudFlare as my DNS for my Sentora domains.
Currently my Sentora subdomain is sentora.mydomain.com, working as expected.
I've created a Client account in Sentora for mydomain.com, working as expected.
In that Client account I've added a subdomain sub.mydomain.com...

CloudFlare DNS Settings:
  • A - mydomain.com - 11.22.33.44 (CloudFlare ENABLED)
  • A - sentora - 11.22.33.44 (CloudFlare Disabled)
  • CNAME - sub - mydomain.com (CloudFlare ENABLED)
With the above settings, sub.mydomain.com does not work, if I disable CloudFlare it starts working.

What I've tried:
  • Waited For Daemon to run and for DNS propagation.
  • Restarted Apache.
  • Rebooted Server.
  • Installed mod_cloudflare (not that it should be needed, but in any case).
  • Tweaked with CNAME and A entries (like the sentora.mydomain.com, same problem).
Note:
Previously I've added subdomains like this and they worked without any issue. I've cleaned my Ubuntu VPS and made a fresh Sentora Install and have setup everything according to the Sentora Guide.

Can anyone try to help me? Thank You!
My Sentora Resources
[Module] Mail Quota Count | Vagrant Box with Sentora

[Image: vanguardly-logo-micro.png]
Graphic and Web Design. Development.
www.vanguardly.com


Reply
Thanks given by:
#2
RE: Sub-Domain not Working with CloudFlare DNS
NOT TRUE subdomains on cloudflare works fine with sentora/zpanel. Never had a problem once I correctly setup the dns entries enabled or not the CDN mode!

mod_cloudflare will only forward real ip to apache logs nothing else! stop rushing in all directions.

If you enable cache mode that means cloudflare will proxy the request toward your server. Then it might be a routing issue ( cloudflare unable to fetch the page) also you need to check your logs to see if cloudflare is hitting your server or not.

This is not a sentora issue as I said before as we use stack apache.

Also check your firewall or if you have custom .htaccess or any routine to prevent hackers.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by: apinto
#3
RE: Sub-Domain not Working with CloudFlare DNS
Hello Me.B Thank You for your reply.
I've checked firewall and htaccess, nothing wrong.

I've fixed the problem after a few hours of looking.
It seems CloudFlare was not replying to DNS requests, It got solved after I added a CNAME for the www subdomain instead for the main domain.

DNS is something I'm not very experienced with, and I just posted my request here because I thought someone had the same problem.

I know subdomains WORK with Sentora (I've said it did worked on previous installs).
Also mod_cloudflare was installed due to the real IP logs, I also said it should not had any impact.
My Sentora Resources
[Module] Mail Quota Count | Vagrant Box with Sentora

[Image: vanguardly-logo-micro.png]
Graphic and Web Design. Development.
www.vanguardly.com


Reply
Thanks given by:
#4
RE: Sub-Domain not Working with CloudFlare DNS
Glad to see it's fixed.

Take care with cnames, they don't always work fine ( in some cases you can't use them).

Best solution as you said here is checking cloudflare DNS response & ensure the DNS entry works already.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS
Reply
Thanks given by: apinto
#5
RE: Sub-Domain not Working with CloudFlare DNS
Thank you Me.B, as always, great support from the Sentora Team Smile
My Sentora Resources
[Module] Mail Quota Count | Vagrant Box with Sentora

[Image: vanguardly-logo-micro.png]
Graphic and Web Design. Development.
www.vanguardly.com


Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
Public_html Inside Domain/Subdomain zHostingSolutions 2 4 ,505 07-23-2021, 09:57 AM
Last Post: Nigel
Cannot Create 2nd 'Addon' Domain In Sentora? Error: Invalid backend configuration. Re BattlinThrough 2 5 ,878 07-07-2020, 01:22 PM
Last Post: TGates
How To Add Letsencrypt SSL certificate To Domain Centos 7 franselect 1 4 ,363 07-04-2020, 02:55 AM
Last Post: Feilding Weather

Forum Jump:


Users browsing this thread: 1 Guest(s)