This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Wordpress "Temp Folder Missing" Issue
Wordpress "Temp Folder Missing" Issue
Hey wonderful web-masters out there,

I'm running into an issue that I need help with.  I'm running into the classic "Temp Folder Missing" issue oh so prevelant on misconfigured wordpress sites.  But its deeper than this issue..  All of my wordpress sites are unable to upload media via the PHP script uploader included in wordpress so it has to be an issue on the server, not just the site.

I've tried defining the temp folder in the wp-config.php file.  (source:, I've tried moving the temp directory to a different area, including outside of the root "public_html" folder and setting it to 777 permissions.  None of this has made a difference.

The trigger for this issue came about during an upgrade to PHP 5.6 a few weeks back for a certain wordpress plugin (the snapshots are long gone at this point, so no rolling it back).  PHP 5.3.20 is uninstalled currently to the best of my knowledge.  I would like to keep 5.6 if possible, its working fine, other than the single temp folder issue on media upload.

At some point I also touched the Suhosin flags in the php.ini file, so if anyone would be so kind as to go into their apache module admin and copy/paste me the default suhosin values for veritual host blacklisting commands, that would be greatly appreciated.

Any help navigating this issue would be amazing.  I'm very lost as to what is blocking me from being able to upload files, or what is misdirecting them away from a working temp directory.


-Nick Huntley
Challenge Media Group
Thanks given by:
RE: Wordpress "Temp Folder Missing" Issue
The suhosin values are actually in the database x_settings line: 82

php_admin_value suhosin.executor.func.blacklist "passthru, show_source, shell_exec, system, pcntl_exec, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, escapeshellarg, exec"
The temp folder can not be outside of the domain's folder. (ie: /var/sentora/hostdata/[username]/public_html/[domain.tld] or you have to change wordpress to use the default temp folder: /var/sentora/temp/
-TGates - Project Council

SEARCH the Forums or read the DOCUMENTATION before posting!
Support Sentora and Donate: HERE

Find my support or modules useful? Donate to TGates HERE
Developers and code testers needed!
Contact TGates for more information
Thanks given by:
RE: Wordpress "Temp Folder Missing" Issue
@ NickNeverSleeps

You are correct saying it's a server side issue. I had the same problem with one of my Wordpress sites on my new server. You can fix this by changing the following values in your php.ini for the Sentora. The file size wasn't set large enough to accept the file I was trying to upload. Not sure why WordPress shows its a temp folder issue because that's not the issue at all. (Mine showed the same error)

Don't go crazy with these settings but change them to what you need them to be.

You can find the Sentora file directories....

You need to edit the following files in the php.ini....


You need to also turn off "Open Base Dir". Here's how you can do this.....
  • GoTo Module Admin > Apache Config
  • Under "Override A Virtual Host Setting" select your domain.
  • Click the Select Vhost button
  • Now uncheck the "OpenBase Enabled" option.
  • Restart apache
  • Smile! It's Fixed! Note: Pay attention to the file sizes so you know how you need to set the above settings.

Hope this helps.  Big Grin
Thanks given by: NickNeverSleeps
RE: Wordpress "Temp Folder Missing" Issue
I've been poking at this issue for weeks trying to find different solutions, but this one did it! I had changed a setting in wordpress to allow 4GB files, but apparently it was still wrong on the main PHP.ini. Thanks for the help!!
Thanks given by:
RE: Wordpress "Temp Folder Missing" Issue
No problem, glad I could get you going.  Cool
Thanks given by:
RE: Wordpress "Temp Folder Missing" Issue
Good morning,
I'm also having the same issue, i've changed the /etc/php5/apache2/php.ini
changed the "Now uncheck the "OpenBase Enabled" option."

And still got the issue.
I've also updated to php 5.6.

I'm missing any parameter .. ?
I did not changed my wp-config with the define wp_temp directory .
Thanks given by:

Possibly Related Threads…
Thread Author Replies Views Last Post
Old issue on Daily Backup iraqiboy90 24 115 ,213 12-26-2020, 12:48 PM
Last Post: conglynina
unable to install wordpress or joomla using sentastico king4m 1 5 ,695 04-10-2020, 07:55 AM
Last Post: TGates
Security issue urgent johnnyp 7 13 ,935 02-27-2020, 06:19 PM
Last Post: johnnyp

Forum Jump:

Users browsing this thread: 1 Guest(s)