This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Killed apache trying to follow guide to enable SSL
#1
Killed apache trying to follow guide to enable SSL
Hi I was reading one of the guides on this forum on how to enable SSL and I did exactly what they told me to do, and after I did that and restarted apache, my apache will not turn on anymore.

I have tried to undo the changes but no luck so far and I am very displeased and unhappy about the terrible experience sentora gives to edit config files to enable ssl... all I tried was to enable SSL...

Anyway what I did was the following,
http://forums.sentora.org/showthread.php?tid=994

I went to nano /etc/sentora/configs/apache/httpd.conf
and i edited that and added,
<IfModule ssl_module>
Listen 443
</IfModule>


After I done that I restarted apache2 and now my apache won't start anymore saying,
root@vps1:/etc/sentora/configs/apache# sudo service apache2 restart
* Restarting web server apache2 no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

Angry What do I do to fix htis? I removed the code I added earlier but it won't help me at all... I can't restart my apache and I am out of an idea what to do now..


Some information:
I read on the internet and asked some people on IRC, they gave me this, http://wiki.apache.org/httpd/CouldNotBindToAddress
I tried to do the following command,
root@vps1:/etc/sentora/configs/apache# sudo lsof -i:80
root@vps1:/etc/sentora/configs/apache#

The output of that is 0, so I tried other things but nothing so far.

These are my /etc/sentora/configs/apache files:
http://paste.ubuntu.com/10173834/ httpd.conf
I tried to remove the include but that didn't work either... I really don't know what to do now? Tongue
Reply
Thanks given by:


Messages In This Thread
Killed apache trying to follow guide to enable SSL - by SupaYoshi - 02-12-2015, 12:25 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
Sentora & Apache behind Nginx Reverse Proxy Feilding Weather 7 11 ,365 08-06-2021, 02:58 PM
Last Post: ccr1969
How to run multiple version PHP with Apache (use Sentora panel) on Centos ??? BigBang 4 6 ,411 12-23-2020, 03:31 PM
Last Post: djkashdui1
Install guide wget over http? edavidf 5 7 ,804 12-15-2020, 07:07 PM
Last Post: jibranahmed

Forum Jump:


Users browsing this thread: 1 Guest(s)