This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Killed apache trying to follow guide to enable SSL
Killed apache trying to follow guide to enable SSL
Hi I was reading one of the guides on this forum on how to enable SSL and I did exactly what they told me to do, and after I did that and restarted apache, my apache will not turn on anymore.

I have tried to undo the changes but no luck so far and I am very displeased and unhappy about the terrible experience sentora gives to edit config files to enable ssl... all I tried was to enable SSL...

Anyway what I did was the following,

I went to nano /etc/sentora/configs/apache/httpd.conf
and i edited that and added,
<IfModule ssl_module>
Listen 443

After I done that I restarted apache2 and now my apache won't start anymore saying,
root@vps1:/etc/sentora/configs/apache# sudo service apache2 restart
* Restarting web server apache2 no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

Angry What do I do to fix htis? I removed the code I added earlier but it won't help me at all... I can't restart my apache and I am out of an idea what to do now..

Some information:
I read on the internet and asked some people on IRC, they gave me this,
I tried to do the following command,
root@vps1:/etc/sentora/configs/apache# sudo lsof -i:80

The output of that is 0, so I tried other things but nothing so far.

These are my /etc/sentora/configs/apache files: httpd.conf
I tried to remove the include but that didn't work either... I really don't know what to do now? Tongue
Thanks given by:
RE: Killed apache trying to follow guide to enable SSL
Solved, removed the line Listen 80 from the entire httpd-vhosts.conf thanks for the help
Thanks given by:
RE: Killed apache trying to follow guide to enable SSL
But when you add or remove domains or subdomains, the problem will come back.
For the file httpd-vhosts.conf will be updated.
Thanks given by:
RE: Killed apache trying to follow guide to enable SSL
Thanks I was able to update the config file after fixing it so the error won't come back. Thanks for the help.
Thanks given by:

Possibly Related Threads…
Thread Author Replies Views Last Post
Sentora & Apache behind Nginx Reverse Proxy Feilding Weather 7 14 ,461 08-06-2021, 02:58 PM
Last Post: ccr1969
How to run multiple version PHP with Apache (use Sentora panel) on Centos ??? BigBang 4 8 ,432 12-23-2020, 03:31 PM
Last Post: djkashdui1
Install guide wget over http? edavidf 5 10 ,191 12-15-2020, 07:07 PM
Last Post: jibranahmed

Forum Jump:

Users browsing this thread: 1 Guest(s)