This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Request: Ubuntu 14.04 support
#41
[Not Solved] RE: Request: Ubuntu 14.04 support
I agree with Kevin, Some users aren't using the panel for 'open' hosting but for their own development and personal web sites hosted from home or a VPS. A warning or notice should be put in place instead of a 'stop'. There are thousands of people attempting hosting with a plain wamp or lamp stack and no panel, why not at least provide them with a better solution Wink
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#42
[Not Solved] RE: Request: Ubuntu 14.04 support
@Kandrews we should revamp security in zpanel/sentora here... Each time we say the last release is free of any bugs. What's the issue now? Why we don't move proactive. For my self an my own setup I see zsudo a major threat and it could be replaced without big problems and better jailing. This might mean some pain and forking some tools from linux to windows but we already do that for mail/ftp...

We should ensure any intrusion get contained and don't see hackers gaining root in 5s once the are in. Also /etc/app is crap to run with the panel high privilege. Instead of jailing them any issue in roundcube/phpmyadmin would blow out the server and it happened. Also modules are being used beyond the framework and it's BAD and odd...

Solutions exist and we can build them and we need to push more in that direction and this is my goal here trying to help with my best.
M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by: iTpain
#43
[Not Solved] RE: Request: Ubuntu 14.04 support
Me.B i agree however we need to focus on getting a stable release out before too many people install while we are developing and fixing zpanel to sentora...

I think we should scheduled a code review and infrastructure/stack review for the next release (1.1). Can you raise this on the To-Do list?
Reply
Thanks given by:
#44
[Not Solved] RE: Request: Ubuntu 14.04 support
Agree Kevin... main focus now is Sentora 1.x with few fixes/rebranding but I'm talking about sentora 1.1 or 1.2 so we can have a clean road map and targets and thus split better the tasks and prepare tests/releases.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by:
#45
[Not Solved] RE: Request: Ubuntu 14.04 support
Once 1.0 is out I'll setup a team meeting and we can all recommend tasks, then I'll get the tasks into github with roadmaps assigned Smile We should definitely start using roadmaps as it gives clear view on what is coming up and what features will be released Smile
Reply
Thanks given by:
#46
[Not Solved] RE: Request: Ubuntu 14.04 support
5050

http://forums.sentora.org/showthread.php...42#pid2442

Ubuntu entered in infinite loop over FQDN..... Had to remove the test.
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by: iTpain
#47
[Not Solved] RE: Request: Ubuntu 14.04 support
Please disable fqdn request or make it optional
Reply
Thanks given by:
#48
[Not Solved] RE: Request: Ubuntu 14.04 support
Code:
ATTENTION: An error has occured. More info is in the syslog!
/var/lib/dpkg/info/mysql-server-5.5.postinst: line 236: logger: command not found
dpkg: error processing package mysql-server-5.5 (--configure):
subprocess installed post-installation script returned error exit status 127
Setting up libsasl2-modules:i386 (2.1.25.dfsg1-17build1) ...
Setting up libhtml-template-perl (2.95-1) ...
Setting up libpq5 (9.3.5-0ubuntu0.14.04.1) ...
Setting up libsasl2-modules-sql:i386 (2.1.25.dfsg1-17build1) ...
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
 Package mysql-server-5.5 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-0ubuntu6.3) ...
Errors were encountered while processing:
mysql-server-5.5
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
start: Job failed to start


Error seen in VPS as MySQL failed in installing here. Will try to force install manually to finish sentora install.

Manual install fail as we got error same as:

http://askubuntu.com/questions/292865/up...rver-issue
Code:
Setting up mysql-server-5.5 (5.5.38-0ubuntu0.14.04.1) ...
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76.)
debconf: falling back to frontend: Readline
/var/lib/dpkg/info/mysql-server-5.5.postinst: line 146: logger: command not found
ATTENTION: An error has occured. More info is in the syslog!
/var/lib/dpkg/info/mysql-server-5.5.postinst: line 236: logger: command not found
dpkg: error processing package mysql-server-5.5 (--configure):
subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
 Package mysql-server-5.5 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mysql-server-5.5
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried removing all mysql packages/ and cleaning repos nothing working here on this VPS.

Still unable to install mysql. And we got a conflict over FQDN... hmmm iTpain

On standard ubuntu system there is nothing preventing mysql to install. The issue is for sure in your OS setup. Try to install mysql:

sudo apt-get install mysql-server

And you will see the errors.

We can't help more here as we need mysql setup.
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Issue in the Samsung interface? Find support from Samsung support number. monktech 0 12 6 hours ago
Last Post: monktech
Ubuntu 18.04 vaxition 1 379 08-06-2020, 11:03 AM
Last Post: Jettaman
Php5.6 on ubuntu possible? lorenaustin 0 353 06-11-2020, 01:01 AM
Last Post: lorenaustin

Forum Jump:


Users browsing this thread: 1 Guest(s)