This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Need Urgent Help !!!
[Not Solved] Need Urgent Help !!!
It was working unless I added two new domains which didn't go live for more than 3 hours so I decided to run the daemon manually but when I run the following 

php -q /etc/zpanel/panel/bin/daemon.php

I get the error below, please help I am not able to host any more websites on my VPS.
php -q /etc/zpanel/panel/bin/daemon.php
PHP Warning:  chdir(): open_basedir restriction in effect. File(/etc/zpanel/panel/) is not within the allowed path(s): (/var/zpanel/hostdata/zadmin/) in /etc/zpanel/panel/bin/daemon.php on line 16
PHP Warning:  require_once(): open_basedir restriction in effect. File(dryden/ is not within the allowed path(s): (/var/zpanel/hostdata/zadmin/) in /etc/zpanel/panel/bin/daemon.php on line 18
PHP Warning:  require_once(dryden/ failed to open stream: Operation not permitted in /etc/zpanel/panel/bin/daemon.php on line 18
PHP Fatal error:  require_once(): Failed opening required 'dryden/' (include_path='.:/usr/share/pear:/usr/share/php') in /etc/zpanel/panel/bin/daemon.php on line 18
Thanks given by:
[Not Solved] RE: Need Urgent Help !!!
You messed up with your default settings for sure.

Did you try to follow some bright guides how to change your open_basedir defaults?

No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Thanks given by:
[Not Solved] RE: Need Urgent Help !!!
Yes, this smells like you changes something in your open_basedir lists.
I'm looking at my httpd-chosts.conf file and there is no basedir directive for panel's virtual host. So what you probably need to do is remove open_basedir for your sentoras vhost, reset apache and it should work.

So, go to etc/zpanel/configs/apache
edit httpd-vhosts.conf and check OpenBasedir directives in first <VirtualHost *:80> entry (first one should be panel's vhost). If it's not for some wierd reason, find it and remove line that looks like:
php_admin_value open_basedir "/var/zpanel/hostdata/USER/public_html/DOMAIN:/var/zpanel/temp/ etc."
Thanks given by:

Possibly Related Threads...
Thread Author Replies Views Last Post
Security issue urgent johnnyp 7 2 675 02-27-2020, 06:19 PM
Last Post: johnnyp
Urgent: Accidentally deleted httpd-vhosts.conf file any one have this file pls share nscloud 4 3 738 10-20-2017, 04:43 AM
Last Post: Me.B
[FIXED] Urgent Problems with Subdomains | Cinfu Host JimKnopf 7 7 380 06-12-2017, 09:20 AM
Last Post: JimKnopf

Forum Jump:

Users browsing this thread: 1 Guest(s)