This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[MODULE] xBilling
[Solved] RE: xBilling [MODULE]
(10-27-2015, 05:10 PM)TGates Wrote:
(10-27-2015, 12:36 PM)coitam Wrote:
(10-23-2015, 02:37 AM)TGates Wrote: I still have not gotten this to work yet. Will post when I do Wink

I have a next question:
does module whmcs have any error??

No idea, never tried. Besides, this is an xBilling support forum Wink

modpluz, hey Remmy! I also have an issue with receiving the emails (Ubuntu 14.04) although I am more interested in how the new/renewed/reactivated client account gets activated after successful payment? Currently, after payment is made, the invoice is not marked paid and the client is not activated.

Where in the code is the 'ClientEnable' function? I do not see it anywhere Sad

Not specifically for you Tgates, but you just reminded me...

One thing I would like to point out on the account activation side of things is to make sure that the e-mail address you are using for your PayPal is the primary e-mail address and you are using it for your xBilling as when I was trying to fix my issues I noted that the IPN listener PHP file listens for PayPal to return the same business e-mail as listed in the xBilling config which might not happen if it's not the primary e-mail account in your PayPal, causing it to not activate the account and to not send out the e-mails.

For example:

In PayPal:
yourname@gmail.com (Primary)
payments@hostingservice.com (Secondary)


A client makes a payment to "payments@hostingservice.com" using your xBilling page.
You get PayPal's e-mail telling you you've received a payment at that e-mail address.
HOWEVER...
PayPal will send only the primary e-mail from your PayPal account to the IPN listener, "yourname@gmail.com" and as the IPN listener is looking for a match it will result in xBilling saying that the invoice is "unpaid" and no e-mails will be sent out.

This is the part of the line I am referring to in the IPN listener:

PHP Code:
if($payment_fields['business_email'] == $receiver_email 

I hope this helps someone, somewhere, at some point! haha Smile
My geeky side: thefuzz.xyz | Photo & Video: fuzzymannerz.co.uk
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Interesting! Will check my email on PayPal Wink

Yep, primary email is being used...

Maybe modpluz could put a check in there to echo an error if the email doesn't match primary Wink
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Hi,

I am still trying to figure out this issue as well.

In reference to the error log.
Nov 11 02:13:50 vps postfix/smtpd[11177]: connect from unknown[122.154.46.172]
Nov 11 02:13:53 vps postfix/smtpd[11177]: warning: unknown[122.154.46.172]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Nov 11 02:13:53 vps postfix/smtpd[11177]: disconnect from unknown[122.154.46.172]

Nov 10 19:24:06 vps postfix/smtpd[12743]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 454 4.7.1 <email@gmail.com>: Relay access denied; from=<apache@localhost.localdomain> to=<email@gmail.com> proto=ESMTP helo=<localhost.localdomain>

Not sure if this helps spread any light on the issue.
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Hello,
I've got a couple of major problems with XBilling module.

1. In the 'Website Settings' tab after replacing all of the details with my own and when I press save, it redirects me somewhere and does not save the settings.

2. In the 'Plans' tab after creating a service plan, adding the amount etc. redirects me to .../?module=xbilling&action=CreatePeriod and does not create a Service Plan.

3. When I edit anything in the xBilling module, it redirects me to some page with an error and does not save the edited part.

Is there any way to fix that? Thank you.
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
I have working xbilling plugin with some fixes and integrations. If you need send me in PM

Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(11-26-2015, 07:39 AM)Samuel Wrote: Hello,
I've got a couple of major problems with XBilling module.

1. In the 'Website Settings' tab after replacing all of the details with my own and when I press save, it redirects me somewhere and does not save the settings.

2. In the 'Plans' tab after creating a service plan, adding the amount etc. redirects me to .../?module=xbilling&action=CreatePeriod and does not create a Service Plan.

3. When I edit anything in the xBilling module, it redirects me to some page with an error and does not save the edited part.

Is there any way to fix that? Thank you.

I second these issues.
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
How am i able to edit the .htaccess in /etc/panel with ubuntu server and terminal. Tried using google to help me find the answer but nothing
Thanks, 
Liam Green ~ Asenav.co.uk
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(10-09-2015, 03:10 PM)coitam Wrote: Sorry but who can fix error of mine this is
my site still error "Problem reading data from http://webhost.ddns.net/api/xbilling". Please help me!

the data do ready from /modules/xbilling???
but i change the line  -  $full_wsurl = $this->wsurl . "/modules/" . $this->module;  -  in the file  - xmwsclient.class.php  -  and still it did not work

@modpluz
Maybe you could help me please with the connection between the frontend and backend
this is my list check:
apikey it's working
.htaccess, php.ini and confing.php they are well configured

Although I read that Mail Quota Count generates conflicts, but I have not wanted to clear for fear that I remove some configuration
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Then I try to submit something in the module I got a page 500, how do I fix that?

Running Ubuntu server
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
I am getting same error "Problem reading data from http://url.shoutme.xyz/api/xbilling", every thing is configured well, fopen() is enabled, help me out!!
Hosting, Small Business and Affiliate Marketing Discussion board.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
[MODULE][WIP] Sencrypt Let's Encrypt SSL Module TGates 45 48 558 09-11-2020, 09:10 AM
Last Post: TGates
My temporary module repo TGates 0 482 09-11-2020, 08:58 AM
Last Post: TGates
[Module] Whois jollyjoke 3 5 433 02-03-2020, 02:04 AM
Last Post: jollyjoke

Forum Jump:


Users browsing this thread: 1 Guest(s)