This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[MODULE] xBilling
[Solved] RE: xBilling [MODULE]
i send message for modpluz in this forum but not yet reply for me. i upgraded xbillng-front end new but it still error Problem reading data from http://webhost.ddns.net/api/xbilling, can you help me?
Maybe API error because i install whmcs, whmcs site can't add user because error API. But I can't repair it.
sorry about my English
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
WHMCS module conflicts with module Mail-Quota-Count
If you want to install this module WHMCS, remove the module Mail-Quota-Count.
If you installed module mail-quota-count and module whmcs, you see message
"Account couldn't be created, the API Request failed."
Reply
Thanks given by: coitam
[Solved] RE: xBilling [MODULE]
Thank for reply
But i haven't got module Mail-Quota-Count. My module:
Aliases
Apache Config
AutoIP Updater
Backup
Backup Config
Change Password
Client Notice Manager
Cron Manager
Distribution Lists
DNS Config
DNS Manager
Domains
FAQ's
Forwards
FTP Accounts
FTP Config
Mail Config
Mailboxes
Manage Clients
Manage Groups
Module Admin
My Account
MySQL Database
MySQL Users
Package Manager
Parked Domains
PHPInfo
phpMyAdmin
phpSysInfo
Protected Directories
Sentora Config
Sentora News
Service Status
Shadowing
Sub Domains
Theme Manager
Updates
Usage Viewer
Webalizer Stats
WebMail
WHMCS
xBilling
So, what must I remove module?
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
You do not have such a module...
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
You are using ZPanel 10.1.1 or Sentora 1.0?

If you are using ZPanel 10.1.1 try this module
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(08-26-2015, 04:04 AM)BBuchanan Wrote:
(08-25-2015, 06:51 AM)zustudios Wrote: I have xbilling working good so far with testing.I just have one major problem.xbilling wont send any emails.Can anyone tell me the solution?
centos 6
sentora 1.0.0

 I know the free packages don't send emails...anyone else confirm this? 

Also a quick question, the ipn url is the ipn_listener.php right?

I just installed sentora 1.0.3 on centos 7 I will let you know if the mail works for xbilling.
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(09-26-2015, 10:57 PM)darkrisingx Wrote: Installed on a test system to see what the results was here is my findings.

Each load of invoices page logs errors.

[Sat Sep 26 08:50:36.727805 2015] [:error] [pid 27804] [client ***] PHP Notice:  Undefined index: error in /var/sentora/hostdata/zadmin/public_html/***/functions/xbilling.php on line 150
[Sat Sep 26 08:50:36.733701 2015] [:error] [pid 27804] [client *] PHP Notice:  Undefined index: invoice in /var/sentora/hostdata/zadmin/public_html/***/functions/xbilling.php on line 244

Paypal method seems to be broken.


Code:
<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <input type="hidden" name="cmd" value="_xclick">
    <input type="hidden" name="business" value="***">
    <input type="hidden" id="payment_method_id" name="custom" value="1">
    <input type="hidden" name="lc" value="{{country_code}}">
    <input type="hidden" name="item_name" value="{{invoice_desc}}">
    <input type="hidden" name="amount" value="{{invoice_amount}}">
    <input type="hidden" name="invoice" value="{{invoice_id}}">
    <input type="hidden" name="currency_code" value="{{currency}}">
    <input type="hidden" name="discount_rate" value="{{discount_rate}}">
    <input type="hidden" name="notify_url" value="***">
    <input type="hidden" name="button_subtype" value="services">
    <input type="hidden" name="bn" value="PP-BuyNowBF:btn_paynowCC_LG.gif:NonHosted">
    <input type="image" src="https://www.paypal.com/en_US/i/btn/btn_paynowCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
    <img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1">
</form>

Seems that the values are not being replaced with the correct values error on my part maybe ? business and notify_url are however replaced correctly.

Tongue

For everyone having this issue, it is now resolved. Please download the frontend package again from xBilling Admin.

Respective source codes have also be updated on Github.
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(10-03-2015, 03:11 PM)modpluz Wrote: For everyone having this issue, it is now resolved. Please download the frontend package again from xBilling Admin.

Respective source codes have also be updated on Github.

Can confirm issue has be fixed. Thanks
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(10-03-2015, 03:11 PM)modpluz Wrote: For everyone having this issue, it is now resolved. Please download the frontend package again from xBilling Admin.

Respective source codes have also be updated on Github.

I upgraded front-end site on Github (https://github.com/modpluz/xbilling-frontend) but my site still error "Problem reading data from http://webhost.ddns.net/api/xbilling". Please help me!
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(10-04-2015, 01:14 PM)coitam Wrote:
(10-03-2015, 03:11 PM)modpluz Wrote: For everyone having this issue, it is now resolved. Please download the frontend package again from xBilling Admin.

Respective source codes have also be updated on Github.

I upgraded front-end site on Github (https://github.com/modpluz/xbilling-frontend) but my site still error "Problem reading data from http://webhost.ddns.net/api/xbilling". Please help me!

That's not the issue I was referring to. Yours is a different issue that has nothing to do with xBilling but your setup/installation. Thanks
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
[Module] Whois jollyjoke 3 4 644 02-03-2020, 02:04 AM
Last Post: jollyjoke
[Module] Module updates jollyjoke 6 8 081 02-03-2020, 02:03 AM
Last Post: jollyjoke
Updated module and theme repo 2018 zustudios 3 3 074 12-24-2019, 08:07 AM
Last Post: zustudios

Forum Jump:


Users browsing this thread: 1 Guest(s)