This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[MODULE] xBilling
[Solved] RE: xBilling [MODULE]
(08-26-2015, 04:04 AM)BBuchanan Wrote: I know the free packages don't send emails...anyone else confirm this? 

Also a quick question, the ipn url is the ipn_listener.php right?

1-Not confirmed.

2-yes.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by: BBuchanan
[Solved] RE: xBilling [MODULE]
My error:
array(4) { ["type"]=> int(2) ["message"]=> string(113) "fopen(http://webhost.ddns.net/api/xbilling): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found " ["file"]=> string(69) "/var/sentora/hostdata/zadmin/public_html/classes/xmwsclient.class.php" ["line"]=> int(112) } Problem reading data from http://webhost.ddns.net/api/xbilling.
and i can't find Public key and Private Key in setting of xbilling.
Please help me!!
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
A search would have helped you find: http://forums.sentora.org/showthread.php?tid=791
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(09-23-2015, 03:35 PM)TGates Wrote: A search would have helped you find: http://forums.sentora.org/showthread.php?tid=791

But this is my etc/php.ini


; Maximum allowed size for uploaded files.
; http://www.php.net/manual/en/ini.core.ph...x-filesize
upload_max_filesize = 200M

;;;;;;;;;;;;;;;;;;
; Fopen wrappers ;
;;;;;;;;;;;;;;;;;;

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
; http://www.php.net/manual/en/filesystem....-url-fopen
allow_url_fopen = On

; Whether to allow include/require to open URLs (like http:// or ftp://) as files.
; http://www.php.net/manual/en/filesystem....rl-include
allow_url_include = Off


what's happended?
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Please help me
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Ok, there is another related to this that has to do with an improper .htaccess file in the /panel/ folder. I'll see if I can dig it up.

Make sure the .htaccess file in /etc/panel/ contains the following and that mod_rewrite is enabled in php.ini:
Code:
# Standard Sentora Rewrite Ruleset
RewriteEngine on
RewriteRule ^api/([^/\.]+)/?$ bin/api.php?m=$1 [L]
RewriteRule ^apps/([^/\.]+)/?$ etc/apps/$1 [L]
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
(09-24-2015, 01:54 AM)TGates Wrote: Ok, there is another related to this that has to do with an improper .htaccess file in the /panel/ folder. I'll see if I can dig it up.

Make sure the .htaccess file in /etc/panel/ contains the following and that mod_rewrite is enabled in php.ini:
Code:
# Standard Sentora Rewrite Ruleset
RewriteEngine on
RewriteRule ^api/([^/\.]+)/?$ bin/api.php?m=$1 [L]
RewriteRule ^apps/([^/\.]+)/?$ etc/apps/$1 [L]

And this is my .htaccess:
Code:
# Standard Sentora Rewrite Ruleset
RewriteEngine on
RewriteRule ^api/([^/\.]+)/?$ bin/api.php?m=$1 [L]
RewriteRule ^apps/([^/\.]+)/?$ etc/apps/$1 [L]
 it's OK, but xblilling front-end still not work. please check with me!!!
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Please help me. i verry like and want this module but i not use.
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
modpluz made the module, so maybe he will stop by and help you better Smile
I know he has been busy lately, but he should get a notice and stop by.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
[Solved] RE: xBilling [MODULE]
Installed on a test system to see what the results was here is my findings.

Each load of invoices page logs errors.

[Sat Sep 26 08:50:36.727805 2015] [:error] [pid 27804] [client ***] PHP Notice:  Undefined index: error in /var/sentora/hostdata/zadmin/public_html/***/functions/xbilling.php on line 150
[Sat Sep 26 08:50:36.733701 2015] [:error] [pid 27804] [client *] PHP Notice:  Undefined index: invoice in /var/sentora/hostdata/zadmin/public_html/***/functions/xbilling.php on line 244

Paypal method seems to be broken.


Code:
<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <input type="hidden" name="cmd" value="_xclick">
    <input type="hidden" name="business" value="***">
    <input type="hidden" id="payment_method_id" name="custom" value="1">
    <input type="hidden" name="lc" value="{{country_code}}">
    <input type="hidden" name="item_name" value="{{invoice_desc}}">
    <input type="hidden" name="amount" value="{{invoice_amount}}">
    <input type="hidden" name="invoice" value="{{invoice_id}}">
    <input type="hidden" name="currency_code" value="{{currency}}">
    <input type="hidden" name="discount_rate" value="{{discount_rate}}">
    <input type="hidden" name="notify_url" value="***">
    <input type="hidden" name="button_subtype" value="services">
    <input type="hidden" name="bn" value="PP-BuyNowBF:btn_paynowCC_LG.gif:NonHosted">
    <input type="image" src="https://www.paypal.com/en_US/i/btn/btn_paynowCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
    <img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1">
</form>

Seems that the values are not being replaced with the correct values error on my part maybe ? business and notify_url are however replaced correctly.

Tongue
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
(Idea) Reminder module bbspike 3 2 805 12-05-2020, 05:04 PM
Last Post: Nigel
[MODULE][WIP] Sencrypt Let's Encrypt SSL Module TGates 45 51 963 09-11-2020, 09:10 AM
Last Post: TGates
My temporary module repo TGates 0 819 09-11-2020, 08:58 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)