This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[MODULE] xBilling
#61
[Solved] RE: xBilling [MODULE]
shoot...it should be "log" and not "logs"
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:
#62
[Solved] RE: xBilling [MODULE]
(01-28-2015, 08:43 PM)modpluz Wrote: shoot...it should be "log" and not "logs"

No Sad 
Code:
tail -f /var/log/apache2/error.log
tail: cannot open ‘/var/log/apache2/error.log’ for reading: No such file or directory
tail: no files remaining

Would it be /var/log/httpd/error_log?
--- Eclectic Digital ---
--- Aled Evans ---
Reply
Thanks given by:
#63
[Solved] RE: xBilling [MODULE]
(01-28-2015, 10:21 PM)aled2305 Wrote:
(01-28-2015, 08:43 PM)modpluz Wrote: shoot...it should be "log" and not "logs"

No Sad 

Code:
tail -f /var/log/apache2/error.log
tail: cannot open ‘/var/log/apache2/error.log’ for reading: No such file or directory
tail: no files remaining

Would it be /var/log/httpd/error_log?

On RHEL/CentOS, yes
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:
#64
[Solved] RE: xBilling [MODULE]
(01-28-2015, 10:27 PM)modpluz Wrote: On RHEL/CentOS, yes

Okay so this is what I got...

Code:
tail -f /var/log/httpd/error_log
[Tue Jan 27 15:30:01.684720 2015] [mpm_prefork:notice] [pid 451] AH00171: Graceful restart requested, doing restart
[Tue Jan 27 15:30:01.802003 2015] [auth_digest:notice] [pid 451] AH01757: generating secret for digest authentication ...
[Tue Jan 27 15:30:01.802715 2015] [lbmethod_heartbeat:notice] [pid 451] AH02282: No slotmem from mod_heartmonitor
[Tue Jan 27 15:30:01.875570 2015] [mpm_prefork:notice] [pid 451] AH00163: Apache/2.4.6 (CentOS) configured -- resuming normal operations
[Tue Jan 27 15:30:01.875590 2015] [core:notice] [pid 451] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
[Tue Jan 27 16:35:01.546805 2015] [mpm_prefork:notice] [pid 451] AH00171: Graceful restart requested, doing restart
[Tue Jan 27 16:35:01.741272 2015] [auth_digest:notice] [pid 451] AH01757: generating secret for digest authentication ...
[Tue Jan 27 16:35:01.743909 2015] [lbmethod_heartbeat:notice] [pid 451] AH02282: No slotmem from mod_heartmonitor
[Tue Jan 27 16:35:01.794486 2015] [mpm_prefork:notice] [pid 451] AH00163: Apache/2.4.6 (CentOS) configured -- resuming normal operations
[Tue Jan 27 16:35:01.794506 2015] [core:notice] [pid 451] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
--- Eclectic Digital ---
--- Aled Evans ---
Reply
Thanks given by:
#65
[Solved] RE: xBilling [MODULE]
Hello @modpluz,
I'm getting the following issue : "Problem reading data from http://domain.tld/api/xbilling"
I checked php.ini and fopen() is currently ENABLED.
I didn't complete these fields in the xBilling module ( Public Key: Private Key: ).
Is it the reason? Where do I find such information?
Thank you!
Reply
Thanks given by:
#66
[Solved] RE: xBilling [MODULE]
(01-29-2015, 04:17 AM)andream Wrote: Hello @modpluz,
I'm getting the following issue : "Problem reading data from http://domain.tld/api/xbilling"
I checked php.ini and fopen() is currently ENABLED.
I didn't complete these fields in the xBilling module ( Public Key: Private Key: ).
Is it the reason? Where do I find such information?
Thank you!

this usually has to do with the .htaccess file in /etc/panel/ folder. It should have this in it near the top:

PHP Code:
# Standard Sentora Rewrite Ruleset
RewriteEngine on
RewriteRule 
^api/([^/\.]+)/?$ bin/api.php?m=$[L]
RewriteRule ^apps/([^/\.]+)/?$ etc/apps/$[L
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by: modpluz , liamgreen
#67
[Solved] RE: xBilling [MODULE]
modpluz 

Any ideas on what's wrong with my setup... or should I just forget about it for now?

Thanks
--- Eclectic Digital ---
--- Aled Evans ---
Reply
Thanks given by:
#68
[Solved] RE: xBilling [MODULE]
(01-29-2015, 06:24 PM)aled2305 Wrote: @[modpluz] 

Any ideas on what's wrong with my setup... or should I just forget about it for now?

Thanks

Hi, I will only be able to look into your server over the weekend, I may need you to be available as well.
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:
#69
[Solved] RE: xBilling [MODULE]
(01-29-2015, 06:37 PM)modpluz Wrote:
(01-29-2015, 06:24 PM)aled2305 Wrote: @[modpluz] 

Any ideas on what's wrong with my setup... or should I just forget about it for now?

Thanks

Hi, I will only be able to look into your server over the weekend, I may need you to be available as well.

That would be great Smile 
--- Eclectic Digital ---
--- Aled Evans ---
Reply
Thanks given by:
#70
[Solved] RE: xBilling [MODULE]
(01-29-2015, 05:05 AM)TGates Wrote:
(01-29-2015, 04:17 AM)andream Wrote: Hello @modpluz,
I'm getting the following issue : "Problem reading data from http://domain.tld/api/xbilling"
I checked php.ini and fopen() is currently ENABLED.
I didn't complete these fields in the xBilling module ( Public Key: Private Key: ).
Is it the reason? Where do I find such information?
Thank you!

this usually has to do with the .htaccess file in /etc/panel/ folder. It should have this in it near the top:


PHP Code:
# Standard Sentora Rewrite Ruleset
RewriteEngine on
RewriteRule 
^api/([^/\.]+)/?$ bin/api.php?m=$[L]
RewriteRule ^apps/([^/\.]+)/?$ etc/apps/$[L

Im having this issue too, the only fix was to put the panel IP address in the server config in place of the panel URL. However, i just get the "API Error:" afterwards.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
[MODULE][WIP] Sencrypt Let's Encrypt SSL Module TGates 45 48 681 09-11-2020, 09:10 AM
Last Post: TGates
My temporary module repo TGates 0 487 09-11-2020, 08:58 AM
Last Post: TGates
[Module] Whois jollyjoke 3 5 436 02-03-2020, 02:04 AM
Last Post: jollyjoke

Forum Jump:


Users browsing this thread: 2 Guest(s)