This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[MODULE] xBilling
#21
[Not Solved] RE: xBilling [MODULE]
when i upload the xbilling frontend i get this message

Problem reading data from http://2talweb.com/xbilling_frontend/api/xbilling
i dont have dir named api and xbilling ?
Reply
Thanks given by:
#22
[Not Solved] RE: xBilling [MODULE]
(12-21-2014, 08:50 AM)2talweb Wrote: when i upload the xbilling frontend i get this message

Problem reading data from http://2talweb.com/xbilling_frontend/api/xbilling
i dont have dir named api and xbilling ?

2talweb, see this post: http://forums.sentora.org/showthread.php?tid=791 Smile
Reply
Thanks given by:
#23
[Not Solved] RE: xBilling [MODULE]
If you HAVEN'T the fopen() enabled and you don't enable this function for security reasons, you need change the fopen() function in /classes/xmwclient.class.php.
You need to replace this:
Code:
function PostRequest($url, $data, $optional_headers = null) {
        $params = array('http' => array(
                'method' => 'POST',
                'content' => $data
                ));
        if ($optional_headers !== null) {
            $params['http']['header'] = $optional_headers;
        }
        $ctx = stream_context_create($params);
        $fp = @fopen($url, 'rb', false, $ctx);
        if (!$fp) {
            die("Problem reading data from " . $url . "");
        }
        $response = @stream_get_contents($fp);
        //var_dump($response);
        if ($response == false) {
            die("Problem reading data from " . $url . "");
        }
        return $response;
    }
for this:
Code:
function PostRequest($url, $data, $optional_headers = null) {
    //Customizations for fopen() or curl()
    if (ini_get('allow_url_fopen') == true) {
         $params = array('http' => array(
            'method' => 'POST',
            'content' => $data
                ));
        if ($optional_headers !== null) {
            $params['http']['header'] = $optional_headers;
        }
            $ctx = stream_context_create($params);
        $fp = @fopen($url, 'rb', false, $ctx);
            if (!$fp) {
                die("Problem reading data from " . $url . "");
            }
            $response = @stream_get_contents($fp);
            //var_dump($response);
            if ($response == false) {
                die("Problem reading data from " . $url . "");
            }
            return $response;
    }
    else if (function_exists('curl_init')) {
        if ($optional_headers !== null) {
            $params = array('httpheader:'. $optional_headers);
        }
        else {
            $params = $optional_headers;
        }
        $curl = curl_init($url);
        curl_setopt($curl, CURLOPT_RETURNTRANSFER, 1);
        curl_setopt($curl, CURLOPT_POST, true);
        curl_setopt($curl, CURLOPT_POSTFIELDS, $data);
               @curl_setopt($curl, CURLOPT_HTTPHEADER, $params);
        $response = curl_exec($curl);
        curl_close($curl);
        return $response;
    }
    else {
               die("Problem reading data from " . $url . "");
    }
    }
to change the function.
I tested on my xBilling and this worked to me Smile
Reply
Thanks given by:
#24
[Not Solved] RE: xBilling [MODULE]
Hi All,
Please note that xBilling is now updated to be Sentora 1 compatible as well. Latest version  is 1.2.0

Upgrade your various installations(refer to first post for instructions).

As usual, request for support in this thread and report bugs on the github page.
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:
#25
[Not Solved] RE: xBilling [MODULE]
(01-02-2015, 07:12 PM)modpluz Wrote: Hi All,
Please note that xBilling is now updated to be Sentora 1 compatible as well. Latest version  is 1.2.0

Upgrade your various installations(refer to first post for instructions).

As usual, request for support in this thread and report bugs on the github page.

Hi modpluz, i've installed the updated xBilling version and i've enabled it for admin, reseller and user in the sentora's package manager, but when i go to [panel url]/?module=xbilling i see an empty blank page  Huh What can i do?  Sad
Reply
Thanks given by:
#26
[Not Solved] RE: xBilling [MODULE]
What does your log file say?
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:
#27
[Not Solved] RE: xBilling [MODULE]
(01-04-2015, 09:58 PM)modpluz Wrote: What does your log file say?
sentora-error.log
Code:
[Sun Jan 04 00:04:34.760302 2015] [:error] [pid 1636] [client 192.168.0.254:40068] script '/etc/sentora/panel/xmlrpc.php' not found or unable to stat
[Sun Jan 04 00:47:24.314942 2015] [autoindex:error] [pid 2081] [client 192.168.0.254:45586] AH01276: Cannot serve directory /etc/sentora/panel/modules/sabre/: No matching DirectoryIndex (index.php) found, and server-generated directory index forbidden by Options directive
[Sun Jan 04 02:24:36.065060 2015] [:error] [pid 2894] [client 192.168.0.254:58036] script '/etc/sentora/panel/wp-login.php' not found or unable to stat
[Sun Jan 04 03:34:00.423577 2015] [:error] [pid 2871] [client 192.168.0.254:38370] script '/etc/sentora/panel/wp-login.php' not found or unable to stat
[Sun Jan 04 10:15:24.455048 2015] [core:error] [pid 2764] [client 192.168.0.254:58599] AH00082: an unknown filter was not added: includes
[Sun Jan 04 10:17:56.107382 2015] [core:error] [pid 2742] [client 192.168.0.254:58915] AH00082: an unknown filter was not added: includes
[Sun Jan 04 10:59:17.116926 2015] [core:error] [pid 20876] [client 192.168.0.254:35789] AH00082: an unknown filter was not added: includes
Reply
Thanks given by:
#28
[Not Solved] RE: xBilling [MODULE]
None of these log items relates to the module. Where did you configured "sentora-error.log"? Have a look at "/var/log/apache2/error.log" instead?
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:
#29
[Not Solved] RE: xBilling [MODULE]
(01-05-2015, 08:03 PM)modpluz Wrote: None of these log items relates to module. Where did you configured "sentora-error.log"? Have a look at "/var/log/apache2/error.log" instead?

Sorry, stupid error! Confused
This is the right one
Code:
[Mon Jan 05 02:47:55.359840 2015] [mpm_event:notice] [pid 24006:tid 139695990019968] AH00489: Apache/2.4.7 (Ubuntu) configured -- resuming normal operations
[Mon Jan 05 02:47:55.359967 2015] [core:notice] [pid 24006:tid 139695990019968] AH00094: Command line: '/usr/sbin/apache2'
[Mon Jan 05 02:47:58.391495 2015] [mpm_event:notice] [pid 24006:tid 139695990019968] AH00491: caught SIGTERM, shutting down
[Mon Jan 05 02:47:59.472918 2015] [:notice] [pid 24196:tid 140159841769344] mod_bw : Memory Allocated 0 bytes (each conf takes 48 bytes)
[Mon Jan 05 02:47:59.473001 2015] [:notice] [pid 24196:tid 140159841769344] mod_bw : Version 0.92 - Initialized [0 Confs]
[Mon Jan 05 02:47:59.473780 2015] [mpm_event:notice] [pid 24196:tid 140159841769344] AH00489: Apache/2.4.7 (Ubuntu) configured -- resuming normal operations
[Mon Jan 05 02:47:59.473811 2015] [core:notice] [pid 24196:tid 140159841769344] AH00094: Command line: '/usr/sbin/apache2'
[Mon Jan 05 02:48:10.603933 2015] [mpm_event:notice] [pid 24196:tid 140159841769344] AH00491: caught SIGTERM, shutting down
[Mon Jan 05 02:49:27.533357 2015] [:notice] [pid 3875] mod_bw : Memory Allocated 0 bytes (each conf takes 48 bytes)
[Mon Jan 05 02:49:27.533442 2015] [:notice] [pid 3875] mod_bw : Version 0.92 - Initialized [0 Confs]
[Mon Jan 05 02:49:27.557571 2015] [mpm_prefork:notice] [pid 3875] AH00163: Apache/2.4.7 (Ubuntu) configured -- resuming normal operations
[Mon Jan 05 02:49:27.557613 2015] [core:notice] [pid 3875] AH00094: Command line: '/usr/sbin/apache2'
[Mon Jan 05 02:49:37.874410 2015] [mpm_prefork:notice] [pid 3875] AH00169: caught SIGTERM, shutting down
[Mon Jan 05 02:50:01.354265 2015] [:notice] [pid 1253] mod_bw : Memory Allocated 0 bytes (each conf takes 48 bytes)
[Mon Jan 05 02:50:01.355214 2015] [:notice] [pid 1253] mod_bw : Version 0.92 - Initialized [0 Confs]
[Mon Jan 05 02:50:03.479341 2015] [mpm_prefork:notice] [pid 1253] AH00163: Apache/2.4.7 (Ubuntu) configured -- resuming normal operations
[Mon Jan 05 02:50:03.479404 2015] [core:notice] [pid 1253] AH00094: Command line: '/usr/sbin/apache2'
[Mon Jan 05 11:05:01.522735 2015] [mpm_prefork:notice] [pid 1253] AH00171: Graceful restart requested, doing restart
[Mon Jan 05 11:05:01.554762 2015] [:notice] [pid 1253] mod_bw : Memory Allocated 0 bytes (each conf takes 48 bytes)
[Mon Jan 05 11:05:01.554778 2015] [:notice] [pid 1253] mod_bw : Version 0.92 - Initialized [0 Confs]
[Mon Jan 05 11:05:01.574711 2015] [mpm_prefork:notice] [pid 1253] AH00163: Apache/2.4.7 (Ubuntu) configured -- resuming normal operations
[Mon Jan 05 11:05:01.574734 2015] [core:notice] [pid 1253] AH00094: Command line: '/usr/sbin/apache2'
sh: 1: Syntax error: "(" unexpected
PHP Notice:  Undefined variable: server_vars in /etc/sentora/panel/modules/xbilling/deploy/install.run on line 33
PHP Notice:  Undefined variable: server_vars in /etc/sentora/panel/modules/xbilling/deploy/install.run on line 34
PHP Notice:  Undefined variable: server_vars in /etc/sentora/panel/modules/xbilling/deploy/install.run on line 173
PHP Fatal error:  Uncaught exception 'PDOException' with message 'SQLSTATE[42S02]: Base table or view not found: 1146 Table '_core.x_vhosts' doesn't exist' in /etc/sentora/panel/modules/xbilling/deploy/install.run:178
Stack trace:
/etc/sentora/panel/modules/xbilling/deploy/install.run(178): PDOStatement->execute()
Forum Add-ons and Usage /etc/sentora/panel/modules/xbilling/deploy/install.run(27): installModule()
MySupport Addon {main}
 thrown in /etc/sentora/panel/modules/xbilling/deploy/install.run on line 178
Reply
Thanks given by:
#30
[Not Solved] RE: xBilling [MODULE]
Ah I see...what is your sentora/zpanel core database named?
Remi - Software Engineer,  Sentora Module Developer,  Owner, imerLabs


Please mark threads as SOLVED if your problem has been resolved.
Do not PM Staff Members for help unless asked to do so, this is so that others can benefit from your solution.
Do a SEARCH before asking in the forums, a solution may already exist.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
[MODULE] Mail Quota Count apinto 30 22,233 11-10-2017, 09:32 AM
Last Post: nark
[Module] User Log Viewer samt2497 14 8,233 11-09-2017, 10:43 AM
Last Post: TGates
[MODULE] Rainloop Castey 19 9,478 11-03-2017, 06:10 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)