This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Port 443 goes active, https causes error
#11
[Not Solved] RE: Port 443 goes active, https causes error
(08-15-2018, 01:47 PM)ogzcreative Wrote: this problem is caused on CentOS installs by a duplicate Listen 443 statement in /etc/httpd/conf.d/ssl.conf  Big Grin

Thanks for the tip. I am running on Ubunto 14.04, which does not have a /etc/httpd/conf.d/ssl.conf file. However, I did a find for ssl.conf. Of the nine files returned, this is the only one which references port 443:

/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot_apache/tests/testdata/centos7_apache/apache/httpd/conf.d/ssl.conf

Reference:
# When we also provide SSL we have to listen to the
# the HTTPS port in addition.
#
Listen 443 https

I don't know if this has anything to do with the issue because I am running on Unbuntu and not Centos. Even if it does, I don't know what to do about it other than rem out the Listen 443 https line.

Could all this have something to do with Let's Encrypt?

If interested, this is the link to a portion of my httpd-vhosts.conf file which shows the SSL setting for the Sentora control panel as well as two domains that had been configured with SSL -- http://rstunlimited.com/httpd-vhosts.pdf.
Reply
Thanks given by:
#12
[Not Solved] RE: Port 443 goes active, https causes error
This should have nothing to do with Lets Encrypt. You should not need to comment out the Listen 443 in the httpd-vhosts.conf as that is the proper location for it. What the problem seems to be is that there is another Listen 443 being called somewhere else for some other reason. I use Ubuntu and I know the Sentora default configurations do not have Listen 443 anywhere. You need to make sure /etc/sentora/configs/apache/httpd.conf does not have Listen 443, also make sure /etc/apache2/apache2.conf looks like this:

Code:
# This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.4/ for detailed information about
# the directives and /usr/share/doc/apache2/README.Debian about Debian specific
# hints.
#
#
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream's suggested way to configure the web server. This is because Debian's
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#    /etc/apache2/
#    |-- apache2.conf
#    |    `--  ports.conf
#    |-- mods-enabled
#    |    |-- *.load
#    |    `-- *.conf
#    |-- conf-enabled
#    |    `-- *.conf
#     `-- sites-enabled
#         `-- *.conf
#
#
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
#
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections which can be
#   customized anytime.
#
# * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
#   directories contain particular configuration snippets which manage modules,
#   global configuration fragments, or virtual host configurations,
#   respectively.
#
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
#   their respective man pages for detailed information.
#
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.


# Global configuration
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the Mutex documentation (available
# at <URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
Mutex file:${APACHE_LOCK_DIR} default

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5


# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups On

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the severity of messages logged to the error_log.
# Available values: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the log level for particular modules, e.g.
# "LogLevel info ssl:warn"
#
LogLevel warn

# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf

# Include list of ports to listen on
#Include ports.conf
# Ports are now handled in Sentora vhosts file


# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

#<Directory /var/www>
#    Options Indexes FollowSymLinks
#    AllowOverride None
#    Require all granted
#</Directory>

#<Directory /srv/>
#    Options Indexes FollowSymLinks
#    AllowOverride None
#    Require all granted
#</Directory>




# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<FilesMatch "^\.ht">
    Require all denied
</FilesMatch>


#
# The following directives define some format nicknames for use with
# a CustomLog directive.
#
# These deviate from the Common Log Format definitions in that they use %O
# (the actual bytes sent including headers) instead of %b (the size of the
# requested file), because the latter makes it impossible to detect partial
# requests.
#
# Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
# Use mod_remoteip instead.
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
# Following line added to fix Webalizer regarding an oversized log record
LogFormat "%h %l %u %t \"%!414r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
#IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Include /etc/sentora/configs/apache/httpd.conf
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#13
[Not Solved] RE: Port 443 goes active, https causes error
(08-16-2018, 07:11 AM)TGates Wrote: This should have nothing to do with Lets Encrypt. You should not need to comment out the Listen 443 in the httpd-vhosts.conf as that is the proper location for it. What the problem seems to be is that there is another Listen 443 being called somewhere else for some other reason. I use Ubuntu and I know the Sentora default configurations do not have Listen 443 anywhere. You need to make sure /etc/sentora/configs/apache/httpd.conf does not have Listen 443, also make sure /etc/apache2/apache2.conf looks like this:

Good one, TGates! Replacing /etc/apache2/apache2.conf might be the answer. Mine has:
<IfModule mod_ssl.c>
Listen 443
</IfModule>
at the end, after the Include /etc/sentora/configs/apache/httpd.conf line. Wonder where it came from. I will copy your version, but might have to wait until September 1 to see if it fixed the problem, since that is when it usually blows out because Listen 443 gets added to the /etc/sentora/configs/apache/httpd.conf file the first of each month.
Reply
Thanks given by:
#14
[Not Solved] RE: Port 443 goes active, https causes error
Nothing should be added to the httpd.conf... There is nothing in Sentora that touches that file. Only the httpd-vhosts.conf
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#15
[Not Solved] RE: Port 443 goes active, https causes error
(08-16-2018, 07:11 AM)TGates Wrote: ...make sure /etc/apache2/apache2.conf looks like this:

As I had said, I replaced my version of /etc/apache2/apache2.conf with the one you provided, and it worked until this morning.

I am running on DreamCompute from DreamHost. I don't know if the server rebooted or what, but suddenly none of my three ssl domains could be accessed. Thinking perhaps DreamCompute has a special version of the conf file I copied the original apache2.conf back over to /etc/apache2/apache2.conf, and remmed out the line "Listen 443" .

However, that didn't work either. It wasn't until the Listen line was unremmed that the ssl domains would come up again. I don't know why the new version of apache2.conf worked at first, but now I'll be back to the first on the month problem as before. Below is my original version of /etc/apache2/apache2.conf.

By the way, what is the command to see where Listen 443 is active?

Code:
# This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.4/ for detailed information about
# the directives and /usr/share/doc/apache2/README.Debian about Debian specific
# hints.
#
#
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream's suggested way to configure the web server. This is because Debian's
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#    /etc/apache2/
#    |-- apache2.conf
#    |    `--  ports.conf
#    |-- mods-enabled
#    |    |-- *.load
#    |    `-- *.conf
#    |-- conf-enabled
#    |    `-- *.conf
#     `-- sites-enabled
#         `-- *.conf
#
#
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
#
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections which can be
#   customized anytime.
#
# * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
#   directories contain particular configuration snippets which manage modules,
#   global configuration fragments, or virtual host configurations,
#   respectively.
#
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
#   their respective man pages for detailed information.
#
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.


# Global configuration
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the Mutex documentation (available
# at <URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
Mutex file:${APACHE_LOCK_DIR} default

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5


# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the severity of messages logged to the error_log.
# Available values: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the log level for particular modules, e.g.
# "LogLevel info ssl:warn"
#
LogLevel warn

# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf

# Include list of ports to listen on
#Include ports.conf
# Ports are now handled in Sentora vhosts file


# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

#<Directory /srv/>
#    Options Indexes FollowSymLinks
#    AllowOverride None
#    Require all granted
#</Directory>




# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<FilesMatch "^\.ht">
    Require all denied
</FilesMatch>


#
# The following directives define some format nicknames for use with
# a CustomLog directive.
#
# These deviate from the Common Log Format definitions in that they use %O
# (the actual bytes sent including headers) instead of %b (the size of the
# requested file), because the latter makes it impossible to detect partial
# requests.
#
# Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
# Use mod_remoteip instead.
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
#IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Include /etc/sentora/configs/apache/httpd.conf
<IfModule mod_ssl.c>
Listen 443
</IfModule>
Reply
Thanks given by:
#16
[Not Solved] RE: Port 443 goes active, https causes error
This should not be there:

Code:
<IfModule mod_ssl.c>
Listen 443
</IfModule>
Otherwise, I see no difference at first glance. Huh 

After checking all the apache configs, at what locations do you find Listen 443?

Ubuntu way of searching (Possibly similar for CentOS): https://askubuntu.com/questions/39200/ho...cific-word
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#17
[Not Solved] RE: Port 443 goes active, https causes error
(08-21-2018, 10:27 AM)TGates Wrote: This should not be there:

Code:
<IfModule mod_ssl.c>
Listen 443
</IfModule>
Otherwise, I see no difference at first glance. Huh 

After checking all the apache configs, at what locations do you find Listen 443?

Ubuntu way of searching (Possibly similar for CentOS): https://askubuntu.com/questions/39200/ho...cific-word

I agree that it shouldn't be there. But I just remmed out those three lines, and an ssl domain would not come up! For some reason, it appears to be necessary, at least until we get to the bottome of this mess.

Thanks for working with me on this!

(08-21-2018, 10:27 AM)TGates Wrote: After checking all the apache configs, at what locations do you find Listen 443?

These are the files where Listen 443 is not remmed out:
/root/letsencrypt/certbot-apache/certbot_apache/parser.py: :param args: Value of the directive. ie. Listen 443, 443 is arg
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multi_vhosts/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multi_vhosts/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/augeas_vhosts/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/augeas_vhosts/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/default_vhost/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/default_vhost/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multiple_vhosts/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multiple_vhosts/apache2/ports.conf: Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/apache-conf-files/passing/finalize-1243.conf:Listen 443
/var/lib/letsencrypt/backups/1508844552.37/CHANGES_SINCE:Added Listen 443 directive to /etc/apache2/apache2.conf
Reply
Thanks given by:
#18
[Not Solved] RE: Port 443 goes active, https causes error
(08-21-2018, 11:03 AM)rsthomas Wrote: I agree that it shouldn't be there.  But I just remmed out those three lines, and an ssl domain would not come up!  For some reason, it appears to be necessary, at least until we get to the bottome of this mess.

Thanks for working with me on this!


These are the files where Listen 443 is not remmed out:
/root/letsencrypt/certbot-apache/certbot_apache/parser.py:        :param args: Value of the directive. ie. Listen 443, 443 is arg
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multi_vhosts/apache2/ports.conf:       Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multi_vhosts/apache2/ports.conf:       Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/augeas_vhosts/apache2/ports.conf:      Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/augeas_vhosts/apache2/ports.conf:      Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/default_vhost/apache2/ports.conf:      Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/default_vhost/apache2/ports.conf:      Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multiple_vhosts/apache2/ports.conf:    Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/testdata/debian_apache_2_4/multiple_vhosts/apache2/ports.conf:    Listen 443
/root/letsencrypt/certbot-apache/certbot_apache/tests/apache-conf-files/passing/finalize-1243.conf:Listen 443
/var/lib/letsencrypt/backups/1508844552.37/CHANGES_SINCE:Added Listen 443 directive to /etc/apache2/apache2.conf

Non of those should be loading, so I don't think that is the problem. If you rem out the one in the httpd.conf and un-rem the one in the httpd-vhosts.conf it should still work (that's how it is designed.)
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#19
[Not Solved] RE: Port 443 goes active, https causes error
(08-22-2018, 06:18 AM)TGates Wrote: If you rem out the one in the httpd.conf and un-rem the one in the httpd-vhosts.conf it should still work (that's how it is designed.)

This is what I did:
/etc/sentora/configs/apache/httpd.conf
no reference to 443

/etc/apache2/apache2.conf
rem out line referencing 443

/etc/sentora/configs/apache/httpd-vhosts.conf
unrem #Listen 443

Restarted apache2 -- so far, so good at bringing up ssl domains!
Reply
Thanks given by:
#20
[Not Solved] RE: Port 443 goes active, https causes error
Excellent! Keep an eye on it and let us know how it turns out.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
sentora install error laci 4 132 5 hours ago
Last Post: fearworks
Sentora move error blackstormy1804 1 252 10-31-2018, 11:29 PM
Last Post: republicus
HTTP 500 error with Ioncube itzdaniel483 0 474 09-15-2018, 10:56 PM
Last Post: itzdaniel483

Forum Jump:


Users browsing this thread: 1 Guest(s)