This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Port 443 goes active, https causes error
#1
[Not Solved] Port 443 goes active, https causes error
After adding Let's Encrypt to my Sentora control panel domain I am not able to access it via https, and sometimes apache2 is automatically stopped.  Trying to restart it then causes this message:  "(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443"

I followed the directions from http://docs.sentora.org/?node=102.  

Below are the configuration settings.  Have I missed something?

-------------------------------
SENTORA CONFIG
Sentora Apache Port     443     Sentora Apache panel port
-------------------------------

APACHE CONFIG
Apache Port     80     Apache service port

Code:
Global Sentora Entry     Extra directives for Sentora default vhost.
SSLEngine on
SSLProtocol ALL -SSLv2 -SSLv3
SSLHonorCipherOrder On
SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS
SSLCertificateFile /etc/letsencrypt/live/admin.rstunlimited.us/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/admin.rstunlimited.us/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/admin.rstunlimited.us/chain.pem
# Keeping bellow for future upgrades.
# Requires Apache >= 2.4
SSLCompression off
---------------------------

HTTPD-VHOSTS.CONF    
Listen 443
Listen 80

# Configuration for Sentora control panel.
<VirtualHost *:443>
ServerAdmin email@rstunlimited.us
DocumentRoot "/etc/sentora/panel/"
ServerName admin.rstunlimited.us
ErrorLog "/var/sentora/logs/sentora-error.log"
CustomLog "/var/sentora/logs/sentora-access.log" combined
CustomLog "/var/sentora/logs/sentora-bandwidth.log" common
AddType application/x-httpd-php .php
<Directory "/etc/sentora/panel/">
Options +FollowSymLinks -Indexes
   AllowOverride All
   Require all granted
</Directory>

# Custom settings are loaded below this line (if any exist)
SSLEngine on
SSLProtocol ALL -SSLv2 -SSLv3
SSLHonorCipherOrder On
SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS
SSLCertificateFile /etc/letsencrypt/live/admin.rstunlimited.us/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/admin.rstunlimited.us/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/admin.rstunlimited.us/chain.pem
# Keeping bellow for future upgrades.

# Requires Apache >= 2.4

SSLCompression off
</VirtualHost>

---------------------------
Reply
Thanks given by:
#2
[Not Solved] RE: Port 443 goes active, https causes error
Did you resolve this? Domain opens with SSL and properly redirects from 80 to 443.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#3
[Not Solved] RE: Port 443 goes active, https causes error
(01-03-2018, 03:07 AM)TGates Wrote: Did you resolve this? Domain opens with SSL and properly redirects from 80 to 443.

No, this has not been resolved. Your statement above is certainly how it should work. With the following settings,

-------------------------------
SENTORA CONFIG
Sentora Apache Port 443 Sentora Apache panel port
-------------------------------
-------------------------------
APACHE CONFIG
Apache Port 80 Apache service port
-------------------------------

whenever /etc/sentora/configs/apache/httpd-vhosts.conf is reset and adds "Listen 443" apache2 gets hung-up and stops running. When I rem out the line and restart apache2, everything is fine until the next time vhosts.conf gets reset.

In other words, when the system is "listening" to port 443, the problem occurs. When it is only listening to port 80, and a SSL domain is accessed, the proper redirect works.
Reply
Thanks given by:
#4
[Not Solved] RE: Port 443 goes active, https causes error
Usually if apache fails when LISTEN 443 is added to the httpd-vhosts.conf then that usually means there is another LISTEN 443 somewhere in the config that shouldn't be (ie: in the httpd.conf) Find and remove it, then the one in the httpd-vhosts.conf will work.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#5
[Not Solved] RE: Port 443 goes active, https causes error
(01-27-2018, 03:56 AM)TGates Wrote: Usually if apache fails when LISTEN 443 is added to the httpd-vhosts.conf then that usually means there is another LISTEN 443 somewhere in the config that shouldn't be (ie: in the httpd.conf) Find and remove it, then the one in the httpd-vhosts.conf will work.

I checked /etc/sentora/configs/apache/httpd.conf, and there is nothing in the file pertaining to 443, right now. Something must trigger the entry occasionally -- any ideas what that might be?
Reply
Thanks given by:
#6
[Not Solved] RE: Port 443 goes active, https causes error
Do you have anything else installed on your server that may trigger port 443? I'm not sure why it would be intermittent. I just testing it again and it redirected to https and loaded fine.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#7
[Not Solved] RE: Port 443 goes active, https causes error
I am having the same problem.

Have followed the manual instructions several times (several whole server re-installations!)

The failure to access the control panel happens immediately after entering the Sentora Global Vhosts info and saving. I get thrown out of the control panel and canot get back in from the browser.
I only have SSh access.

No other instances of Listen 443.

Disappointed I cannot get Lets Encrypt working with Sentora. LE works and sets up ok, its something within Sentora and relationship with Apache that is going wrong.

Any help?

Am using Ubuntu 14.04 on OpenVZ VPS. Sentora 1.0.3
Reply
Thanks given by:
#8
[Not Solved] RE: Port 443 goes active, https causes error
You are more than likely not pasting/editing the custom entry properly which is causing apache to fail to start. If you check your apache error log you should see the reason.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#9
[Not Solved] RE: Port 443 goes active, https causes error
(02-25-2018, 08:04 AM)TGates Wrote: Do you have anything else installed on your server that may trigger port 443? I'm not sure why it would be intermittent. I just testing it again and it redirected to https and loaded fine.

Sorry for the late response!

I am not aware of anything else that wants to use port 443. Checking httpd.conf mid-month showed nothing.

Meanwhile, the pattern I have noticed the past several months is that the Listen 443 appears in /etc/sentora/configs/apache/httpd-vhosts.conf and causes apache to stop running on the first day of every month. Do you know of anything that runs only on the first day that would cause httpd-vhosts.conf to be updated? Funny thing is that the Listen 443 that I rem out is gone at that time, indicating the whole file is recreated.

If we don't have this solved by September 1, I will check the httpd.conf at that time, like previously suggested, to see if anything else is using port 443.
Reply
Thanks given by:
#10
[Not Solved] RE: Port 443 goes active, https causes error
this problem is caused on CentOS installs by a duplicate Listen 443 statement in /etc/httpd/conf.d/ssl.conf  Big Grin
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
sentora install error laci 4 132 5 hours ago
Last Post: fearworks
Sentora move error blackstormy1804 1 250 10-31-2018, 11:29 PM
Last Post: republicus
HTTP 500 error with Ioncube itzdaniel483 0 474 09-15-2018, 10:56 PM
Last Post: itzdaniel483

Forum Jump:


Users browsing this thread: 1 Guest(s)