This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Apache not starting
#1
[Solved] Apache not starting
Hello, 
Can anyone help. I tried to install ssl certificate on my zpanel. I changed apache port from 80 to 443 via phpmyadmin zpanel_core>x.setting and followed this thread: http://forums.sentora.org/showthread.php?tid=488

I stopped the apache server and wont restart after. I have restored the changed files but I can not access phpmyadmin to change the apache port back to 80.
Is there anything I can do to make it work again.
Thanks
Reply
Thanks given by:
#2
[Solved] RE: Apache not starting
If you restored your original files it should work. What errors show up when you try to start apache? Check your error logs.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#3
[Solved] RE: Apache not starting
(12-24-2017, 04:19 AM)TGates Wrote: If you restored your original files it should work. What errors show up when you try to start apache? Check your error logs.

I had this issue several times before it worked installing the basic openssl and then the certificate manager plugin, then it worked fine..

I had to format and reinstall OS and Sentora every time till it worked..

The steps I followed:
1. http://docs.sentora.org/?node=20#USL
2. http://forums.sentora.org/showthread.php?tid=2001

When you install a cert it will take like 5 mins till its active.. Smile
Reply
Thanks given by:
#4
[Solved] RE: Apache not starting
I have solved that problem now. I reinstalled the original files. Thanks all for your help.

However, I need to install ssl cert on one domain. I have few domains on my server running zpanel version 10.1.0 on Windows server. I am having problems installing the certificate.
I have PositiveSSl and was given ca.bundle and .crt files.
I have followed some of the in http://forums.sentora.org/showthread.php?tid=488 but it is not working and I do not want to mess up the server.
Please help!!!
Reply
Thanks given by:
#5
[Solved] RE: Apache not starting
I'm not sure how to help if 'it is not working'. What is not working? Are there any errors displayed or in the logs?
The tutorial you used is a bit out of date. You may want to try: http://docs.sentora.org/?node=64 the section about Override a Virtual Host Setting changing the paths to match your certificates.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#6
[Solved] RE: Apache not starting
(01-13-2018, 03:38 AM)TGates Wrote: I'm not sure how to help if 'it is not working'. What is not working? Are there any errors displayed or in the logs?
The tutorial you used is a bit out of date. You may want to try: http://docs.sentora.org/?node=64 the section about Override a Virtual Host Setting changing the paths to match your certificates.

Hello TGates,
Thanks for your reply. I am on windows server. I hope it will be ok as the thread title reads: All Linux OS Distributions with self signed SSL for a Domain or Sub-Domain.
I will give it a go.
Thanks again.
Reply
Thanks given by:
#7
[Solved] RE: Apache not starting
Hello, I have followed the instruction here http://docs.sentora.org/?node=64 to install sslcertificate. The address bar reads https:// but gives error the site can not be reached. Please any idea how to solve this. Am on zpanel with windows server 2008.
Thanks
Reply
Thanks given by:
#8
[Solved] RE: Apache not starting
[Moved to proper forum section]

It should be working if your file/folder paths are correct. PM me your httpd-vhosts.conf file.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#9
[Solved] RE: Apache not starting
Hello,
Am having this error after installing ssl on zpanel OS Windows server 2008:

PHP Notice: CURL error checking plugin versions: 60:SSL certificate problem: self signed certificate in certificate chain
Kindly help, anybody?
Thanks
Reply
Thanks given by:
#10
[Solved] RE: Apache not starting
That seems to reference the fact that curl is outdated. Since we do not officially support Windows anymore, you will need to check Google (or your favorite search engine) and find out how to update the curl extension properly.

I found this thread which may help out: https://stackoverflow.com/questions/2118...ficate-cha
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
* Starting web server apache2 no listening sockets available, shutting down Gaz_in_Wales 5 6,202 05-13-2015, 10:40 PM
Last Post: Me.B
Generated vhosts.conf not compatible with Apache 2.4 gyro 5 6,685 02-06-2015, 02:48 AM
Last Post: CliffMitchell

Forum Jump:


Users browsing this thread: 1 Guest(s)