This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

ProFTPD Unit not found
#21
[Not Solved] RE: ProFTPD Unit not found
agree that's odd how we did it. BUT that need still to be done that way for centos 6. Since centos 7 we are able to add epel release in easier way using the yum install epel-release

Agree we should fix the installer checking it.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Coldfusion Freelance

10$ free to start your VPS

Reply
Thanks given by:
#22
[Not Solved] RE: ProFTPD Unit not found
Hi there,

Sorry, I hadn't paid attention to the CentOS 6 code so didn't realise if you modify the installer where I said it then breaks the CentOS 6 installation. The CentOS 6 code is working as it originally was because the Fedora Project have put a copy of the EPEL file inside the architect (x86_64) folder rather than having to delve into the "Packages" or the "e" folder - but only for CentOS 6. CentOS 7 still appears to need the fix, so I think this code is more correct for both CentOS 6 & 7 versions as opposed to what I suggested in my earlier post:

Code:
#EPEL Repo Install
EPEL_BASE_URL="http://dl.fedoraproject.org/pub/epel/$VER/$ARCH";
if  [[ "$VER" = "7" ]]; then
   EPEL_FILE=$(wget -q -O- "$EPEL_BASE_URL/Packages/e/" | grep -oP '(?<=href=")epel-release.*(?=">)')
   wget "$EPEL_BASE_URL/Packages/e/$EPEL_FILE"
else
   EPEL_FILE=$(wget -q -O- "$EPEL_BASE_URL/" | grep -oP '(?<=href=")epel-release.*(?=">)')
   wget "$EPEL_BASE_URL/$EPEL_FILE"
fi
$PACKAGE_INSTALLER -y install epel-release*.rpm
rm "$EPEL_FILE"

Keith.
Reply
Thanks given by:
#23
[Not Solved] RE: ProFTPD Unit not found
I'm not going to keep chasing this but it looks like you have changed the installation script back to what it was originally was.

If you read my post above I am not suggesting to do that, as the EPEL installation on CentOS 7 is still broken in this case. I have simply moved the "Packages" addition to within the CentOS 7 routine, so it does not affect the CentOS 6 routine, for the reasons outlined in my post above.

Hopefully it is clear enough for those reading here to see what needs modifying to make it work (as of July 2018) and hopefully provide a reason why people have had issues with ProFTPD etc.

Keith.
Reply
Thanks given by:
#24
[Not Solved] RE: ProFTPD Unit not found
Great! I will try and find some time to make the changes on Github unless Me.B does it first (He knows the proper branch to update.)
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
proftpd.service not found tallguy64 2 544 06-30-2018, 04:22 AM
Last Post: fearworks
Clamav on ProFtpd gcmstudios 0 715 02-05-2017, 10:08 AM
Last Post: gcmstudios
ProFTPD Version 1.3.5rc3 How secure is? theotherpeople 1 1,616 03-05-2016, 05:15 AM
Last Post: Me.B

Forum Jump:


Users browsing this thread: 1 Guest(s)