This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Release with php 7 compatibility
#1
Release with php 7 compatibility
Hi All!

Like you know i'm working on a new sentora installator with php 7 compatibility.

I'm not talking about support yet because is a Pre-Alpha release at this time.

I will probably do some overall tests during the next few days and request a master pull.

This the link for download the new installator

https://raw.githubusercontent.com/Eulogy...install.sh


What is new :

Installation support for

Fedora 24
Fedora 25
Ubuntu 16.04

compatible with php 7, the lastest mysql release and suhosin7 for php7

Apps upgrade
phpMyAdmin 4.0.10 to 4.7 (last stable)
Roundcube 1.0.4 to 1.2.x
phpsysinfo 3.2.4 to 2.3.7 (last stable)

All new apps are compatible with php 7.

Major bugs for the update...

The biggest bugs are about Ubuntu 16.04. 

- The MySQL 5.7 don't allow the user root to connect through the php dpo. That cause the issues about "can't connect to the sentora_core database" on the promt logging.
- A other Bug also with the MySQL 5.7 from Ubuntu. He add the sql_mode = 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION'. These sql_mode are incompatible with the sentora sql creation query, probably because some dates are empty or something like that.

I did partial patch about the last one til we rebuilt the sql query database creation.

If you try it and you have any issues, please post it on the thread. I gonna try to solve your problem soon as possible.

Thank you!

Eulogy
Reply
Thanks given by: TGates
#2
RE: Release with php 7 compatibility
Nice! Great work! Looking forward to testing this out Smile
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#3
RE: Release with php 7 compatibility
Hello All!

With my look around test, I'm meeting a issue with suhosin7 under the vhost (hostdata) forlder. I don't have any problem with the apps and sentora it's self, but the same code under vhost get a "ERR_EMPTY_RESPONSE" cause by a "zend_mm_heap corrupted".

If I'm disabling suhosin.ini the error gone.

Don't have any error in suhosin compilation.. any clue what can cause that problem?

btw, the problem is with my main Fedora25.. keep working..

Thank you!

Eulogy
Reply
Thanks given by:
#4
RE: Release with php 7 compatibility
Oki the problem base is in the apache module

the line

php_admin_value suhosin.executor.func.blacklist "passthru, show_source, shell_exec, system, pcntl_exec, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, escapeshellarg, exec"

in the apache module doesn't work any more. we need to check what is wrong with the suhosin7 and this line.

The suhosin.executor.func.blacklist doesn't work the same way?

keep working...
Reply
Thanks given by:
#5
RE: Release with php 7 compatibility
it's look to be a bug under php 7.0.19, the zend version and suhosin7.

The suhosin don't look to apply to the Zend engine.

I don't remember to get this problem with the version 7.0.18 one or two weeks ago.

Someone can tell me if he've got the same problem with any php 7.0.18?

btw you can avoid the bug by erasing the "Suhosin Value" string under the Apache Module in the "Module Admin". But it's not the objective.

bug report done for suhosin7... hope an answer...

good night all!
Reply
Thanks given by:
#6
RE: Release with php 7 compatibility
Glad to see this test going on. Instead of using mysql-server give mariadb a try. It works the same as regular mysql but it will allow root password usage under Ubuntu 16.04. Just a thought.

Sent from my LG-K550 using Tapatalk
Russ
Co-Owner
KTMGaming.net
Reply
Thanks given by:
#7
RE: Release with php 7 compatibility
(05-28-2017, 11:48 PM)HogensHero Wrote: Glad to see this test going on. Instead of using mysql-server give mariadb a try. It works the same as regular mysql but it will allow root password usage under Ubuntu 16.04. Just a thought.

Sent from my LG-K550 using Tapatalk

Thank you for your comment Russ!

Yeap Fedora works with root under madiadb aswell without any problem. But don't use the root user it's not a error itself. This is even more secure. I can understand why mysql block it. This is something we can thinking about in the futur upgrade.

Thank you!

Eulogy
Reply
Thanks given by:
#8
RE: Release with php 7 compatibility
I understand what you are saying. I have been testing various setups and have found that without the root user some errors pop up when installing for phpmyadmin and others like roundcube or squirrelmail.

Sent from my LG-K550 using Tapatalk
Russ
Co-Owner
KTMGaming.net
Reply
Thanks given by:
#9
RE: Release with php 7 compatibility
(05-29-2017, 12:41 AM)HogensHero Wrote: I understand what you are saying. I have been testing various setups and have found that without the root user some errors pop up when installing for phpmyadmin and others like roundcube or squirrelmail.

Sent from my LG-K550 using Tapatalk

hmm.. My current installer push I other SuperUser then root. So the problem as been solved for Ubuntu 16.04 under mysql 5.7. Except if your current tests cause others trouble with this update. If it's the case, you can share it with us and let's see what we can do.

At this time my only real problem is about suhosin7 and I think (but not sure) is since the update 19 of php 7.0 . I opened a issue in the github of suhosin7 about that. We need to keep in mind it a Pre-Alpha release...

I'm working for a alternate security solution atm for php 7.x. Something like mod_security + fail2ban. I installed it in my main Fedora 25 server for now and try it on my VMs for others distribution later.

For now you can install Sentora under Ubuntu 16.04 with link in the higher post. For your Vhost, just disable suhosin in the Admin Apache Module. It's less secure but working. Maybe you will not have the touble under Ubuntu for suhosin7 too. 


Thank you!

Eulogy
Reply
Thanks given by:
#10
RE: Release with php 7 compatibility
Ok I will test it later

Sent from my LG-K550 using Tapatalk
Russ
Co-Owner
KTMGaming.net
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
1.0.4 release Me.B 17 6,164 02-25-2018, 07:29 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)