This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Sending email but not receiving
#1
[Solved] Sending email but not receiving
I've got Sentora installed on CentOS 7, and am able to send email, but not receive.
I find the following error in /var/dovecot.log when I try to send an email to an account hosted by Sentora:

Fatal: setuid(xyz from userdb lookup) failed with euid=994(vmail):
Operation not permitted (This binary should probably be called with process user set to xyz instead of 994(vmail)

I am also still getting a warning that the server does not support TLS when I us mxtoolbox, but I presume that is an unrelated issue.
Reply
Thanks given by:
#2
[Solved] RE: Sending email but not receiving
So I fixed it. For anyone troubleshooting this problem, here's what I found:

The users' mail folders were owned by XYZ:mail. Not sure what happened there, but XYZ seemed to be an invalid user. So I did "chown -R vmail:mail /var/sentora/vmail/* " to match the configuration of the auth service in /var/sentora/configs/dovecot2/dovecot.conf.

/var/sentora/configs/dovecot2/dovecot-mysql.conf was hard-coding the uid to XYZ, which as we covered earlier was invalid. I changed it to the uid for the vmail user(994), restarted dovecot, and all is right with the world!
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Email not being forwarded rsthomas 7 173 10-15-2017, 08:31 PM
Last Post: zanga
Email not being forwarded rsthomas 3 145 09-30-2017, 10:15 AM
Last Post: rsthomas
Support for Email Server TLS encryption on Sentora? americanninja 18 5,167 09-21-2017, 07:21 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)