This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Jump to the post that solved this thread.
[SOLVED] Postfix ignoring Alias table
[Solved] [SOLVED] Postfix ignoring Alias table
Hi there,
please, help, trying to figure out a very strange problem.

My server is ignoring the postfix's "alias" table. It was working, nothing changed (config files). Everything original from Sentora installation. Sentora creates correctly the table records.

Alias example:

Postfix returns a "user unknown" error on

The only thing is that there's a Distribution List with >20 destinations. But I've tried to remove it, no effect.

Everything on "alias" table is just ignored. If I create a real box ("mailbox" table) everything goes ok.

No typos detected. Checked a zillion times. This is driving me crazy.
Any ideas how to fix or debug this?  Huh

Thank you.


virtual_alias_maps = proxy:mysql:/etc/sentora/configs/postfix/,                     regexp:/etc/sentora/configs/postfix/virtual_regexp

query = SELECT goto FROM alias WHERE address='%s' AND active = '1'

If I run the query manually:
SELECT goto FROM alias WHERE address='' AND active = '1'
returns correctly
Thanks given by:
[Solved] RE: [SOLVED] Postfix ignoring Alias table
Ops, my mistake Sad

I have disabled Amavisd to use an external anti-spam (MailCleaner).
I forgot to disable the receive_override_options on

smtp inet n - n - - smtpd
-o smtpd_sasl_auth_enable=yes
# -o content_filter=smtp-amavis:
# -o receive_override_options=no_address_mappings

Well, thanks anyway
Thanks given by:
Jump to the post that solved this thread.

Possibly Related Threads...
Thread Author Replies Views Last Post
I want to change the postfix HELO/EHLO butlerxyz 3 336 02-19-2018, 03:08 AM
Last Post: Me.B
Postfix mysql connection mrobot 4 1,330 07-13-2017, 04:46 AM
Last Post: mrobot
Postfix can't send above 5MB attachments. [UNSOLVED] thomasfoskolos 1 711 05-18-2017, 11:35 PM
Last Post: thomasfoskolos

Forum Jump:

Users browsing this thread: 1 Guest(s)