This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Setting up different mail server for one domain in zpanel
#1
[Not Solved] Setting up different mail server for one domain in zpanel
I have two domains in zpanel server:

abc.com
def.com

There are many email accounts which belong to these domains. In this example I am using

mark@abc.com
john@def.com

When I use same local mail server and send email from one email to another is not a problem. But when I change mail server of def.com to another server for example to microsoft office 365 then I can't send email from mark@abc.com to john@def.com.

Below is the error I am getting:

SMTP Error (450): Failed to add recipient "john@def.com" (4.1.1 <john@def.com>: Recipient address rejected: User unknown in virtual mailbox table).

How can I solve this problem? I think zpanel is looking for local server to deliver mail.

I tried following:

created /etc/postfix/transport and inserted following:
def.com smtp:mailserver.com

$ postmap /etc/postfix/transport
then uncommented transport_maps = hash:/etc/postfix/transport in /etc/postfix/main.cf and at last restarted postfix.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
ZPanel can't resolve CNAME entries jmar83 3 209 09-03-2017, 10:52 PM
Last Post: jmar83
Problem with Bandwith not update for each domain since 01/01/2017 vinhkien1288 12 2,260 07-06-2017, 12:20 AM
Last Post: rob_van
zpanel daemon errors "Undefined class constant 'MYSQL_ATTR_INIT_COMMAND'" craigh 3 543 06-02-2017, 03:52 AM
Last Post: craigh

Forum Jump:


Users browsing this thread: 1 Guest(s)