This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

upgrade to php 5.6
#11
[Not Solved] RE: upgrade to php 5.6
(02-02-2017, 03:36 AM)FernandoGarcia Wrote: Sorry, I don't know what's Suhosin.

I think this package is not loaded.

php -v says:


Code:
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies


And with php -m I can't see the module.

How to recompile it on Ubuntu?

Huh
It is mentioned a couple posts up in this very same thread (Install Docs-ISPconfig) Rolleyes
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#12
[Not Solved] RE: upgrade to php 5.6
(02-02-2017, 06:29 AM)TGates Wrote: Huh
It is mentioned a couple posts up in this very same thread (Install Docs-ISPconfig) Rolleyes

The tutorial on post Install Docs-ISPconfig is for CentOS I'm using Ubuntu.

http://forums.sentora.org/showthread.php...ht=php+5.6
Reply
Thanks given by:
#13
[Not Solved] RE: upgrade to php 5.6
Well, then I am not really sure. I haven't tried it (since I have no need to) but, Google may have some answers for you. First you will have to look into upgrading php (which looks easy enough) then check into how to recompile suhosin (Not so easy).

You also need to remember, that by doing this we will no longer be able to support you as it will be a custom install and it may also break any future upgrades of Sentora and the web stack that are planned in the future.

Good luck!
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#14
[Not Solved] RE: upgrade to php 5.6
i have this problem how to fix it
my vps have php5.6 but sentora panel PHP Version 5.5.9-1ubuntu4.21
Reply
Thanks given by:
#15
[Not Solved] RE: upgrade to php 5.6
The easier way is to follow this tutorial for Ubi: https://www.digitalocean.com/community/t...untu-14-04 ; This tutorial for Cent: https://www.digitalocean.com/community/t...n-centos-7

With Ubi you need to use the language filters so use this command (in Ubi tut): 
Code:
sudo apt-get install -y language-pack-en-base
sudo LC_ALL=en_US.UTF-8 add-apt-repository ppa:ondrej/php

Then don't forget to run your regular commands:
Code:
sudo a2dismod phpx.x
sudo a2enmod phpx.x
sudo service apache2 restart

where the first line is the version of php you want to disable, and the second you want to enable. Follow all that up with:

Code:
sudo apt-get install php7.0-cli php7.0-common libapache2-mod-php7.0 php7.0 php7.0-mysql php7.0-fpm php7.0-curl php7.0-gd php7.0-bz2

followed up with some:

Code:
sudo service apache2 restart

and everything should be kosher. Takes me about 20 Minutes to deploy a whole server with sentora and everything.

Exclamation Exclamation Exclamation WARNING! Exclamation Exclamation Exclamation : Please remember to BACK UP your data in case that this fails. I am not responsible for lost data or people who follow my words blindly! Do anything I tell you with a grain of salt and do your research prior to doing ANYTHING!
Reply
Thanks given by:
#16
[Not Solved] RE: upgrade to php 5.6
is Suhosin running on your updated server?
Don't you have to reinstall Suhosin again if you update php?
Suhosin is very important for the security in Sentora.
=------=
My Sentora DemoMy GithubAuxio Github
Zentora themeS-Type themeCstyleX theme
flat-color-iconssmall-n-flat-icons
=------=


Like my work? Consider [Image: btn_donate_SM.gif]
Reply
Thanks given by: worksmarter
#17
[Not Solved] RE: upgrade to php 5.6
(05-05-2017, 12:04 AM)Ron-e Wrote: is Suhosin running on your updated server?
Don't you have to reinstall Suhosin again if you update php?
Suhosin is very important for the security in Sentora.

Yes and yep. When you change PHP versions you must recompile SUHOSIN. Without it, SENTORA is not at all safe - they use SUHOSIN by design as part of SENTORA's rigid security.

It is also very easy to compile SUHOSIN. I and others have several threads on it. It maybe takes 45 seconds to complete as a one-liner... I canot over-state the importance of SUHOSIN working and up to date with SENTORA!!!
Everyone makes mistakes, but to truly screw up it takes the root password!
Reply
Thanks given by: TGates
#18
[Not Solved] RE: upgrade to php 5.6
(05-05-2017, 02:57 PM)worksmarter Wrote: Yes and yep. When you change PHP versions you must recompile SUHOSIN. Without it, SENTORA is not at all safe - they use SUHOSIN by design as part of SENTORA's rigid security.

It is also very easy to compile SUHOSIN. I and others have several threads on it. It maybe takes 45 seconds to complete as a one-liner... I canot over-state the importance of SUHOSIN working and up to date with SENTORA!!!

Hi!

If it's easy please point me a link or a step by step.

Best regards.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Official Upgrade php version? visionix 4 931 06-22-2017, 11:19 AM
Last Post: Sonichaos
Upgrade Kinda Work - Domain Issues Now ppcseopro 4 1,927 05-17-2016, 12:40 PM
Last Post: ppcseopro
After upgrade to MySQL 5.6 create Mysql user no longer works jeremyotten 3 2,461 12-04-2015, 10:15 PM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)