This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

upgrade to php 5.6
#1
[Not Solved] upgrade to php 5.6
Dear,
 
I have a machine with:
 
Ubuntu 12.4
Sentence Panel 1.0.3
Php 5.3
 
I need to upgrade to php 5.6
 
I used the commands for the update.
 
I check on the server the installed version php with the command (php -v)
 
PHP 5.6.29-1 + deb.sury.org ~ need + 1 (cli)
Copyright 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright 1998-2016 Zend Technologies
     With Zend OPcache v7.0.6-dev, Copyright 1999-2016, by Zend Technologies
 
 
But when I check through php.info and the Sentora panel it shows me that I'm still using php 5.3
 
My question is how to direct to php 5.6
 
Can I delete php 5.3? The server?
 
Or do we have another way to go?
 
I'm trying to install a module on my site most only works with php 5.6
 
Thanks and I look forward to your help.
Reply
Thanks given by:
#2
[Not Solved] RE: upgrade to php 5.6
you are in the right path for messing up your setup.

I don't understand how you upgraded if sentora phpinfo still shows it's 5.3. May be you compiled it aside. So my advice use ubuntu 14.04 you will get php 5.5 instead of trying to upgrade ubuntu 12.04.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Coldfusion Freelance

10$ free to start your VPS

Reply
Thanks given by:
#3
[Not Solved] RE: upgrade to php 5.6
Personally, I have done the above upgrade my self and I was succeeded in the process, php info gave me the upgraded results. i.e 5.6
If you need any help plz contact me via sajunsandaruwan @ gmail.com

I think you have messed up with some thing Smile
Reply
Thanks given by:
#4
[Not Solved] RE: upgrade to php 5.6
(12-08-2016, 11:53 PM)claudiobiato Wrote: Dear,
 
I have a machine with:
 
Ubuntu 12.4
Sentence Panel 1.0.3
Php 5.3
 
I need to upgrade to php 5.6
 
I used the commands for the update.
 
I check on the server the installed version php with the command (php -v)
 
PHP 5.6.29-1 + deb.sury.org ~ need + 1 (cli)
Copyright 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright 1998-2016 Zend Technologies
     With Zend OPcache v7.0.6-dev, Copyright 1999-2016, by Zend Technologies
 
 
But when I check through php.info and the Sentora panel it shows me that I'm still using php 5.3
 
My question is how to direct to php 5.6
 
Can I delete php 5.3? The server?
 
Or do we have another way to go?
 
I'm trying to install a module on my site most only works with php 5.6
 
Thanks and I look forward to your help.

Hi!

Have you found a solution for this problem?

I have this problem too, see image.

EDIT: I have installed using this commands:

Code:
apt-get -y update
add-apt-repository ppa:ondrej/php
apt-get -y install php5.6 php5.6-mcrypt php5.6-mbstring php5.6-curl php5.6-cli php5.6-mysql php5.6-gd php5.6-intl php5.6-xsl php5.6-zip
apt-get -y update


Best regards.


Attached Files Thumbnail(s)
   
Reply
Thanks given by:
#5
[Not Solved] RE: upgrade to php 5.6
Answer was not applicable. (Directions for CentOS, not Ubuntu...)
Everyone makes mistakes, but to truly screw up it takes the root password!
Reply
Thanks given by:
#6
[Not Solved] RE: upgrade to php 5.6
Also, you do not show proof of Suhosin working which is a major security issue if it is not.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support helpful? Donate HERE
Help me to help you by getting your domains using this link:
GoDaddy - Domains
Reply
Thanks given by:
#7
[Not Solved] RE: upgrade to php 5.6
To be honest, it looks to me like you didn't install php 5.6 properly (which in part, included re-compiling suhosin).
Following this tutorial from these very forums, php 5.6 and suhosin are the result (read the entire thread, Forum theme points out you need to recompile suhosin). Do it correctly, and you get:
Code:
[root@deckard ~]# php -v
PHP 5.6.29 (cli) (built: Dec  8 2016 08:42:35)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
   with Suhosin v0.9.38, Copyright (c) 2007-2015, by SektionEins GmbH
Keep in mind you do at your own risk and could break things even more than you might have already...
Reply
Thanks given by: TGates
#8
[Not Solved] RE: upgrade to php 5.6
Hi!

My solution is:

Uninstall php:


Code:
sudo apt-get -y purge php*


Install php 5.6:


Code:
sudo apt-get update
sudo apt-get install php5.6

Install PDO driver:

Code:
apt-get install php5.6-mysql

Edit php.ini:

Code:
sudo nano /etc/php/5.6/apache2/php.ini

Add:

Code:
extension=pdo.so
extension=pdo_mysql.so

Restart Apache:

Code:
sudo service apache2 restart

Check if PDO modules are installed:

Code:
php -i|grep PDO

The result should be like this:

Code:
PDO
PDO support => enabled
PDO drivers => mysql
PDO Driver for MySQL => enabled

That's all I think.

Best regards.
Reply
Thanks given by:
#9
[Not Solved] RE: upgrade to php 5.6
(02-01-2017, 08:56 PM)FernandoGarcia Wrote: Hi!

My solution is:

Uninstall php:


Code:
sudo apt-get -y purge php*


Install php 5.6:


Code:
sudo apt-get update
sudo apt-get install php5.6

Install PDO driver:

Code:
apt-get install php5.6-mysql

Edit php.ini:

Code:
sudo nano /etc/php/5.6/apache2/php.ini

Add:

Code:
extension=pdo.so
extension=pdo_mysql.so

Restart Apache:

Code:
sudo service apache2 restart

Check if PDO modules are installed:

Code:
php -i|grep PDO

The result should be like this:

Code:
PDO
PDO support => enabled
PDO drivers => mysql
PDO Driver for MySQL => enabled

That's all I think.

Best regards.

Confused
Did you recompile suhosin and is it running?
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support helpful? Donate HERE
Help me to help you by getting your domains using this link:
GoDaddy - Domains
Reply
Thanks given by:
#10
[Not Solved] RE: upgrade to php 5.6
Sorry, I don't know what's Suhosin.

I think this package is not loaded.

php -v says:


Code:
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies


And with php -m I can't see the module.

How to recompile it on Ubuntu?
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Official Upgrade php version? visionix 4 488 06-22-2017, 11:19 AM
Last Post: Sonichaos
Upgrade Kinda Work - Domain Issues Now ppcseopro 4 1,527 05-17-2016, 12:40 PM
Last Post: ppcseopro
After upgrade to MySQL 5.6 create Mysql user no longer works jeremyotten 3 2,082 12-04-2015, 10:15 PM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)