Ubuntu: apt-get update failures
#1
Exclamation  Ubuntu: apt-get update failures
Just in case some of you start getting these errors, here's the temporary solution until the world turns to ipv6:
NOTE: I am not sure if this is also true for CentOS (yum update) at this time.
Quote:Problem: ISPs are starting to setup an internal IPv6 network in preparation for eventually connecting to the IPv6 internet. As a result, servers in this network now try to connect to *.ubuntu.com via its IPv6 address by default when running apt-get.
SOLUTION:
Quoted from: http://askubuntu.com/questions/574569/ap...ubuntu-com
Quote:Edit [url=http://manpages.ubuntu.com/gai.conf.5][/url]
Code:
gai.conf

Code:
sudo vim /etc/gai.conf
change line ~54 to uncomment the following:
Code:
precedence ::ffff:0:0/96  100
write and quit:
Code:
:wq

CAUTION
Look out line 50 which looks almost identical:
Code:
precedence ::ffff:0:0/96  10
This is the wrong line. Go ~4 lines down and you'll find the correct line to uncomment because it ends with
Code:
100
instead of
Code:
10
OTHER RELATED ISSUES:
  1. file_get_contents() fails
  2. webmin fails to load
  3. slow loading of some sentora modules (xbilling for one)
  4. higher than normal CPU and RAM usage
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 12 - Module Installs: 102k+

Find my support helpful? Donate HERE
Help me to help you by getting your domains using this link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
  Update your profiles! TGates 11 11,768 11-22-2016, 05:22 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)