This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

PHP version changer
#51
[Not Solved] RE: PHP version changer
good job ccr1969
Reply
Thanks given by:
#52
[Not Solved] PHP version changer
@ccr1969 any updates on this I would like to see updates from you more often even if it's just check ups this will be a very useful add on and your doing such a good job

Sent from my SM-N950W using Tapatalk
Reply
Thanks given by:
#53
[Not Solved] RE: PHP version changer
(07-02-2018, 05:09 AM)type-00 Wrote: @ccr1969 any updates on this I would like to see updates from you more often even if it's just check ups this will be a very useful add on and your doing such a good job

Sent from my SM-N950W using Tapatalk
@ccr1969 have you made any more progress on the addon personally i would like to see mysql version switching as well but i know that is out of the scope of the addon but it would be nice to have both of that selectable on the same page
Reply
Thanks given by:
#54
[Not Solved] RE: PHP version changer
nice module
Reply
Thanks given by:
#55
[Not Solved] RE: PHP version changer
It´s possible test this plugin or no ?, Best Regards
Reply
Thanks given by:
#56
[Not Solved] RE: PHP version changer
i kinda stopped working on it but have started to again but its not near ready
i have a lot to figure out as I've been changing things and my coding sucks

[Image: v2.jpg][Image: view.jpg]
Reply
Thanks given by:
#57
[Not Solved] RE: PHP version changer
Is anybody interested maybe help me finish this I'm working on windows server myself so that would have to be changed if you want to use with Linux. My code is sloppy . But it does work on my server and i through together another to test on fresh install worked there also. File attached Remember Its for testing and getting maybe better coders to fix or whatever
so if you download it use at own risk !!!
find file here
https://runner.ga
https://drive.google.com/file/d/1F2O6D0R...sp=sharing
Reply
Thanks given by: TGates
#58
[Not Solved] RE: PHP version changer
(01-25-2021, 09:54 PM)ccr1969 Wrote: Is anybody interested maybe help me finish this I'm working on windows server myself so that would have to be changed if you want to use with Linux. My code is sloppy . But it does work on my server and i through together another to test on fresh install worked there also. File attached Remember Its for testing and getting maybe better coders to fix or whatever
so if you download it use at own risk !!!
find file here
https://runner.ga
https://drive.google.com/file/d/1F2O6D0R...sp=sharing

Hi ccr1969,

I would love to take a look. I’m the new main developer here at Sentora. I have been developing a new module for php version switching for our new Sentora 3.0 with PHP-FPM. Still far from release of course. I would love to see what you have done and check code. You have a few years of development on this code compared to me. I know you said your code is “sloppy” but that doesn’t mean that you aren’t on track to something great and can be updated to be secure/modern code. :-)

The main issue with using a PHP version changer module with Sentora v1.0.3 is Sentora relies on Suhosin for PHP security. Suhosin is only supported up to PHP 5.6. Sentora uses Suhosin to protect you from PHP functions that can hack your full system ( No joke ). If you would like for me to show you and test Sentora on PHP 7+ No problem ( I can access your full system if there is a vulnerability in your code.) Not good. 

I love that you support Sentora and are thinking of future code.
-Jettaman-

Sentora 2.0 with PHP 7+ support coming soon. Stay Tuned!!!

Sentora's quick recovery depends on community support and donations. We need to stand as one and help Sentora into the future.

Donate HERE and do your part. We thank you for your support.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Sentastico MediaWiki Requires Newer Version of PHP? dsmarter 1 2 624 08-19-2017, 03:45 AM
Last Post: TGates
How to install Select PHP Version cangkirhost 5 9 621 11-03-2016, 12:03 PM
Last Post: cangkirhost

Forum Jump:


Users browsing this thread: 1 Guest(s)