This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

PHP version changer
#31
[Not Solved] RE: PHP version changer
This does work for php 5.4 and 5.6 but php 7 it does not since Suhosin is NOT yet available for 7.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#32
[Not Solved] RE: PHP version changer
(10-10-2017, 03:38 AM)TGates Wrote: This does work for php 5.4 and 5.6 but php 7 it does not since Suhosin is NOT yet available for 7.

wait does this mean it's kinda available or just for testing/posably being intergrated into sentora
Reply
Thanks given by:
#33
[Not Solved] RE: PHP version changer
It's not available due to the suhosin issue.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#34
[Not Solved] RE: PHP version changer
it's just the php 7 that does not have suhosin right so one thing that could be done is to disable php7 another thing that could be done is if you select it warn that suhosin is not available for  it and to use at your own risk because there are those that would
Reply
Thanks given by:
#35
[Not Solved] RE: PHP version changer
Correct. All good points Cool 
It would be good to have to use older versions of php to keep site compatibility.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#36
[Not Solved] RE: PHP version changer
That's why I feel it should be integrated into sentora

Now if only we could have the same for mysql

Sent from my SM-G900W8 using Tapatalk
Reply
Thanks given by:
#37
[Not Solved] RE: PHP version changer
dead post
Reply
Thanks given by:
#38
[Not Solved] RE: PHP version changer
Sorry guys got busy with life yes i still have this . Let me look through my files this has manual mods that are required files that need changing etc . it does work php 5.4 5.5 5.6 (7 no suhoshin) give me time
Reply
Thanks given by:
#39
[Not Solved] RE: PHP version changer
I've did 1 php selector in my own sentora edition, it's simple and use FPM/FastCGI.

Php 5.6 and 7.1 with Suhosin
And before someone came here to say something about suhosin on php7:
I've added others modules and configurations to improve security (like diseval) Smile
Reply
Thanks given by:
#40
[Not Solved] RE: PHP version changer
(11-29-2017, 04:36 AM)DkHosting Wrote: I've did 1 php selector in my own sentora edition, it's simple and use FPM/FastCGI.

Php 5.6 and 7.1 with Suhosin
And before someone came here to say something about suhosin on php7:
I've added others modules and configurations to improve security (like diseval) Smile

That sounds pretty cool!
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Sentastico MediaWiki Requires Newer Version of PHP? dsmarter 1 699 08-19-2017, 03:45 AM
Last Post: TGates
How to install Select PHP Version cangkirhost 5 4,073 11-03-2016, 12:03 PM
Last Post: cangkirhost

Forum Jump:


Users browsing this thread: 1 Guest(s)