This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[Module] Theme_installer
#1
[Not Solved] [Module] Theme_installer
My new module

Theme_installer

a simple way to install theme to sentora and delete Smile

the users make a theme upload it to my server and all users that have install this module can install it Big Grin

And now how to install it Huh


Code:
zppy repo add repo.alio.dk
zppy update
zppy install Theme_installer


Attached Files Thumbnail(s)
       
Sentora 1.0.3 on [Image: DO_Logo_Horizontal_Blue-3db19536.png]

-= Github =-  -= My Repo =-

My Modules
Reply
Thanks given by: Jango , apinto
#2
[Not Solved] RE: [Module] Theme_installer
The store are now up and running

link http://theme.alio.dk
Sentora 1.0.3 on [Image: DO_Logo_Horizontal_Blue-3db19536.png]

-= Github =-  -= My Repo =-

My Modules
Reply
Thanks given by: TGates
#3
[Not Solved] RE: [Module] Theme_installer
I see you have uploaded 2 of my themes already.
How are they gone be updated?

P.S. i get this message if i try to install the module:
Quote:No module.xml file found in the unzipped archive.
The package is wrong:
[Image: dXdKBe5.png]
=------=
My Sentora DemoMy GithubAuxio Github
Zentora themeS-Type themeCstyleX theme
flat-color-iconssmall-n-flat-icons
=------=


Like my work? Consider [Image: btn_donate_SM.gif]
Reply
Thanks given by:
#4
[Not Solved] RE: [Module] Theme_installer
Hmm can you try to delete the folder and try again

About the update work on a xml where the version is add in the folder where the author is listet and you website/github and version like on module

and if you upload a new theme and xml on the module it will say hey a new version is ready will you upgrade

and yes i have uploadet 2 of you theme but will remove them if you say
Sentora 1.0.3 on [Image: DO_Logo_Horizontal_Blue-3db19536.png]

-= Github =-  -= My Repo =-

My Modules
Reply
Thanks given by:
#5
[Not Solved] RE: [Module] Theme_installer
(10-01-2015, 03:26 AM)Diablo925 Wrote: Hmm can you try to delete the folder and try again
Still the same problem, your zpp package is wrong...
if i unpack the .zpp package i get 2 directories one called "__MACOSX" and another directory called "Theme_installer.zpp".
If i manually repackage and install it it works.


(10-01-2015, 03:26 AM)Diablo925 Wrote: About the update work on a xml where the version is add in the folder where the author is listet and you website/github and version like on module
The xml from your theme installer package can not be read because it is packed wrong.

(10-01-2015, 03:26 AM)Diablo925 Wrote: and if you upload a new theme and xml on the module it will say hey a new version is ready will you upgrade

and yes i have uploadet 2 of you theme but will remove them if you say
You don't have to remove them, just a question about uploading a updated version from a theme as like it looks like you need a password.
=------=
My Sentora DemoMy GithubAuxio Github
Zentora themeS-Type themeCstyleX theme
flat-color-iconssmall-n-flat-icons
=------=


Like my work? Consider [Image: btn_donate_SM.gif]
Reply
Thanks given by:
#6
[Not Solved] RE: [Module] Theme_installer
Im asorry about that

i have just testet the module
on a new server and it Works now "I hope"
it is in version 103 upgrade has been addet to the module just need to add it to my website
Sentora 1.0.3 on [Image: DO_Logo_Horizontal_Blue-3db19536.png]

-= Github =-  -= My Repo =-

My Modules
Reply
Thanks given by:
#7
[Not Solved] RE: [Module] Theme_installer
it works but i get an message when i install:
Code:
[root@mail ~]# zppy install Theme_installer
Module to be installed Theme_installer
--2015-10-01 20:17:53--  http://repo.alio.dk/Theme_installer.zpp
Resolving repo.alio.dk... 2a03:b0c0:2:d0::49d:f001, 188.166.57.74
Connecting to repo.alio.dk|2a03:b0c0:2:d0::49d:f001|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10786 (11K)
Saving to: âTheme_installer.zppâ

100%[======================================>] 10,786      43.5K/s   in 0.2s

2015-10-01 20:17:53 (43.5 KB/s) - âTheme_installer.zppâ


Notice: Undefined property: XMLTag::$type in /etc/sentora/panel/dryden/ui/module.class.php on line 82

Notice: Trying to get property of non-object in /etc/sentora/panel/dryden/ui/module.class.php on line 82
Module installed successfully!
=------=
My Sentora DemoMy GithubAuxio Github
Zentora themeS-Type themeCstyleX theme
flat-color-iconssmall-n-flat-icons
=------=


Like my work? Consider [Image: btn_donate_SM.gif]
Reply
Thanks given by:
#8
[Not Solved] RE: [Module] Theme_installer
yeah but it is in the core module it Works and not have the time to find the error


If you want try the theme store at http://theme.alio.dk Smile

and i forgot to add a link in the module :/ next version
Sentora 1.0.3 on [Image: DO_Logo_Horizontal_Blue-3db19536.png]

-= Github =-  -= My Repo =-

My Modules
Reply
Thanks given by:
#9
[Not Solved] RE: [Module] Theme_installer
Your email got stuck in the spam folder after registering for updating the themes..

Please change the
Code:
<a class="navbar-brand" href="#">Sentora Theme store</a>
 to something like
Code:
<a class="navbar-brand" href="./">Sentora Theme store</a>
Tongue


I and lots like me use logo's headers to go back to the index page..  Wink
=------=
My Sentora DemoMy GithubAuxio Github
Zentora themeS-Type themeCstyleX theme
flat-color-iconssmall-n-flat-icons
=------=


Like my work? Consider [Image: btn_donate_SM.gif]
Reply
Thanks given by:
#10
[Not Solved] RE: [Module] Theme_installer
Changed and your account has been enable
Sentora 1.0.3 on [Image: DO_Logo_Horizontal_Blue-3db19536.png]

-= Github =-  -= My Repo =-

My Modules
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
[MODULE] Net2FTP-Filemanager betatester3.0 3 93 09-17-2017, 10:23 PM
Last Post: betatester3.0
[MODULE] Mail Quota Count apinto 29 20,185 09-04-2017, 09:06 PM
Last Post: betatester3.0
[MODULE] Error Pages Module [ALL OS] TGates 2 5,031 08-09-2017, 05:37 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)