This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
#21
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
Glad emails and clients / websites are working without issues Smile let me know if anything isn't working ....
Reply
Thanks given by:
#22
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
Hi, All

As im using My zpanel on live and in virtual server i can do bakup and restore it on another VPS, if you guys need to test !

Gonna give it atry once i reinstall the Dedicated !
Reply
Thanks given by: TGates
#23
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
(09-24-2015, 05:36 AM)Ilia Wrote: Hi, All

As im using My zpanel on live and in virtual server i can do bakup and restore it on another VPS, if you guys need to test !

Gonna give it atry once i reinstall the Dedicated !

That would be great! Wait for kandrews to commit the SQL update fix then we can both give it a try again.
[Image: logo2.png]

My being on this forum is all personal and all is done here by me has nothing to with the company Web Improved I work for Smile
Reply
Thanks given by:
#24
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
I noticed that the protected directory's module is not part of the upgrade?
[Image: logo2.png]

My being on this forum is all personal and all is done here by me has nothing to with the company Web Improved I work for Smile
Reply
Thanks given by:
#25
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
Think i added that to the sql files.. can you double check me?
Reply
Thanks given by:
#26
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
If you need to fix after the conversion over to sentora_ prefixed databases run the following:

Code:
CREATE TABLE `sentora_core`.`x_htpasswd_file` (
  `x_htpasswd_file_id` int(11) NOT NULL AUTO_INCREMENT,
  `x_htpasswd_file_target` varchar(255) NOT NULL,
  `x_htpasswd_file_message` varchar(255) NOT NULL,
  `x_htpasswd_file_created` int(11) NOT NULL,
  `x_htpasswd_file_deleted` int(11) DEFAULT NULL,
  `x_htpasswd_sentora_user_id` int(11) NOT NULL,
  PRIMARY KEY (`x_htpasswd_file_id`),
  UNIQUE KEY `x_htpasswd_file_target` (`x_htpasswd_file_target`),
  KEY `x_htpasswd_file_x_htpasswd_sentora_user_id_idx` (`x_htpasswd_sentora_user_id`)
) DEFAULT CHARSET=utf8;

CREATE TABLE `sentora_core`.`x_htpasswd_mapper` (
  `x_htpasswd_mapper_id` int(11) NOT NULL AUTO_INCREMENT,
  `x_htpasswd_file_id` int(11) NOT NULL,
  `x_htpasswd_user_id` int(11) NOT NULL,
  PRIMARY KEY (`x_htpasswd_mapper_id`),
  KEY `x_htpasswd_mapper_x_htpasswd_file_id_idx` (`x_htpasswd_file_id`),
  KEY `x_htpasswd_mapper_x_htpasswd_user_id_idx` (`x_htpasswd_user_id`)
) DEFAULT CHARSET=utf8;

CREATE TABLE `sentora_core`.`x_htpasswd_user` (
  `x_htpasswd_user_id` int(11) NOT NULL AUTO_INCREMENT,
  `x_htpasswd_user_username` varchar(255) NOT NULL,
  `x_htpasswd_user_password` varchar(255) NOT NULL,
  `x_htpasswd_user_created` int(11) NOT NULL,
  `x_htpasswd_user_deleted` int(11) DEFAULT NULL,
  `x_htpasswd_sentora_user_id` int(11) NOT NULL,
  PRIMARY KEY (`x_htpasswd_user_id`),
  UNIQUE KEY `x_htpasswd_user_username` (`x_htpasswd_user_username`),
  UNIQUE KEY `x_htpasswd_user_password` (`x_htpasswd_user_password`)
) DEFAULT CHARSET=utf8;
Reply
Thanks given by:
#27
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
(09-24-2015, 08:32 PM)kandrews Wrote: If you need to fix after the conversion over to sentora_ prefixed databases run the following:

Code:
CREATE TABLE `sentora_core`.`x_htpasswd_file` (
 `x_htpasswd_file_id` int(11) NOT NULL AUTO_INCREMENT,
 `x_htpasswd_file_target` varchar(255) NOT NULL,
 `x_htpasswd_file_message` varchar(255) NOT NULL,
 `x_htpasswd_file_created` int(11) NOT NULL,
 `x_htpasswd_file_deleted` int(11) DEFAULT NULL,
 `x_htpasswd_sentora_user_id` int(11) NOT NULL,
 PRIMARY KEY (`x_htpasswd_file_id`),
 UNIQUE KEY `x_htpasswd_file_target` (`x_htpasswd_file_target`),
 KEY `x_htpasswd_file_x_htpasswd_sentora_user_id_idx` (`x_htpasswd_sentora_user_id`)
) DEFAULT CHARSET=utf8;

CREATE TABLE `sentora_core`.`x_htpasswd_mapper` (
 `x_htpasswd_mapper_id` int(11) NOT NULL AUTO_INCREMENT,
 `x_htpasswd_file_id` int(11) NOT NULL,
 `x_htpasswd_user_id` int(11) NOT NULL,
 PRIMARY KEY (`x_htpasswd_mapper_id`),
 KEY `x_htpasswd_mapper_x_htpasswd_file_id_idx` (`x_htpasswd_file_id`),
 KEY `x_htpasswd_mapper_x_htpasswd_user_id_idx` (`x_htpasswd_user_id`)
) DEFAULT CHARSET=utf8;

CREATE TABLE `sentora_core`.`x_htpasswd_user` (
 `x_htpasswd_user_id` int(11) NOT NULL AUTO_INCREMENT,
 `x_htpasswd_user_username` varchar(255) NOT NULL,
 `x_htpasswd_user_password` varchar(255) NOT NULL,
 `x_htpasswd_user_created` int(11) NOT NULL,
 `x_htpasswd_user_deleted` int(11) DEFAULT NULL,
 `x_htpasswd_sentora_user_id` int(11) NOT NULL,
 PRIMARY KEY (`x_htpasswd_user_id`),
 UNIQUE KEY `x_htpasswd_user_username` (`x_htpasswd_user_username`),
 UNIQUE KEY `x_htpasswd_user_password` (`x_htpasswd_user_password`)
) DEFAULT CHARSET=utf8;

This code is in the update-structure.sql file. Strange it did not appeared.

Gone give it another go.
[Image: logo2.png]

My being on this forum is all personal and all is done here by me has nothing to with the company Web Improved I work for Smile
Reply
Thanks given by:
#28
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
Everything went Good after upgrade !
4 problem found :
1st one change theme name in database after upgrading from /etc/sentora/panel/etc/styles/zpanelx
to
/etc/sentora/panel/etc/styles/Sentora_Default
2nd one : the vhosts probleme :
PHP Code:
<Directory "/etc/zpanel/panel/">
DocumentRoot "/etc/zpanel/panel/"

NameVirtualHost *:
NameVirtualHost *:80
Listen 
Listen 80

# Configuration for Sentora control panel.
<VirtualHost *:>
ServerAdmin webmaster@......
DocumentRoot ""
ServerName 
ErrorLog 
"/var/zpanel/logs/sentora-error.log" 
CustomLog "/var/zpanel/logs/sentora-access.log" combined
CustomLog 
"/var/zpanel/logs/sentora-bandwidth.log" common
AddType application
/x-httpd-php .php
<Directory "">
Options +FollowSymLinks -Indexes
    AllowOverride All
    Order allow
,deny
    Allow from all
</Directory>

# Custom settings are loaded below this line (if any exist)

</VirtualHost>

....and 
my other domaine ..... 
tried twice and the same errors .

3rd problem, the version shown in sentora is the same version of Zpanel means 10.1.1 Knowing that we are on 1.0.3.

4rth problem : when i launch run daemon the link doesn't exist, when i searched on /panel/modules/ i found a subforlder called modules ,/panel/modules/modules/ wich contain all zpanel modules .

and there is no rundaemon.php under modules/sentoraconfig/code/rundaemon.php
but exists under : modules/modules/zpanelconfig/code/rundaemon.php

That's all
Reply
Thanks given by: kandrews
#29
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
Theme name should have been changed - must be related to failing SQL statements, will be fixed shortly.

Code:
NameVirtualHost *:
NameVirtualHost *:80
Listen
Listen 80

That doesn't look right... i'll try and replicate... This file should have been overwritten and regenerated...

In sentora i'm not sure if you can run the daemon from the web front anymore.. have a look round the forums about this.

Thanks for reporting the issues i'll get them fixed Smile
Reply
Thanks given by:
#30
RE: Upgrading ZPanel 10.1.* to Sentora - Alpha/Beta
(10-01-2015, 07:43 AM)Ilia Wrote: Everything went Good after upgrade !
4 problem found :
1st one change theme name in database after upgrading from /etc/sentora/panel/etc/styles/zpanelx
to
/etc/sentora/panel/etc/styles/Sentora_Default
2nd one : the vhosts probleme :
PHP Code:
<Directory "/etc/zpanel/panel/">
DocumentRoot "/etc/zpanel/panel/"

NameVirtualHost *:
NameVirtualHost *:80
Listen 
Listen 80

# Configuration for Sentora control panel.
<VirtualHost *:>
ServerAdmin webmaster@......
DocumentRoot ""
ServerName 
ErrorLog 
"/var/zpanel/logs/sentora-error.log" 
CustomLog "/var/zpanel/logs/sentora-access.log" combined
CustomLog 
"/var/zpanel/logs/sentora-bandwidth.log" common
AddType application
/x-httpd-php .php
<Directory "">
Options +FollowSymLinks -Indexes
    AllowOverride All
    Order allow
,deny
    Allow from all
</Directory>

# Custom settings are loaded below this line (if any exist)

</VirtualHost>

....and 
my other domaine ..... 
tried twice and the same errors .

3rd problem, the version shown in sentora is the same version of Zpanel means 10.1.1 Knowing that we are on 1.0.3.

4rth problem : when i launch run daemon the link doesn't exist, when i searched on /panel/modules/ i found a subforlder called modules ,/panel/modules/modules/ wich contain all zpanel modules .

and there is no rundaemon.php under modules/sentoraconfig/code/rundaemon.php
but exists under : modules/modules/zpanelconfig/code/rundaemon.php

That's all

Strange... did not run in to these problem with my updates.
[Image: logo2.png]

My being on this forum is all personal and all is done here by me has nothing to with the company Web Improved I work for Smile
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
sentora 1.0.3 & critical patch for sentora 1.0.x Me.B 24 37,673 10-11-2015, 10:20 PM
Last Post: Finallf
From ZPanel upto Sentora 5050 41 59,305 09-18-2015, 08:21 PM
Last Post: kandrews
Sentora 1.0.0 patch (Centos 6.x Only) Me.B 9 21,552 04-01-2015, 12:04 PM
Last Post: akong

Forum Jump:


Users browsing this thread: 1 Guest(s)