This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

PHP Upload limit
#1
[Not Solved] PHP Upload limit
I would like some help looking for how to change the PHP upload limit.

I have a wordpress installation with sentora 1.0.0. I have updated everything I could think of, from htaccess tweaks to php.ini to increase the upload limit. I have even put in some custom variables for suhosin (even disabling it) to try and allow a higher upload limit.

No matter what I try and do, I cannot upload greater than 128M, I have all the upload limits at 256M.

I suppose I would assume there is some magical hidden upload limit that I can't seem to figure out where it is or where I might be able to change it. If anyone could help me out, I would be very grateful.
Reply
Thanks given by:
#2
[Not Solved] RE: PHP Upload limit
Hello Crunchn,
Please check PHPinfo (you can see it at your Sentora Panel under the Admin menu (logged as zadmin).
Verify if the value "upload_max_filesize" is set to the value you want.
Also, "post_max_size" must be at least equal to the "upload_max_filesize".

If all this is setup correctly, eventually you have some setting on your WordPress install that is overriding the config;
in this case please read http://www.wpbeginner.com/wp-tutorials/h...wordpress/ as it provides ways to do it inside the public_html directory of our wordpress domain.
Keep in mind that these settings can't increase past the limit set on the server.

Hope this helps, post any update Wink
My Sentora Resources
[Module] Mail Quota Count | Vagrant Box with Sentora

[Image: vanguardly-logo-micro.png]
Graphic and Web Design. Development.
www.vanguardly.com


Reply
Thanks given by:
#3
[Not Solved] RE: PHP Upload limit
I did see that post and many others like it. I do work with cPanel a lot at work so I know how it works there, but for some reason the same thing doesn't apply to sentora.

Here is some info from a wordpress plugin that checks server info and wordpress permissions,

// Generated by the Send System Info Plugin //

Multisite: No

WordPress Version: 4.2.2

PHP Version: 5.5.9-1ubuntu4.9
MySQL Version: 5.5.43-0ubuntu0.14.04.1
Web Server Info: Apache

WordPress Memory Limit: 256MB
PHP Safe Mode: No
PHP Memory Limit: 256M
PHP Upload Max Size: 250M
PHP Post Max Size: 256M
PHP Upload Max Filesize: 250M
PHP Time Limit: 3000
PHP Max Input Vars: 10000
PHP Arg Separator: &
PHP Allow URL File Open: Yes
WP_DEBUG: Disabled

WP Table Prefix: Length: 3 Status: Acceptable

Show On Front: posts
Page On Front: ()
Page For Posts: ()

WP Remote Post: wp_remote_post() works

Session: Disabled
Session Name: PHPSESSID
Cookie Path: /
Save Path: /var/sentora/sessions
Use Cookies: On
Use Only Cookies: On

DISPLAY ERRORS: N/A
FSOCKOPEN: Your server supports fsockopen.
cURL: Your server supports cURL.
SOAP Client: Your server has the SOAP Client enabled.
SUHOSIN: Your server has SUHOSIN installed.



And attached I have the important part of phpinfo in the picture.

I should have everything setup for PHP to upload a lot more, but it starts uploading and the bar just resets every time it gets to ~35 seconds or 40M of the 197M file I am trying to upload.

A 100M file I upload goes straight in without any issues. I can usually figure things out on my own pretty easily, but this has me straight stumped. I assume it may just be a limitation of something, I may just need to make an upload script with basic PHP to see if it's wordpress itself, in which I would be surprised because I have never faced this issue before with wordpress.


Attached Files Thumbnail(s)
   
Reply
Thanks given by:
#4
[Not Solved] RE: PHP Upload limit
First of all, Are you using Cloud Flare?

I will check my own WordPress websites for this limit.
I've never had the real need to upload something bigger than 128mb.

I'll update here tomorrow.

If you find any news, please tell us.
My Sentora Resources
[Module] Mail Quota Count | Vagrant Box with Sentora

[Image: vanguardly-logo-micro.png]
Graphic and Web Design. Development.
www.vanguardly.com


Reply
Thanks given by: Crunchn
#5
[Not Solved] RE: PHP Upload limit
1. disabling suhosing can't work in .htaccess.

2. apinto is right pointing cloudflare upload limit here that may impact you. As once you unlock php.ini & all apache settings ( watch suhosin too & custom .htaccess) there is no reason to have such cap.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by: apinto , Crunchn
#6
[Not Solved] RE: PHP Upload limit
I disabled suhosin through the admin panel, not through .htaccess.

Anyway, yes, I had no idea cloudflare had an upload limit like that. Thank you for pointing that out. I will notify the domain owner to disable cloudflare and see if that works, which I am confident it will. If I don't reply, that was the issue.

Thank you both for your amazing help!
Reply
Thanks given by: apinto
#7
[Not Solved] RE: PHP Upload limit
If it is using Cloud Flare it has a 100mb upload limit on free acounts.

Good to see you found the issue Smile
My Sentora Resources
[Module] Mail Quota Count | Vagrant Box with Sentora

[Image: vanguardly-logo-micro.png]
Graphic and Web Design. Development.
www.vanguardly.com


Reply
Thanks given by:
#8
[Not Solved] RE: PHP Upload limit
This limit also can be if u have mod_security.
Quote:from romania with love...Wink
Reply
Thanks given by:
#9
[Not Solved] RE: PHP Upload limit
(05-30-2015, 02:40 AM)Crunchn Wrote: I would like some help looking for how to change the PHP upload limit.

I have a wordpress installation with sentora 1.0.0. I have updated everything I could think of, from htaccess tweaks to php.ini to increase the upload limit. I have even put in some custom variables for suhosin (even disabling it) to try and allow a higher upload limit.

No matter what I try and do, I cannot upload greater than 128M, I have all the upload limits at 256M.

I suppose I would assume there is some magical hidden upload limit that I can't seem to figure out where it is or where I might be able to change it. If anyone could help me out, I would be very grateful.

You can increase upload size limit editing the PHP.ini file and add the code

upload_max_filesize = 20M
post_max_size = 25M
memory_limit = 30M

You can also do this editing .htaccess fileand add the code

php_value upload_max_filesize 20MB
php_value post_max_size 25MB
php_value memory_limit 30MB

Another method is modifying WordPress editing wp-config.php or functions.php  

@ini_set( ‘upload_max_size’ , ’20MB’ );
@ini_set( ‘post_max_size’, ’25MB’);
@ini_set( ‘memory_limit’, ’30MB’ );

If still facing any issue you can go through this guide to increase upload size limit
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
How do i increase memory limit for one user?? vickyperkin 1 270 07-31-2019, 08:44 AM
Last Post: TGates
How do i increase memory limit for one user?? BloodySky 3 1,913 08-11-2018, 11:28 AM
Last Post: wormsunited
Webpage not updating after I upload new files Zreddx 2 1,393 04-18-2018, 05:26 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)