This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

PHP version changer
#21
[Solved] RE: PHP version changer
(02-28-2021, 02:32 PM)ccr1969 Wrote: Right on let me know how your making out . Like i said first time myself testing Ubuntu with Sentora as i run windows 2019 server And myself & a friend rebuilt my Sentora and is running SQL 8 latest Apache Perl Python Still Using PHP 5.6 to jail panel. As i have yet to get a good compile of snuffleupagus on Windows always errors with java time .
But Panel will work with PHP 7 just i want to Secure it . So 5.6 is it till i can get a good compile than i will do panel to work with PHP 7 or 8 . Good luck testing spoonman

the server is slower because of CGI and it is old server side technology.
"Nothing is true; everything is permitted"

Thanks given by:
#22
[Solved] RE: PHP version changer
(03-01-2021, 01:41 AM)spoonman Wrote: the server is slower because of CGI and it is old server side technology.
Try Tweaking your mod-fcgid-conf
you did change your mod-fcgid-conf ?
/etc/apache2/mods-available/fcgid.conf
play around with this it to you find a sweet spot
<IfModule mod_fcgid.c>
MaxRequestLen 1000000000
IPCCommTimeout 9999
IPCConnectTimeout 100
FcgidBusyTimeout 600
IPCConnectTimeout 600
FcgidZombieScanInterval 30
FcgidIdleTimeout 40
FcgidProcessLifeTime 30
FcgidMaxProcesses 120
FcgidMaxProcessesPerClass 120
FcgidMinProcessesPerClass 60
FcgidConnectTimeout 600
FcgidIOTimeout 600
FcgidInitialEnv RAILS_ENV production
FcgidIdleScanInterval 10
</IfModule>

Code:
FcgidBusyTimeout 3600
FcgidProcessLifeTime 3600
FcgidOutputBufferSize   0
Code:
FcgidMaxRequestsPerProcess 10000
FcgidInitialEnv PHP_FCGI_MAX_REQUESTS 10000
Thanks given by:
#23
[Solved] RE: PHP version changer
(03-01-2021, 05:04 AM)ccr1969 Wrote: Try Tweaking your mod-fcgid-conf
you did change your mod-fcgid-conf ?
play around with this it to you find a sweet spot

Thats what i have done.
I'm going to check back a little later on the speed.
"Nothing is true; everything is permitted"

Thanks given by:
#24
[Solved] RE: PHP version changer
(03-01-2021, 05:21 AM)spoonman Wrote: Thats what i have done.
I'm going to check back a little later on the speed.

did it make any difference ?
Thanks given by:
#25
[Solved] RE: PHP version changer
(03-07-2021, 05:34 AM)ccr1969 Wrote: did it make any difference 
Have not had much time to work on it. 
Still messing around with the settings. 
If I haven't said already good job on this mod.
"Nothing is true; everything is permitted"

Thanks given by:
#26
[Solved] RE: PHP version changer
(03-07-2021, 08:53 AM)spoonman Wrote: Have not had much time to work on it. 
Still messing around with the settings. 
If I haven't said already good job on this mod.

Thanks for testing it
Thanks given by:
#27
[Solved] RE: PHP version changer Ubuntu-14.04.6
(02-21-2021, 10:23 PM)spoonman Wrote: This is what i would do
open Treminal
type:

Code:
sudo -i
then root password
then
Code:
sudo nautilu
file manager will open.
go to file /etc/sentora/panel/modules/Php_Ver/hooks/ and change permissions on the file with right click on the Properties button to
[Image: 07:07:27.png]

Hi.

Ok. So, the module works well with my Windows Sentora and I guess it's really changing the version since it shows version 7 which I changed from version 5. However, it doesn't do anything like in this image. I attached what mine look like.


Attached Files Thumbnail(s)
   
Thanks given by:
#28
[Solved] RE: PHP version changer Ubuntu-14.04.6
(06-06-2021, 03:09 AM)zHostingSolutions Wrote: Hi.

Ok. So, the module works well with my Windows Sentora and I guess it's really changing the version since it shows version 7 which I changed from version 5. However, it doesn't do anything like in this image. I attached what mine look like.

The post that you're replying from was for changing permissions on files Within a Ubuntu system.
"Nothing is true; everything is permitted"

Thanks given by:
#29
[Solved] RE: PHP version changer Ubuntu-14.04.6
(06-06-2021, 03:09 AM)zHostingSolutions Wrote: Hi.

Ok. So, the module works well with my Windows Sentora and I guess it's really changing the version since it shows version 7 which I changed from version 5. However, it doesn't do anything like in this image. I attached what mine look like.

Your screenshot shows it correctly . The pending will change after daemon run. to live
if you want to see if its changed create a php info insert it into site folder and run it. It should show your version of php currently on domain.
Remember if you run lets encrypt after the php ver per say it will over write the vhost therefore you must rewrite php version back by re-choosing it php ver will not over write any existing data on vhost only its self .


Attached Files Thumbnail(s)
           
Thanks given by:
#30
[Solved] RE: PHP version changer Ubuntu-14.04.6
(06-12-2021, 06:26 AM)ccr1969 Wrote: Your screenshot shows it correctly . The pending will change after daemon run. to live
if you want to see if its changed create a php info insert it into site folder and run it. It should show your version of php currently on domain.
Remember if you run lets encrypt after the php ver per say it will over write the vhost therefore you must rewrite php version back by re-choosing it php ver will not over write any existing data on vhost only its self .

I want mine to have the same look and feel of the screenshot with the "Basic," "Permission" and "Open With." Therefore, I can change permissions.
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
PHP version changer Theo 61 119 465 10-24-2021, 12:22 AM
Last Post: sparkrack
Sentastico MediaWiki Requires Newer Version of PHP? dsmarter 1 4 211 08-19-2017, 03:45 AM
Last Post: TGates
How to install Select PHP Version cangkirhost 5 13 556 11-03-2016, 12:03 PM
Last Post: cangkirhost

Forum Jump:


Users browsing this thread: 1 Guest(s)