This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

SSL install breaks apache service
#1
[Not Solved] SSL install breaks apache service
Hello, when I configure SSL using the method in the Sentora docs, and restart the httpd service, I get an error saying that the httpd service exited with an error code. Upon checking the status of the service using systemctl, I see the following message.
Code:
#I have censored the domain for security reasons

● httpd.service - The Apache HTTP Server
  Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
  Active: failed (Result: exit-code) since Tue 2020-07-21 18:05:40 EDT; 1min 29s ago
    Docs: man:httpd(8)
          man:apachectl(8)
 Process: 11923 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
 Process: 11876 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
 Process: 11927 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
Main PID: 11927 (code=exited, status=1/FAILURE)

Jul 21 18:05:40 panel.*** systemd[1]: Stopped The Apache HTTP Server.
Jul 21 18:05:40 panel.*** systemd[1]: Starting The Apache HTTP Server...
Jul 21 18:05:40 panel.*** httpd[11927]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
Jul 21 18:05:40 panel.*** systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Jul 21 18:05:40 panel.*** systemd[1]: Failed to start The Apache HTTP Server.
Jul 21 18:05:40 panel.*** systemd[1]: Unit httpd.service entered failed state.
Jul 21 18:05:40 panel.*** systemd[1]: httpd.service failed.

Apparently, it says that some other process is using the SSL port 443 but after checking with many tools, including netstat and lsof, they say that the port is not being used. Please help me with this issue.

EDIT: I fixed it by replacing the configs and starting the httpd service. After installing wordpress, SSL works fine on it

Thanks,
EGO SKY
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Install guide wget over http? edavidf 5 332 07-30-2020, 03:23 AM
Last Post: edavidf
PLZ Help me install ssl in my own VPS Centos7 Sentora panel younessesoft 1 692 05-26-2020, 07:34 PM
Last Post: 5050
unable to install wordpress or joomla using sentastico king4m 1 1 187 04-10-2020, 07:55 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)