This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

DNS does not work Bind problem...
#1
[Solved] DNS does not work Bind problem...
Hello !

I'm on Unbuntu 14.04 and when I install Sentora I'm asked if I want to update Bind. I say yes then at the end of the installation I check if Bind is activated... and indeed it is activated but it has been 3 days that my domain name is not live yet I checked and everything communicates well. Bind doesn't give me logs.
Reply
Thanks given by:
#2
[Solved] RE: DNS does not work Bind problem...
And when I say no to install the latest version of Bind the DNS doesn't work at all!
Reply
Thanks given by:
#3
[Solved] RE: DNS does not work Bind problem...
Please give details of the domain name that isn't working and the IP address of your Sentora server.
PM them if you don't want to post publicly.

Keith
Reply
Thanks given by:
#4
[Solved] RE: DNS does not work Bind problem...
I have to before I reinstall Sentora because I uninstalled it! I'll send you this as soon as it's installed!

(06-30-2019, 02:13 AM)fearworks Wrote: Please give details of the domain name that isn't working and the IP address of your Sentora server.
PM them if you don't want to post publicly.

Keith

I sent the information by mp

The problem is that all services work perfectly but my domain name never goes online
Reply
Thanks given by:
#5
[Solved] RE: DNS does not work Bind problem...
(06-30-2019, 02:17 AM)Greval Wrote: I have to before I reinstall Sentora because I uninstalled it! I'll send you this as soon as it's installed!


I sent the information by mp

The problem is that all services work perfectly but my domain name never goes online

I got the PM thanks.

When you say your domain name never goes online, what do you mean?

I see your domain name is currently pointing to your Sentora server, but the nameservers for your domain are not pointing at your server, so by my reckoning you are not relying on the DNS system (BIND) of your Sentora installation. Effectively you are bypassing it and using the nameservers of lwsdns.com. Is that how you know it to be configured and how you want it set up?

The other thing to check is that you have added your domain as a domain in Sentora so that it knows to listen for it. This creates a proper vhost entry for it in Apache's config files. If you haven't done this yet, visiting your domain name will just show the control panel, in the same way that visiting the bare IP address of your server will also do.

I can see that port 53 is open to the world on your server, so BIND is there, running and listening, and you don't seem to have any firewall issues... it's just that the domain name you sent me isn't being requested from your server.

Feel free to ask any questions to continue this conversation Smile

Keith
Reply
Thanks given by:
#6
[Solved] RE: DNS does not work Bind problem...
I use LWS server names, is that the problem? Thank you for your answer!

Otherwise I meant that my domain name is still waiting on Sentora

But before when I put the LWS server names it worked but since the new version you have to put the Sentora server names?
Reply
Thanks given by:
#7
[Solved] RE: DNS does not work Bind problem...
(06-30-2019, 11:35 PM)Greval Wrote: I use LWS server names, is that the problem? Thank you for your answer!

Otherwise I meant that my domain name is still waiting on Sentora

Well no, it isn't a problem, it's just a choice really. You can either use their DNS system, which involves setting your domain's nameservers to theirs (which is what you have right now), and then changing any DNS records through their system, OR you can use your Sentora server's DNS system (BIND) by changing your domain's nameservers to your own and then changing any DNS records within Sentora. The latter needs some extra work though, as you'd need to set up "glue" records with your domain name registrar and have the correct records for them in your Sentora DNS records.

You can choose either... keeping the DNS with LWS means less work/maintenance but relying on that third party, putting the DNS onto your Sentora server means more setting up and maintenance, but (slightly) more control - especially if you're willing to go modifying the Sentora code to include new record types such as CAA records... but that's another discussion!

So, do you actually have the domain name set up on your server as a domain in the "domains" module? If so, something isn't working quite right but it's not BIND that's the problem. Or do you still need to add it as a domain?

Keith
Reply
Thanks given by:
#8
[Solved] RE: DNS does not work Bind problem...
So the problem is not BIND. Yes I added it well in domain and not only him so it is Sentora who has a problem. 3 months ago I had an old server with Sentora it was working great and a week ago when I tried to reinstall it, it wasn't working.
Reply
Thanks given by:
#9
[Solved] RE: DNS does not work Bind problem...
(06-30-2019, 11:55 PM)Greval Wrote: So the problem is not BIND. Yes I added it well in domain and not only him so it is Sentora who has a problem. 3 months ago I had an old server with Sentora it was working great and a week ago when I tried to reinstall it, it wasn't working.

In Sentora, does it say "pending" or "live" for the domain, and can you send me your vhost file? PM it again to keep it private if you wish:

log into your server, and open:


Code:
/etc/sentora/configs/apache/httpd-vhosts.conf


and paste the contents in a message to me, if you are able to. Keep in mind that is the CentOS path, it might be different in Ubuntu, but let me know Smile

Keith
Reply
Thanks given by:
#10
[Solved] RE: DNS does not work Bind problem...
It has been marked as pending for 2 days...

Code:
################################################################
# Apache VHOST configuration file
# Automatically generated by Sentora 1.0.3
# Generated on: 19:01 29th Jun 2019 CEST
#==== YOU MUST NOT EDIT THIS FILE : IT WILL BE OVERWRITTEN ====
# Use Sentora Menu -> Admin -> Module Admin -> Apache config
################################################################

Listen 80

# Configuration for Sentora control panel.
<VirtualHost *:80>
ServerAdmin zadmin@localhost
DocumentRoot "/etc/sentora/panel/"
ServerName panel.next-station.fr
ErrorLog "/var/sentora/logs/sentora-error.log"
CustomLog "/var/sentora/logs/sentora-access.log" combined
CustomLog "/var/sentora/logs/sentora-bandwidth.log" common
AddType application/x-httpd-php .php
<Directory "/etc/sentora/panel/">
Options +FollowSymLinks -Indexes
   AllowOverride All
   Require all granted
</Directory>

# Custom settings are loaded below this line (if any exist)

</VirtualHost>

################################################################
# Sentora generated VHOST configurations below.....
################################################################

My domain name has been waiting for two days on Sentora  ...
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Bind.log ERRORs CMs222 6 2,851 10-26-2018, 08:11 AM
Last Post: fearworks
Problem Setup DNS Slave rizkypratama 1 1,868 10-31-2017, 04:01 PM
Last Post: gozfly
DNS not working - need bind restart dragosxps 1 2,412 04-22-2017, 05:25 PM
Last Post: Ron-e

Forum Jump:


Users browsing this thread: 1 Guest(s)