This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[Module] Let's Encrypt
#51
[Solved] RE: [Module] Let's Encrypt
Bizarrus Wrote:Please read the full Thread - If you done, you will see, it's a Problem with your PHP-Version.

No Details, no support. I don't want to pull all the information out of your head.


Dear Bizarrus,
First of all, i feel gratitude for your nice work. It works at Sentora Windows (https://sourceforge.net/projects/sentoraforwindows/) well.

At first, I got white screen and 500 error. But then I realized that your vhost.template (https://github.com/Bizarrus/Sentora-Lets...t.template) is missing at Apache httpd-vhosts.conf file. It converted vhosts from 80 to 443, and added redirection from http to https codes, but I couldn't find vhost.template values in it. Then I added it into  Apache httpd-vhosts.conf file manually. So it works perfectly now..


As a solution for windows; we can change controller.php file (https://github.com/Bizarrus/Sentora-Lets...er.ext.php) as followed:

Line 697:
Code:
$template    = ($create ? str_replace([
                '$PATH',
                '$USER',
                '$DOMAIN'
            ], [
                ctrl_options::GetSystemOption('hosted_dir'),
                $user['username'],
                $domain
            ], file_get_contents(dirname(__FILE__, 2) . '/vhost.template')) : NULL);


to

Code:
            if(sys_versions::ShowOSPlatformVersion() !== 'Windows')
            {
                    $template    = ($create ? str_replace([
                    '$PATH',
                    '$USER',
                    '$DOMAIN'
                ], [
                    ctrl_options::GetSystemOption('hosted_dir'),
                    $user['username'],
                    $domain
                ], file_get_contents(dirname(__FILE__, 2) . '/vhost.template')) : NULL);
            }
            else
            {
                    $template    = ($create ? str_replace([
                    '$PATH',
                    '$USER',
                    '$DOMAIN'
                ], [
                    ctrl_options::GetSystemOption('hosted_dir'),
                    $user['username'],
                    $domain
                ], file_get_contents('C:/Sentora/panel/modules/letsencrypt/vhost.template')) : NULL);
            }
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
[MODULE] Auto-IP Updater TGates 20 32 531 09-11-2020, 09:05 AM
Last Post: TGates
[MODULE] Certificate Manager Diablo925 75 129 509 04-27-2020, 07:55 PM
Last Post: quotestatusdp
[Module] Pydio jollyjoke 51 74 255 02-04-2020, 04:45 PM
Last Post: jollyjoke

Forum Jump:


Users browsing this thread: 1 Guest(s)