This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Connecting to mail on other clients (iphone)
#1
[Not Solved] Connecting to mail on other clients (iphone)
Hello,

I have a server with sentora V1 and all my domains are protected with cloudlare, I set the mx record for the sub domain mail.mydomain.com to redirect to the server IP directly .

I tried to connect to the email I created with sentora on my iphone but it didn't work. It works just fine with the webmail on my server tho.

I tried connecting using both options IMAP and POP with the following settings:
incoming :
server: serverIP , and I tried serverIP:110
username: myemail[at]m8hamedh.ml
password: myCORRECTpassword

outgoing:
server: serverIP , and I tried serverIP:25
username: myemail[at]m8hamedh.ml
password: myCORRECTpassword

(replace 8 with normal lowercase o)
I just put one of my domains as example but I have a couple of other domains on the same server and it gives the same error with the other domains too. It always refuses to connect.

I use the IP because I tried many times with the domain and mail.domain but it dind't work neither so I thought it might be something wrong with my subdomains but even with the ip it doesn't work

any help?
And thanks in advance
Reply
Thanks given by:
#2
[Not Solved] RE: Connecting to mail on other clients (iphone)
(01-22-2019, 08:58 AM)mohamedh Wrote: Hello,

I have a server with sentora V1 and all my domains are protected with cloudlare, I set the mx record for the sub domain mail.mydomain.com to redirect to the server IP directly .

I tried to connect to the email I created with sentora on my iphone but it didn't work. It works just fine with the webmail on my server tho.

I tried connecting  using both options IMAP and POP with the following settings:
incoming :
server: serverIP  , and I tried serverIP:110
username: myemail[at]m8hamedh.ml
password: myCORRECTpassword

outgoing:
server: serverIP  , and I tried serverIP:25
username: myemail[at]m8hamedh.ml
password: myCORRECTpassword

(replace 8 with normal low case o)
I just put one of my domains as example but I have a couple of other domains on the same server and it gives the same error with the other domains too. It always refuses to connect.

I use the IP because I tried many times with the domain and mail.domain but it dind't work neither so I thought it might be something wrong with my subdomains but even with the ip it doesn't work

any help?
And thanks in advance

It sounds like it could be ports that are not open. The webmail on the server doesn't need firewall ports open as it's local to Postfix but connecting from an external client does need firewall ports opening etc. You might want to take Cloudflare out of the equation for now and set up the DNS to point directly to you server, get it working properly and then add Cloudflare back in. The you be able to tell if Cloudflare introduces any additional issues.

Keith.
Reply
Thanks given by:
#3
[Not Solved] RE: Connecting to mail on other clients (iphone)
I must add that it happens to me too, same issue, i cannot connect any POP3 account or IMAP using the details i have, although they seem to be correct.

Not just iPhone, but even Android or a simple Thunderbird, Outlook, I always get an error to send, receiving seems to be working just fine, but sending is not for sure.
'' Life is full of important choices ''
Help Sentora Donate now => http://sentora.org/donate Blush
Reply
Thanks given by:
#4
[Not Solved] RE: Connecting to mail on other clients (iphone)
(01-23-2019, 06:52 AM)wormsunited Wrote: I must add that it happens to me too, same issue, i cannot connect any POP3 account or IMAP using the details i have, although they seem to be correct.

Not just iPhone, but even Android or a simple Thunderbird, Outlook, I always get an error to send, receiving seems to be working just fine, but sending is not for sure.

It could be so many things, and I'm sure I've discussed various versions of this issue with others in the forums in the last few months... 

If you are having SMTP troubles (port 25) it could be anything from your ISP blocking port 25, to your firewall, to your ISP's firewall, to the alignment of the stars...  Tongue

I've found from past experience that the best and quickest way to diagnose issues with email in Sentora is to be given server access and an account in the Sentora installation so that I can test out what the problem is. For obvious reasons sometimes people won't want to give such access to a random stranger, but if you're having issues then I would assume the server is not a production server and therefore subjecting it to "test" accounts, logins and users should not be so much of an issue.

Keith
Reply
Thanks given by:
#5
[Not Solved] RE: Connecting to mail on other clients (iphone)
@fearwoks,

according to panel/?module=services
"HTTP (port 80 is open)
FTP (port 21 is open)
SMTP (port 25 is open)
POP3 (port 110 is open)
IMAP (port 143 is open)
MySQL (port 3306 is open)
DNS (port 53 is open)
"

So I guess the ports are fine, also, I tried to connect with the ip directly and it didn't work, and I remember trying years ago before using cloudflare and it never worked, but for now I turned off their protection, the domain points directly to the server's ip.
Do you have any suggestions? I can offer an access to sentora if you wish, or create a test email and give you the password to see if it works with external clients
Reply
Thanks given by:
#6
[Not Solved] RE: Connecting to mail on other clients (iphone)
(01-24-2019, 02:02 AM)mohamedh Wrote: @fearwoks,

according to panel/?module=services
"HTTP (port 80 is open)
FTP (port 21 is open)
SMTP (port 25 is open)
POP3 (port 110 is open)
IMAP (port 143 is open)
MySQL (port 3306 is open)
DNS (port 53 is open)
"

So I guess the ports are fine, also, I tried to connect with the ip directly and it didn't work, and I remember trying years ago before using cloudflare and it never worked, but for now I turned off their protection, the domain points directly to the server's ip.
Do you have any suggestions? I can offer an access to sentora if you wish, or create a test email and give you the password to see if it works with external clients

Unfortunately the Services page does not indicate which ports are open to the outside world, it only shows which ports the server itself is getting a response from, so there could still be a firewall blocking a port somewhere. If you want to PM me your server IP and/or hostname, and set up a test mail account for me, I don't mind taking a look. Don't give me server access details yet as the first thing I would do is try to diagnose what the problem is from an external network's point of view, and then if I need to have a look on the actual server we can sort that out later.

Keith.
Reply
Thanks given by:
#7
[Not Solved] RE: Connecting to mail on other clients (iphone)
(01-24-2019, 02:02 AM)mohamedh Wrote: @fearwoks,

according to panel/?module=services
"HTTP (port 80 is open)
FTP (port 21 is open)
SMTP (port 25 is open)
POP3 (port 110 is open)
IMAP (port 143 is open)
MySQL (port 3306 is open)
DNS (port 53 is open)
"

So I guess the ports are fine, also, I tried to connect with the ip directly and it didn't work, and I remember trying years ago before using cloudflare and it never worked, but for now I turned off their protection, the domain points directly to the server's ip.
Do you have any suggestions? I can offer an access to sentora if you wish, or create a test email and give you the password to see if it works with external clients

Whats your domain?
If your domain is m8hamedh.ml then you definitely need to give DNS some attention.

Try using telnet to connect to each port to see what's making it through your firewall.
Eg.:
Code:
telnet example.com 110


You can add telnet as an added Windows feature and use the above command in command prompt.
If you have puTTY, telnet is also integrated.

Any answer from telnet is a good sign. It may be a mail banner, login, etc.


Or, you could also run a Windows PowerShell command to check from Windows 10.
Code:
New-Object System.Net.Sockets.TcpClient("example.com" 110)

It should answer several lines:

Client                                : System.Net.Sockets.Socket
Available                            : 115
Connected                      : True
ExclusiveAddressUse         : False
ReceiveBufferSize              : 65536
SendBufferSize                  : 65536
ReceiveTimeout                : 0
SendTimeout                    : 0
LingerState                       : System.Net.Sockets.LingerOption
NoDelay                           : False


Reply
Thanks given by:
#8
[Not Solved] RE: Connecting to mail on other clients (iphone)
@republicus, thanks for trying to help.
No my domain is not m8hamedh.ml, I just replaced mo by m8 to avoid spam Smile
I actually solved my issue. Part of the issue was my phone itself, I has to reset some settings.
Also since I use Cloudflare typing the domain name worked with outlook but not with iphone, so I had to type the server ip (without including any ports!).
Thanks everyone
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
How to fix the issue of AOL Mail not sending? JerryThomas 0 24 09-11-2019, 06:20 PM
Last Post: JerryThomas
mail() don't working BigBang 3 1,676 08-13-2018, 08:32 AM
Last Post: wormsunited
How to move mail system to external storage Rayvat 1 1,370 03-21-2018, 11:03 PM
Last Post: Me.B

Forum Jump:


Users browsing this thread: 1 Guest(s)