This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

sub-domain issue
#11
[Not Solved] RE: sub-domain issue
(12-18-2018, 08:51 PM)kevwebbie Wrote: Hi Keith,
Yes, I tried to create a new home directory. Also, I believe this is the installation script I used for it:
https://raw.githubusercontent.com/sentor...install.sh

I may have changed a line or two around the "this operating system is not supported" area in order to get it installed on Debian Jessie but I can't remember. I usually document all of my installs, especially when I'm doing something new, but I think I was in a hurry on this one for whatever reason.

Also, the server is using php5.6 as the Apps on the server are built in that version. I haven't moved up to php7 just yet.

Ok well Sentora isn't supported on PHP 7 yet so that's good Smile

That is the latest install script, not the official release, and it still has some bugs and issues from what I remember. I'll have a play around with Debian Jessie and see if I have the same issues - but I might not get onto it straight away so give me a couple of weeks - unless someone else can help you out quicker Smile

Keith
Reply
Thanks given by:
#12
[Not Solved] RE: sub-domain issue
(12-19-2018, 12:10 AM)fearworks Wrote: Ok well Sentora isn't supported on PHP 7 yet so that's good Smile

That is the latest install script, not the official release, and it still has some bugs and issues from what I remember. I'll have a play around with Debian Jessie and see if I have the same issues - but I might not get onto it straight away so give me a couple of weeks - unless someone else can help you out quicker Smile

Keith

Not Debian Jessie... I mean version 9 (Stretch?). I think you did too a couple of messages ago?

Keith.
Reply
Thanks given by:
#13
[Not Solved] RE: sub-domain issue
(12-19-2018, 11:06 AM)fearworks Wrote: Not Debian Jessie... I mean version 9 (Stretch?). I think you did too a couple of messages ago?

Keith.

I am not able to get Sentora to install on Debian 9, even with a few tweaks to get past the "not supported on this OS" message at the start. The packages or repositories must just not be correct for this version. I'm not able to spend loads of time looking into making it work on Debian 9 as that's not my field, so I'd say we can only continue diagnosing this is you are using a supported OS, of which Debian 9 is not one of them.

It's possible that you could get it working and the sub-domain PHP code just needs a tweak somewhere, so have you tried making the modification to the $badname variable you spoke about in your first post?

It might be a case of it being a lot easier to diagnose and fix with access to the server but it would be your choice whether you wanted to let me do this or not, otherwise I'm stuck at not being able to recreate your setup... Sad

Keith.
Reply
Thanks given by:
#14
[Not Solved] RE: sub-domain issue
Hi Keith. Thanks for the reply. It is actually Debian 8 (Jessie) I have it installed on. I couldn't install on Debian Stretch either. I know Debian Stretch installs PHP7 as standard so one would have to roll back to PHP5.6 to use Sentora on it.

I was going to modify the $badname variable but I wanted to run it by the experts before I started messing around with it. I will take a look and see what I can do.
Reply
Thanks given by:
#15
[Not Solved] RE: sub-domain issue
(12-21-2018, 12:16 AM)kevwebbie Wrote: Hi Keith. Thanks for the reply. It is actually Debian 8 (Jessie) I have it installed on. I couldn't install on Debian Stretch either. I know Debian Stretch installs PHP7 as standard so one would have to roll back to PHP5.6 to use Sentora on it.

I was going to modify the $badname variable but I wanted to run it by the experts before I started messing around with it. I will take a look and see what I can do.

Ah, ok. Just trying to catch me out, eh? Wink

I will have another go on Debian 8 then. I abandoned it during my test install as I suddenly remembered we'd started the discussion mentioning Debian 9 and all that jazz...

Keith.
Reply
Thanks given by:
#16
[Not Solved] RE: sub-domain issue
Lol, no, I wasn't trying to catch you out. I must have got mixed up as I use Debian Stretch on my desktop.
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
how to add wildcard sub domain fnash139 2 193 02-28-2019, 06:32 PM
Last Post: fnash139
cant add wildcard sub domain nrd44 2 268 01-17-2019, 12:14 PM
Last Post: republicus
Wordpress "Temp Folder Missing" Issue NickNeverSleeps 5 2,324 12-13-2018, 09:20 PM
Last Post: ngeluis@gmail.com

Forum Jump:


Users browsing this thread: 1 Guest(s)