This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Roundcube problem
#1
[Not Solved] Roundcube problem
Hi friends.... Please I need some help about this......

When I want login trough roundcube I receive the error "Your session in invalid or expired"..... I updated php from 5 to 7 in Centos 7, I dont know if this updated has affected the roundcube access.


Please may anyone help to me?

Thanks beforehand.
Reply
Thanks given by:
#2
[Not Solved] RE: Roundcube problem
(10-05-2018, 01:16 AM)cfreire Wrote: Hi friends.... Please I need some help about this......

When I want login trough roundcube I receive the error "Your session in invalid or expired"..... I updated php from 5 to 7 in Centos 7, I dont know if this updated has affected the roundcube access.


Please may anyone help to me?

Thanks beforehand.

There are a few things that need changing/tweaking/updating to get Roundcube running on PHP 7 compared to the version packaged with Sentora 1.0.3, but you have upgraded PHP to an unsupported version, and the Sentora package is not (currently) designed for running on PHP 7.

The easiest solution would be to downgrade to PHP 5 as you were presumably running before and (unless you have changed other things) this should restore your access.

If I am incorrect about the above advice, I would be happy to amend it.

Keith.
Reply
Thanks given by:
#3
[Not Solved] RE: Roundcube problem
(10-05-2018, 01:45 AM)fearworks Wrote: There are a few things that need changing/tweaking/updating to get Roundcube running on PHP 7 compared to the version packaged with Sentora 1.0.3, but you have upgraded PHP to an unsupported version, and the Sentora package is not (currently) designed for running on PHP 7.

The easiest solution would be to downgrade to PHP 5 as you were presumably running before and (unless you have changed other things) this should restore your access.

If I am incorrect about the above advice, I would be happy to amend it.

Keith.

Hi Keith , thanks for your help.... MAy you to say me what things could I to change to try to access to Roundcube?, because the functions remains are OK.
Reply
Thanks given by:
#4
[Not Solved] RE: Roundcube problem
(10-05-2018, 02:00 AM)cfreire Wrote: Hi Keith , thanks for your help.... MAy you to say me what things could I to change to try to access to Roundcube?, because the functions remains are OK.

If you are still running the stock version of Rouncube that came with Sentora, you should upgrade that to the latest release:

Code:
cd /etc/sentora/panel/etc/apps

wget https://github.com/roundcube/roundcubemail/releases/download/1.3.7/roundcubemail-1.3.7-complete.tar.gz

tar xf roundcubemail-1.3.7-complete.tar.gz

./roundcubemail-1.3.7/bin/installto.sh /etc/sentora/panel/etc/apps/webmail

Finish by removing/cleaning up some folders:


Code:
rm -rf roundcubemail-1.3.7-complete.tar.gz
rm -rf roundcubemail-1.3.7
rm -rf webmail/installer
rm -rf webmail/SQL

Please note that you do this at your own risk. If you are running a production server you really should go back to PHP 5 as Sentora does not support PHP 7 yet, and there's more than just Roundcube that needs updating for everything to run correctly... However, if your server is "disposable", in other words, if you can afford to mess it up and load it all again from scratch if things go wrong, then fine, play about with PHP 7 and do the Roundcube upgrade - but it's at your own risk!

Keith
Reply
Thanks given by:
#5
[Not Solved] RE: Roundcube problem
(10-05-2018, 02:18 AM)fearworks Wrote: If you are still running the stock version of Rouncube that came with Sentora, you should upgrade that to the latest release:

Code:
cd /etc/sentora/panel/etc/apps

wget https://github.com/roundcube/roundcubemail/releases/download/1.3.7/roundcubemail-1.3.7-complete.tar.gz

tar xf roundcubemail-1.3.7-complete.tar.gz

./roundcubemail-1.3.7/bin/installto.sh /etc/sentora/panel/etc/apps/webmail

Finish by removing/cleaning up some folders:


Code:
rm -rf roundcubemail-1.3.7-complete.tar.gz
rm -rf roundcubemail-1.3.7
rm -rf webmail/installer
rm -rf webmail/SQL

Please note that you do this at your own risk. If you are running a production server you really should go back to PHP 5 as Sentora does not support PHP 7 yet, and there's more than just Roundcube that needs updating for everything to run correctly... However, if your server is "disposable", in other words, if you can afford to mess it up and load it all again from scratch if things go wrong, then fine, play about with PHP 7 and do the Roundcube upgrade - but it's at your own risk!

Keith

Hi... thanks very much for your help........ After I updated roundcube that works for five minutes... but after this time I now receive this error in my browser....

xxx.xxxx.xxx.xxx. no puede procesar esta solicitud en este momento.
HTTP ERROR 500
Reply
Thanks given by:
#6
[Not Solved] RE: Roundcube problem
(10-05-2018, 03:37 AM)cfreire Wrote: Hi... thanks very much for your help........ After I updated roundcube that works for five minutes... but after this time I now receive this error in my browser....

xxx.xxxx.xxx.xxx. no puede procesar esta solicitud en este momento.
HTTP ERROR 500


Hi my friend.... Thanks very much for your help Keith... Yours instructions were excellent... The errors that were presented were because there were not the packages php-xml and php-mbstring . Later of install them, RoundCube ran of marvelous.....

Regards..
Reply
Thanks given by:
#7
[Not Solved] RE: Roundcube problem
(10-05-2018, 06:26 AM)cfreire Wrote: Hi my friend.... Thanks very much for your help Keith... Yours instructions were excellent... The errors that were presented were because there were not the packages php-xml and php-mbstring . Later of install them, RoundCube ran of marvelous.....

Regards..

Ah right, yes, upgrading PHP inevitably brings the need to update or install new PHP components etc.

Glad you spotted the additional stuff that needed to be done. Just keep in mind that Sentora isn't officially supported on PHP 7 yet so if you go tweaking too many things you may end up with other issues! And I'm sure you've already read the disclaimers on the forum about securing Sentora running on PHP 7, and that Suhosin is no longer protecting you, etc. Big Grin

Keith
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
roundcube receives but it doesn't send demo 1 616 08-22-2018, 06:44 AM
Last Post: TGates
Webmail roundcube link megasmorf 1 465 08-21-2018, 08:57 AM
Last Post: TGates
wordpress problem mohamadcom 4 1,791 06-20-2018, 07:00 PM
Last Post: sktthemes

Forum Jump:


Users browsing this thread: 1 Guest(s)