This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Error after upgrade apache to latest version
#1
[Not Solved] Error after upgrade apache to latest version
I have recently install sentora, but apache version was old so i have upgraded apache by following command

Code:
cd /etc/yum.repos.d && wget https://repo.codeit.guru/codeit.el7.repo
yum install -y epel-release
yum upgrade httpd

Apache upgraded successfully but not working. getting following error while try to start apache
Code:
AH00526: Syntax error on line 40 of /etc/sentora/configs/apache/httpd-vhosts.conf:

Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

Please help me
Reply
Thanks given by:
#2
[Not Solved] RE: Error after upgrade apache to latest version
(08-20-2018, 11:28 PM)templatemaza Wrote: I have recently install sentora, but apache version was old so i have upgraded apache by following command

Code:
cd /etc/yum.repos.d && wget https://repo.codeit.guru/codeit.el7.repo
yum install -y epel-release
yum upgrade httpd

Apache upgraded successfully but not working. getting following error while try to start apache
Code:
AH00526: Syntax error on line 40 of /etc/sentora/configs/apache/httpd-vhosts.conf:

Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

Please help me

Huh  What version did you upgrade to? Did it change any of Sentora's configs?
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#3
[Not Solved] RE: Error after upgrade apache to latest version
(08-21-2018, 09:23 AM)TGates Wrote: Huh  What version did you upgrade to? Did it change any of Sentora's configs?

Thank you for reply. I did not changed anything in config files. Just add one domain in sentora panel so one virtual host created in apache before upgrade. Upgraded from 2.4.3 to latest 2.4.34.
Reply
Thanks given by:
#4
[Not Solved] RE: Error after upgrade apache to latest version
I think you didn't ship some PHP modules? What php version do you have there?

Why are you upgrading apache? To get latest php?

Can you send upgrade logs?

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Coldfusion Freelance

10$ free to start your VPS

Reply
Thanks given by:
#5
[Not Solved] RE: Error after upgrade apache to latest version
(08-21-2018, 06:47 PM)Me.B Wrote: I think you didn't ship some PHP modules? What php version do you have there?

Why are you upgrading apache? To get latest php?

Can you send upgrade logs?

M B

I have upgraded apache after a fresh installation of centora. and nothing was done for php. i want to upgrade php to latest 7.1. so i have upgraded apache before that. where can i find log files? i mean what is location of logs?
Reply
Thanks given by:
#6
[Not Solved] RE: Error after upgrade apache to latest version
(08-21-2018, 06:47 PM)Me.B Wrote: I think you didn't ship some PHP modules? What php version do you have there?

Why are you upgrading apache? To get latest php?

Can you send upgrade logs?

M B

I have commented "php_admin_value" line in apache virtual host file(/etc/sentora/configs/apache/httpd-vhosts.conf). So now apache started and working, but when I visit centora panel from the browser then something is download. I think php is not working. visit my centora link to see. 
http://cpanel.templatemaza.com/

So now i need to enable php in apache, please let me know how to do it. Thank you for your support
Reply
Thanks given by:
#7
[Not Solved] RE: Error after upgrade apache to latest version
(08-21-2018, 08:43 PM)templatemaza Wrote: I have commented "php_admin_value" line in apache virtual host file(/etc/sentora/configs/apache/httpd-vhosts.conf). So now apache started and working, but when I visit centora panel from the browser then something is download. I think php is not working. visit my centora link to see. 
http://cpanel.templatemaza.com/

So now i need to enable php in apache, please let me know how to do it. Thank you for your support

Loaded modules in apache

Code:
core_module (static)
so_module (static)
http_module (static)
access_compat_module (shared)
actions_module (shared)
alias_module (shared)
allowmethods_module (shared)
auth_basic_module (shared)
auth_digest_module (shared)
authn_anon_module (shared)
authn_core_module (shared)
authn_dbd_module (shared)
authn_dbm_module (shared)
authn_file_module (shared)
authn_socache_module (shared)
authz_core_module (shared)
authz_dbd_module (shared)
authz_dbm_module (shared)
authz_groupfile_module (shared)
authz_host_module (shared)
authz_owner_module (shared)
authz_user_module (shared)
autoindex_module (shared)
brotli_module (shared)
cache_module (shared)
cache_disk_module (shared)
cache_socache_module (shared)
data_module (shared)
dbd_module (shared)
deflate_module (shared)
dir_module (shared)
dumpio_module (shared)
echo_module (shared)
env_module (shared)
expires_module (shared)
ext_filter_module (shared)
filter_module (shared)
headers_module (shared)
include_module (shared)
info_module (shared)
log_config_module (shared)
logio_module (shared)
macro_module (shared)
mime_magic_module (shared)
mime_module (shared)
negotiation_module (shared)
remoteip_module (shared)
reqtimeout_module (shared)
request_module (shared)
rewrite_module (shared)
setenvif_module (shared)
slotmem_plain_module (shared)
slotmem_shm_module (shared)
socache_dbm_module (shared)
socache_memcache_module (shared)
socache_shmcb_module (shared)
status_module (shared)
substitute_module (shared)
suexec_module (shared)
unique_id_module (shared)
unixd_module (shared)
userdir_module (shared)
version_module (shared)
vhost_alias_module (shared)
watchdog_module (shared)
dav_module (shared)
dav_fs_module (shared)
dav_lock_module (shared)
lua_module (shared)
mpm_event_module (shared)
proxy_module (shared)
lbmethod_bybusyness_module (shared)
lbmethod_byrequests_module (shared)
lbmethod_bytraffic_module (shared)
lbmethod_heartbeat_module (shared)
proxy_ajp_module (shared)
proxy_balancer_module (shared)
proxy_connect_module (shared)
proxy_express_module (shared)
proxy_fcgi_module (shared)
proxy_fdpass_module (shared)
proxy_ftp_module (shared)
proxy_http_module (shared)
proxy_hcheck_module (shared)
proxy_scgi_module (shared)
proxy_uwsgi_module (shared)
proxy_wstunnel_module (shared)
systemd_module (shared)
cgid_module (shared)
http2_module (shared)
proxy_http2_module (shared)
Reply
Thanks given by:
#8
[Not Solved] RE: Error after upgrade apache to latest version
Well, that is why... Sentora is not yet meant to run on php 7. It requires Suhosin which uses the php_admin_vallues.
And suhosin is not yet completed for php 7.

Is nobody reading the announcements? We do not support php 7 yet, therefor if you upgrade to php 7 the staff will no longer help you.

http://forums.sentora.org/announcements.php?aid=1
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#9
[Not Solved] RE: Error after upgrade apache to latest version
(08-22-2018, 06:21 AM)TGates Wrote: Well, that is why... Sentora is not yet meant to run on php 7. It requires Suhosin which uses the php_admin_vallues.
And suhosin is not yet completed for php 7.

Is nobody reading the announcements? We do not support php 7 yet, therefor if you upgrade to php 7 the staff will no longer help you.

http://forums.sentora.org/announcements.php?aid=1

When will sentora support for PHP 7? Can we use sentora without suhosin? Currently sentora panel accessible in PHP 7. I have commented php_admin_values in apache virtual host file. Is it ok?
Reply
Thanks given by:
#10
[Not Solved] RE: Error after upgrade apache to latest version
(08-22-2018, 04:26 PM)templatemaza Wrote: When will sentora support for PHP 7? Can we use sentora without suhosin? Currently sentora panel accessible in PHP 7. I have commented php_admin_values in apache virtual host file. Is it ok?

Not sure, as soon as Suhosin for php 7 is completed or we find a different solution.
Sentora does work with php, Your server is less secure without it, but it will work.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Premium Service: Upgrade from Zpanel? BenI 3 610 06-11-2018, 11:17 PM
Last Post: BenI
Official Upgrade php version? visionix 5 4,432 01-28-2018, 10:37 PM
Last Post: mavdesigns
upgrade to php 5.6 claudiobiato 19 13,162 01-17-2018, 01:00 AM
Last Post: worksmarter

Forum Jump:


Users browsing this thread: 1 Guest(s)