This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Sentora for Windows 1.0.0 released!
#41
RE: Sentora for Windows 1.0.0 released!
(02-23-2015, 08:44 AM)MarkDark Wrote: Well what can I say. Wink
You refused to see my video tutorial on setting up the panel.
I have everything working Wink
Tested on 100%

Don't worry, I think I just found the solution... Cool

So, lets start!
In order to be able to send emails from a website (contact form), we need to fulfill some prerequisites:

1 - The domain and the email address must exist
2 - Somehow, the SENDER email address must contain the domain name on the right side
3 - All the relevant ports must be opened and configured in router and firewall: 25, 110, etc...

In my case those 3 prerequisites are fulfilled... (CONTINUATION WILL FOLLOW! Wink )
Reply
Thanks given by:
#42
RE: Sentora for Windows 1.0.0 released!
So, here are the main conclusions at the point:

1 - Alll the configured email accounts are sending and receiving emails

2 - The website contact form is not sending emails!

I tried several contact form solutions and I'm receiving this kind of error messages:

email error: mail() returned failure
server: Apache/2.2.29 (Win32) mod_antiloris/0.6.0 PHP/5.4.36 mod_perl/2.0.8 Perl/v5.16.3

or

(mail) Could not instantiate mail function. PHPMailer error: Could not instantiate mail function.

when using a form with PHPMailer function
Perhaps a problem of CHMOD?
Reply
Thanks given by:
#43
RE: Sentora for Windows 1.0.0 released!
(02-23-2015, 07:34 PM)Miow5 Wrote: So, here are the main conclusions at the point:

1 - Alll the configured email accounts are sending and receiving emails

2 - The website contact form is not sending emails!

I tried several contact form solutions and I'm receiving this kind of error messages:

email error: mail() returned failure
server: Apache/2.2.29 (Win32) mod_antiloris/0.6.0 PHP/5.4.36 mod_perl/2.0.8 Perl/v5.16.3

or

(mail) Could not instantiate mail function. PHPMailer error: Could not instantiate mail function.

when using a form with PHPMailer function
Perhaps a problem of CHMOD?

LOL!!!
In Windows, there is no CHMOD
Reply
Thanks given by:
#44
RE: Sentora for Windows 1.0.0 released!
Quote:LOL!!!
In Windows, there is no CHMOD

Windows has no CHMOD but it still have similar security issues!

After hours of investigation, I found following:

When installing WebMatrix in Windows and also having Sentora Windows installed, I
uploaded the contact form files to the Matrix environment, which is e.g. http://localhost:8080 and guess what?

I was able to send an e-mail from my contact-form.php hosted at http://localhost:8080 (no smtp AUTH., sendmail, PHPmailer). The form has also a reply feature, so I received 2 emails:

me@mydomain and otheremail@me.com

The problem on the contact form not sending email in a website has probably to do with ports:
what if I change the port to 8080? [This will be my next step]

APACHE CONFIG HTTPD
=> Listen 8080?
Reply
Thanks given by:
#45
RE: Sentora for Windows 1.0.0 released!
(02-25-2015, 05:01 AM)Miow5 Wrote: After hours of investigation, I found following:

When installing WebMatrix in Windows and also having Sentora Windows installed, I
uploaded the contact form files to the Matrix environment, which is e.g. http://localhost:8080 and guess what?

I was able to send an e-mail from my contact-form.php hosted at http://localhost:8080 (no smtp AUTH., sendmail, PHPmailer). The form has also a reply feature, so I received 2 emails:

me@mydomain and otheremail@me.com

The problem on the contact form not sending email in a website has probably to do with ports:
what if I change the port to 8080? [This will be my next step]

APACHE CONFIG HTTPD
=> Listen 8080?

1. You can indeed send emails without authentifcation, it's not a security issue as you are sending from localhost! But you can disable that in Hmail server.

2. If you care for security you can't run web matrix on production server.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by:
#46
RE: Sentora for Windows 1.0.0 released!
Quote:1. You can indeed send emails without authentification, it's not a security issue as you are sending from localhost! But you can disable that in Hmail server.

2. If you care for security you can't run web matrix on production server.

M B

Yes, but I still have a problem:

It seems pathetic that windows allows to send emails from http://localhost:8080 (with a PHP, IIS 8 EXPRESS and WebMatrix constellation and all the relevant ports opened, which is perhaps 25, 80, 110, etc.) and it doesn't allow that when we have a regular DNS configuration, where the name of the websites is known and so on...

WHY is the server not sending the emails over contact-form.php when the website is LIVE, hosted at c:/SENTORA/www/... (without SMTP AUTH)? What do I need to do, so that the emails are normaly sent over mail/sendmail method with PHPmailer and without a SMTP smarthost?

This is a very, very small issue, compared with all the SENTORA abilities... But it is driving me mad, once I can't find the solution for it... Dodgy
Reply
Thanks given by:
#47
RE: Sentora for Windows 1.0.0 released!
1. This PORT is not official, but kindly DONE and BUILT by MARK.

2. Hmail server is open for relaying local mail.

3. What errors do you face? Error logs? may be an issue with php configuration but it should work fine as the smtp is the same and it's mainly OPEN only for local senders and have nothing to do with DNS!

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by:
#48
RE: Sentora for Windows 1.0.0 released!
(02-25-2015, 06:39 AM)Me.B Wrote: 1. This PORT is not official, but kindly DONE and BUILT by MARK.

Mark has done a good job  Big Grin
Only the CMD PHP/PHP.exe is somehow annoying... It writes logs each minute

   

Quote:2. Hmail server is open for relaying local mail.

I didn't change the configurations, is it a standard config?

Quote:3. What errors do you face? Error logs? may be an issue with php configuration but it should work fine as the smtp is the same and it's mainly OPEN only for local senders and have nothing to do with DNS!

As I already wrote here, the local email accounts are working fine.
I tried them with 2 or 3 domains and I was able to send and receive emails from outside.

The contact-form.php is hosted in one of the websites.
WebBuilder 10 offers the possibility to choose several send methods: qmail, mail, sendmail, SMTP.
I tried them all without success.

Using the mail/sendmail method I receive this message:
ERROR: could not instantiate mail function. phpmailer error: could not instantiate mail function
As I wrote before, the problem is not the PHPmailer.php script, once I was able to send an email with it over "http://localhost:8080" (the WebMatrix story)

I also tried some dedicated software (Arclab Webformular Generator), to know if the problem was only the code,
but I also received an error message:

email error: mail() returned failure
server: Apache/2.2.29 (Win32) mod_antiloris/0.6.0 PHP/5.4.36 mod_perl/2.0.8 Perl/v5.16.3
Reply
Thanks given by:
#49
RE: Sentora for Windows 1.0.0 released!
Have you tried changing all occurrences of 'localhost' to '127.0.0.1' (related to mail system)? I remember reading about this a while back and is what I am currently using for Windows.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#50
RE: Sentora for Windows 1.0.0 released!
(02-25-2015, 07:09 AM)TGates Wrote: Have you tried changing all occurrences of 'localhost' to '127.0.0.1' (related to mail system)? I remember reading about this a while back and is what I am currently using for Windows.

Yes, I had that idea after analyzing the HOSTS file... But I think I didn't change it properly as I should. I thought the shortest way would be to change it directly in HOSTS, the reason why I uncommented the first value:

127.0.0.1 localhost

After that SENTORA wasn't working right anymore, and I restored HOSTS to its former values, with all the websites and "commented ;127.0.0.1 localhost".

I also changed the value in the SMTP TAB of HMAILSERVER, from localhost into 127.0.0.1 but it wasn't right, I think. The first thing I've done after restarting APACHE was to check the email accounts. Somehow, the account couldn't load the mail lists or connect to db, the functionality was restricted.

However, once I had done too many changes and extra installations, I resolved to start again from the scratch and reinstall Windows 7 and SENTORA.

You mean I should change localhost into 127.0.0.1 in

php.ini
sendmail.ini
hmailserver.ini ?
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Sentora on Windows ANY NEW INSTALLER elmoutakaf 3 3 980 10-04-2020, 02:37 AM
Last Post: Gigamax
ZPanel 10.1.1 -> Sentora 1.0.3 Windows Version TGates 16 21 023 07-09-2020, 09:50 PM
Last Post: andykimpe
sentora awserver apache 2.2 to 2.4 migration elmoutakaf 1 2 448 07-08-2020, 09:49 PM
Last Post: andykimpe

Forum Jump:


Users browsing this thread: 1 Guest(s)