This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Jump to the post that solved this thread.
new reseller not receiving welcome email
#1
[Solved] new reseller not receiving welcome email
Hi

i have sentora 1.0.3

everything works well, except new reseller not receiving welcome email and Zgod report not sent, also Certificate requst..

no emails from the Sentora..

roundcube works perfect..

please HELP....
Reply
Thanks given by:
#2
[Solved] RE: new reseller not receiving welcome email
(01-05-2019, 06:48 PM)itzik53 Wrote: Hi

i have sentora 1.0.3

everything works well, except new reseller not receiving welcome email and Zgod report not sent, also Certificate requst..

no emails from the Sentora..

roundcube works perfect..

please HELP....

OK

found the problem... 
adding

 if (!spl_autoload_functions() OR (!in_array('PHPMailerAutoload', spl_autoload_functions()))) {
  require_once('PHPMailerAutoload.php');
}


to file /etc/sentora/panel/etc/lib/PHPMailer/class.phpmailer.php

That fixed the problem....
Reply
Thanks given by:
#3
[Solved] RE: new reseller not receiving welcome email
(01-06-2019, 04:11 AM)itzik53 Wrote: OK

found the problem... 
adding

 if (!spl_autoload_functions() OR (!in_array('PHPMailerAutoload', spl_autoload_functions()))) {
  require_once('PHPMailerAutoload.php');
}


to file /etc/sentora/panel/etc/lib/PHPMailer/class.phpmailer.php

That fixed the problem....

That file should already contain:

if (!in_array('PHPMailerAutoload', spl_autoload_functions())) {
    require 'PHPMailerAutoload.php';
}

so my questions would be:

- was your class.phpmailer.php file missing these lines for some reason?
- is your server/PHP config set to not allow use of the "require" function?
- is your server/PHP config set to not allow spl_autoload_functions()?

I can't see that this would be a problem for anyone with a vanilla Sentora installation, but I could be wrong Wink

Keith
Reply
Thanks given by:
Jump to the post that solved this thread.


Possibly Related Threads...
Thread Author Replies Views Last Post
Can't Find Reseller section in my VPS EgyHoster.Club 0 137 04-05-2019, 06:56 PM
Last Post: EgyHoster.Club
Where can i find email users passwd, quota file ? gotam19 1 710 08-08-2018, 10:46 AM
Last Post: wormsunited
Reseller/Users Domain Nameservers CMs222 4 2,103 01-12-2018, 09:17 AM
Last Post: CMs222

Forum Jump:


Users browsing this thread: 1 Guest(s)