This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Port 443 goes active, https causes error
#3
[Not Solved] RE: Port 443 goes active, https causes error
(01-03-2018, 03:07 AM)TGates Wrote: Did you resolve this? Domain opens with SSL and properly redirects from 80 to 443.

No, this has not been resolved. Your statement above is certainly how it should work. With the following settings,

-------------------------------
SENTORA CONFIG
Sentora Apache Port 443 Sentora Apache panel port
-------------------------------
-------------------------------
APACHE CONFIG
Apache Port 80 Apache service port
-------------------------------

whenever /etc/sentora/configs/apache/httpd-vhosts.conf is reset and adds "Listen 443" apache2 gets hung-up and stops running. When I rem out the line and restart apache2, everything is fine until the next time vhosts.conf gets reset.

In other words, when the system is "listening" to port 443, the problem occurs. When it is only listening to port 80, and a SSL domain is accessed, the proper redirect works.
Reply
Thanks given by:


Messages In This Thread
RE: Port 443 goes active, https causes error - by rsthomas - 01-26-2018, 11:52 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
https without certificate redirects to panel iraqiboy90 9 2 494 10-14-2020, 10:45 PM
Last Post: iraqiboy90
Having both HTTP & HTTPS (Port 443 and Port 80) sites on a server dsmarter 15 21 098 08-22-2020, 02:49 PM
Last Post: kenzopoker1
redirect error after letsencrypt + subdomain mizerek 1 483 08-06-2020, 04:54 AM
Last Post: mizerek

Forum Jump:


Users browsing this thread: 1 Guest(s)