This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Port 443 goes active, https causes error
#1
[Not Solved] Port 443 goes active, https causes error
After adding Let's Encrypt to my Sentora control panel domain I am not able to access it via https, and sometimes apache2 is automatically stopped.  Trying to restart it then causes this message:  "(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443"

I followed the directions from http://docs.sentora.org/?node=102.  

Below are the configuration settings.  Have I missed something?

-------------------------------
SENTORA CONFIG
Sentora Apache Port     443     Sentora Apache panel port
-------------------------------

APACHE CONFIG
Apache Port     80     Apache service port

Code:
Global Sentora Entry     Extra directives for Sentora default vhost.
SSLEngine on
SSLProtocol ALL -SSLv2 -SSLv3
SSLHonorCipherOrder On
SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS
SSLCertificateFile /etc/letsencrypt/live/admin.rstunlimited.us/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/admin.rstunlimited.us/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/admin.rstunlimited.us/chain.pem
# Keeping bellow for future upgrades.
# Requires Apache >= 2.4
SSLCompression off
---------------------------

HTTPD-VHOSTS.CONF    
Listen 443
Listen 80

# Configuration for Sentora control panel.
<VirtualHost *:443>
ServerAdmin email@rstunlimited.us
DocumentRoot "/etc/sentora/panel/"
ServerName admin.rstunlimited.us
ErrorLog "/var/sentora/logs/sentora-error.log"
CustomLog "/var/sentora/logs/sentora-access.log" combined
CustomLog "/var/sentora/logs/sentora-bandwidth.log" common
AddType application/x-httpd-php .php
<Directory "/etc/sentora/panel/">
Options +FollowSymLinks -Indexes
   AllowOverride All
   Require all granted
</Directory>

# Custom settings are loaded below this line (if any exist)
SSLEngine on
SSLProtocol ALL -SSLv2 -SSLv3
SSLHonorCipherOrder On
SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS
SSLCertificateFile /etc/letsencrypt/live/admin.rstunlimited.us/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/admin.rstunlimited.us/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/admin.rstunlimited.us/chain.pem
# Keeping bellow for future upgrades.

# Requires Apache >= 2.4

SSLCompression off
</VirtualHost>

---------------------------
Reply
Thanks given by:


Messages In This Thread
Port 443 goes active, https causes error - by rsthomas - 01-02-2018, 10:56 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
https without certificate redirects to panel iraqiboy90 9 2 494 10-14-2020, 10:45 PM
Last Post: iraqiboy90
Having both HTTP & HTTPS (Port 443 and Port 80) sites on a server dsmarter 15 21 098 08-22-2020, 02:49 PM
Last Post: kenzopoker1
redirect error after letsencrypt + subdomain mizerek 1 483 08-06-2020, 04:54 AM
Last Post: mizerek

Forum Jump:


Users browsing this thread: 1 Guest(s)