This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

I want to create a subdomain using XMWS
#1
[Not Solved] I want to create a subdomain using XMWS
I want to create a subdomain using XMWS.
I wrote the test code below.

<?php
  require_once '../../conf.php';
  require_once '../../lib/xmwsclient.class.php';
  $xmws = new xmwsclient();
  $xmws->InitRequest($apiurl, 'sub_domains', 'CreateSubDomain', $apikey);
  $xmws->SetRequestData('<subname>test.mydomain.com</subname><subdirectory>/test_mydomain_com</subdirectory><uid>zadmin</uid><autohome>1</autohome>');
  $response_array = $xmws->XMLDataToArray($xmws->Request($xmws->BuildRequest()));
  if ($response_array['xmws']['response'] <> 1101) {
    die("API Error: " . $response_array['xmws']['content']);
  }
  else {
    echo $xmws->Request($xmws->BuildRequest());
  }
?>

It does not work normally.
I confirmed that it is registered in the database table x_vhosts.
It does not appear on the sentora subdomain manager.

What is the problem?
Reply
Thanks given by:


Messages In This Thread
I want to create a subdomain using XMWS - by phuong112 - 11-05-2019, 01:39 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
Public_html Inside Domain/Subdomain zHostingSolutions 2 1 642 07-23-2021, 09:57 AM
Last Post: Nigel
redirect error after letsencrypt + subdomain mizerek 1 2 178 08-06-2020, 04:54 AM
Last Post: mizerek
Cannot Create 2nd 'Addon' Domain In Sentora? Error: Invalid backend configuration. Re BattlinThrough 2 2 971 07-07-2020, 01:22 PM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)