This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

httpd-vhosts.conf problem
#1
[Solved] httpd-vhosts.conf problem
I am already installing nginx, varnish, apache on my server and my "httpd-vhosts.conf" listen on port 8081,443

In sentora > apache config > apache port I sent port to 8081,

everything is ok but somethimes my "httpd-vhosts.conf" listen ports change from 8081,443 to 80,443
how I can stop automatically port changing and keep my ports :/
==============
Reply
Thanks given by:
#2
[Solved] RE: httpd-vhosts.conf problem
(02-02-2018, 02:04 AM)mohamadcom Wrote: I am already installing nginx, varnish, apache on my server and my "httpd-vhosts.conf" listen on port 8081,443

In sentora > apache config > apache port I sent port to 8081,

everything is ok but somethimes my "httpd-vhosts.conf" listen ports change from 8081,443 to 80,443
how I can stop automatically port changing and keep my ports :/
==============

You cannot edit the httpd-vhosts.conf file as every time the daemon runs it will overwrite your changes. You need to make changes to Admin>Apache Config Apache service port.

Run the daemon:
sudo /usr/bin/php -q /etc/sentora/panel/bin/daemon.php

Thanks for straightening me out TGates.
Everyone makes mistakes, but to truly screw up it takes the root password!
Reply
Thanks given by:
#3
[Solved] RE: httpd-vhosts.conf problem
Module Admin > Apache Config > Apache Service Port = 8081
Save and wait for the daemon to run.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#4
[Solved] RE: httpd-vhosts.conf problem
(02-02-2018, 07:50 AM)worksmarter Wrote: You cannot edit the httpd-vhosts.conf file as every time the daemon runs it will overwrite your changes. You need to make changes to Admin>Apache Config Apache service port.

Run the daemon:
sudo /usr/bin/php -q /etc/sentora/panel/bin/daemon.php

Thanks for straightening me out TGates.

thanks for help, but this is my problem, 
I have an old domain " I was add it before port changing " , I change the port from apache config in sentora control panel but till now the port always return back to 80 :/
no problem with new domain, only the old one .
Reply
Thanks given by:
#5
[Solved] RE: httpd-vhosts.conf problem
hello,
I solve it, and I will write here the solution to be useful to another people who face this problem ...
there is a static value in "OnDaemonRun.hook.php" file for that even if someone  change the port from sentora config and apache vhost config in sentora panel will face a problem in
"# PORT FORWARD FROM 80 TO: 443" for that you should go to :
...../panel/modules/apache_admin/hooks/OnDaemonRun.hook.php
and search for this line "# PORT FORWARD FROM"
and under it change the port 80 to any other port you want ...
like attachment....


Attached Files Thumbnail(s)
   
Reply
Thanks given by:
#6
[Solved] RE: httpd-vhosts.conf problem
This was a bug which is fixed in 1.0.4
This is the proper fix: https://github.com/sentora/sentora-core/...65f7c915cb
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Important HTTPD not starting timce2000 4 977 03-17-2018, 06:43 AM
Last Post: TGates
Change client's data folder problem dimnas 1 518 02-14-2018, 03:49 AM
Last Post: TGates
wordpress problem mohamadcom 3 555 02-02-2018, 01:49 AM
Last Post: mohamadcom

Forum Jump:


Users browsing this thread: 1 Guest(s)