This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

wordpress problem
#1
[Not Solved] wordpress problem
hello,
I have word-press installation, I can't update,add any plugin,media,them ... etc..
I apply chmod 777 on all directorys from /var ... to wp-admin/plugins but till now I can't add anything to my wordpress site..
another question, I change my apache port from sentora settings and from vhost config file " from 80 to 8081" but sometimes the ports in vhost config file automatically changed back from 8081 to 80 is here a soluations ?
note ports in sentora settings not changed
Reply
Thanks given by:
#2
[Not Solved] RE: wordpress problem
(02-01-2018, 09:15 AM)mohamadcom Wrote: hello,
I have word-press installation, I can't update,add any plugin,media,them ... etc..
I apply chmod 777 on all directorys from /var ... to wp-admin/plugins but till now I can't add anything to my wordpress site..
another question, I change my apache port from sentora settings and from vhost config file " from 80 to 8081" but sometimes the ports in vhost config file automatically changed back from 8081 to 80 is here a soluations ?
note ports in sentora settings not changed

Hi, try executing this command from shell , chmod -r www-data:www-data /(your installation directory), basically its giving the recursive directory permission to apache for the mentioned directory. Well if you are setting the specifically for domain you can see under menu admin>module admin>apache config. You can also see the attached screenshot.


Attached Files Thumbnail(s)
   
Reply
Thanks given by:
#3
[Not Solved] RE: wordpress problem
(02-01-2018, 09:15 AM)mohamadcom Wrote: I apply chmod 777 on all directorys from /var ... to wp-admin/plugins

You do not want to give world read/write permissions to any of your web site directories. - No more than 0770.
Everyone makes mistakes, but to truly screw up it takes the root password!
Reply
Thanks given by:
#4
[Not Solved] RE: wordpress problem
Thanks for helping,
I solve it by this command
1- change owner for all files,folders,sub-folders
chown -R apache:apache "path"
2- change files ,sub files , folders and sub folder permissions
files to 644 , folders to 755
chmod -R u+rwX,go+rX,go-w "path"

(02-01-2018, 03:52 PM)ismailfazal Wrote: Hi, try executing this command from shell , chmod -r www-data:www-data /(your installation directory), basically its giving the recursive directory permission to apache for the mentioned directory. Well if you are setting the specifically for domain you can see under menu admin>module admin>apache config. You can also see the attached screenshot.

by the way, can you told me the name of the theme you are using on your website, it's very beautiful Big Grin
Reply
Thanks given by:
#5
[Not Solved] RE: wordpress problem
If you looking for best WordPress themes for your website kindly visit https://www.sktthemes.net/themes
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Wordpress Multisite Support (& Multiple Domains if Possible) asobiek 1 170 06-18-2018, 05:19 AM
Last Post: asobiek
Change client's data folder problem dimnas 1 574 02-14-2018, 03:49 AM
Last Post: TGates
httpd-vhosts.conf problem mohamadcom 5 797 02-03-2018, 08:40 AM
Last Post: TGates

Forum Jump:


Users browsing this thread: 1 Guest(s)