This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Sentora open_basedir - how to set for specific directory
#1
[Solved] Sentora open_basedir - how to set for specific directory
Hi,

how to set for specific directory open_basedir

i get following error when running my CI project


Code:
A PHP Error was encountered

Severity: Warning

Message: ini_set(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/var/sentora/hostdata/zadmin/public_html/inv_opensourceworld_info:/var/sentora/temp/)

Filename: drivers/Session_files_driver.php

Line Number: 108

Backtrace:

File: /var/sentora/hostdata/zadmin/public_html/inv_opensourceworld_info/application/controllers/Auth.php
Line: 7
Function: __construct

File: /var/sentora/hostdata/zadmin/public_html/inv_opensourceworld_info/index.php
Line: 315
Function: require_once
Reply
Thanks given by:
#2
[Solved] RE: Sentora open_basedir - how to set for specific directory
Fixed the issue thanks to @Ron-e

Thread Link


http://forums.sentora.org/showthread.php...1#pid20031

Steps:

Module Admin -> Apache Config -> Select domain at "Override a Virtual Host Setting" -> unselect "OpenBase Enabled" -> save -> wait 5 min. or run daemon manually.
Reply
Thanks given by:
#3
[Solved] RE: Sentora open_basedir - how to set for specific directory
lol, i'm glad i could help.. Tongue
●●●●●●●
My Sentora DemoMy GithubAuxio Github
Zentora themeS-Type themeCstyleX theme
flat-color-iconssmall-n-flat-icons
●●●●●●●


Reply
Thanks given by:
#4
[Solved] RE: Sentora open_basedir - how to set for specific directory
(10-26-2017, 11:31 PM)Ron-e Wrote: lol, i'm glad i could help.. Tongue


Hi sorry for interrupt this post, my english its not good and im new at sentora but i have the same issue when i try to use session_start

Warning: session_start(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/var/sentora/hostdata/zadmin/public_html/adharagrill_mx:/var/sentora/temp/) in /var/sentora/hostdata/zadmin/public_html/adharagrill_mx/lang/Language.php on line 10

I saw your fix solution but you mentioned that fix could lead to an security issue so there is another way to fix?
Reply
Thanks given by:
#5
[Solved] RE: Sentora open_basedir - how to set for specific directory
(04-10-2019, 01:28 AM)Juan Pablo Wrote: Hi sorry for interrupt this post, my english its not good and im new at sentora but i have the same issue when i try to use session_start

Warning: session_start(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/var/sentora/hostdata/zadmin/public_html/adharagrill_mx:/var/sentora/temp/) in /var/sentora/hostdata/zadmin/public_html/adharagrill_mx/lang/Language.php on line 10

I saw your fix solution but you mentioned that fix could lead to an security issue so there is another way to fix?

That is because your script is looking for /tmp while it should be pointed at /var/sentora/temp You could also try and add /tmp to the Open Base Temp Directory config in: Admin > Module Admin > Apache Config and change it to look like:

Code:
/var/sentora/temp/:/tmp/
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#6
[Solved] RE: Sentora open_basedir - how to set for specific directory
(04-11-2019, 07:24 AM)TGates Wrote: That is because your script is looking for /tmp while it should be pointed at /var/sentora/temp You could also try and add /tmp to the Open Base Temp Directory config in: Admin > Module Admin > Apache Config and change it to look like:

Code:
/var/sentora/temp/:/tmp/

Sorry for the late response but i tried as you said setting this: /var/sentora/temp/:/tmp/ to Apache config and restarted the service but still got the same issue.

[Image: open_base.png]

But still got this 
[Image: issue_temp.png]
i should do the override config?
Reply
Thanks given by:
#7
[Solved] RE: Sentora open_basedir - how to set for specific directory
You can do the bypass to test the site and get it working, then we can sort out the folder restriction so that you can turn the blocking back on. I checked the domain and whatever scripts you are using are full of problems from the looks of it.
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
to clone 'sentora' installation to another machine gabriel15959 4 320 06-19-2019, 06:02 AM
Last Post: Me.B
Can I remove suhosin on non sharing sentora vps? maximus___ 1 331 04-17-2019, 12:48 AM
Last Post: Me.B
Point subdomain to other ip server from sentora MeredithSmith 1 383 04-09-2019, 06:19 PM
Last Post: fearworks

Forum Jump:


Users browsing this thread: 1 Guest(s)