This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

.htaccess has stopped working?
#1
[Not Solved] .htaccess has stopped working?
I have SSL enabled on my Sentora installation for my panel and all of my websites.  I also have my .htaccess setup so that all http requests forward to https.  Everything has been working great since initially setting this up. As I matter of fact I logged into my panel yesterday to check my webmail.  Outside of checking my webmail I haven't made any changes to my server or my Sentora install. 

All of sudden, tonight, I go to log into my panel and I start receiving: 

Code:
Bad Request

Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.
Apache Server at panel.breeviate.com Port 443

I checked the rest of my domains and now all of them are receiving this message.

I verified my .htaccess was being read by Apache by breaking it and receiving an Internal Server error.

Now I have two questions:

1.  What can I do to correct this?
2.  What could have caused this to happen without any interaction from me?

Here's what's in my .htaccess file (again this was working fine until today).
Code:
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Reply
Thanks given by:
#2
[Not Solved] RE: .htaccess has stopped working?
Did you update the server?

May be likely the condition is no more working.
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Coldfusion Freelance

10$ free to start your VPS

Reply
Thanks given by:
#3
[Not Solved] RE: .htaccess has stopped working?
What tutorial did you use for SSL?
Do you have any sites at all on port 80?
What happens if you use https to view your sites? Any errors?

Your server should still listen on port 80 in order to forward to port 443.
Does your /etc/sentora/configs/apache/httpd-vhosts.conf file have Listen 80 near the top?
You may need to add this fix: https://github.com/sentora/sentora-core/...76e30f3509
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
Sentora Admin login not working after Enabling FREE SSL nscloud 7 142 11-17-2017, 03:31 AM
Last Post: TGates
site not working after adding SSL code in Sentora override option premwithme 4 215 10-22-2017, 08:15 PM
Last Post: nscloud
Sentora change FQDN setso not working mares992 3 502 07-24-2017, 12:12 AM
Last Post: mares992

Forum Jump:


Users browsing this thread: 1 Guest(s)