This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

SSL as per Wiki not working on Ubuntu, my solution provided
#1
[Not Solved] SSL as per Wiki not working on Ubuntu, my solution provided
Hi
the way provided by http://docs.sentora.io/?node=21 was not working for me on Ubuntu LTS

to make SSL working with a self signed SSL certificate (next test will be with purchased certificate but should work as well) I had to edit

/etc/zpanel/configs/apache/httpd-vhosts.conf

and modify as attached to this thread

PLEASE REMEMBER to replace SERVERADMINEMAIL and SENTORAFQDM according to your server

hope this can help, suggestions and improvements accepted


Attached Files
.txt   httpd-vhosts.conf.txt (Size: 1.38 KB / Downloads: 30)
Reply
Thanks given by:
#2
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
(08-18-2014, 03:03 AM)lucaballerini Wrote: Hi
the way provided by http://docs.sentora.io/?node=21 was not working for me on Ubuntu LTS

to make SSL working with a self signed SSL certificate (next test will be with purchased certificate but should work as well) I had to edit

/etc/zpanel/configs/apache/httpd-vhosts.conf

and modify as attached to this thread

PLEASE REMEMBER to replace SERVERADMINEMAIL and SENTORAFQDM according to your server

hope this can help, suggestions and improvements accepted

The certificate for your control panel needs to be installed Globally (i.e. system wide) and not locally (like you've done). The local certificates are for you're domains and sub-domains.

I'll fire up a VM in the next couple of days and get this fixed once and for all.
***Retail***
SCPH-39002, Running FCMB, HDD-OSD, Mini-OPL.
SCPH-30002 RSW (Automobile Collection Snow White)
SCPH-10000 x2
SCPH-15000
SCPH-18000 x2
DESR-7700
SCPH-2040X x2
Linux Kit
PSBBN V0.20, V0.30
HDD Utility V1.00, V1.01

***Dev***
DTL-H30102 Running FCMB, HDD-OSD, Mini-OPL.
DTL-H20400 - Boxed
Reply
Thanks given by:
#3
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
Not to mention, you can not edit the httpd-vhosts.conf file. It is completely controlled by the panel. You need to add it a custom vhost entry...
-TGates - Head of Support

SEARCH the Forums or read the DOCUMENTATION before posting!
Modules Maintained: 13 - Module Installs: 108k+

Find my support or modules helpful? Donate HERE
Get your domains using my affiliate link:
GoDaddy - Domains
Reply
Thanks given by:
#4
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
Thanks for your suggestions, please provide the right way to do it and update the Guide.

thanks in advance
Reply
Thanks given by:
#5
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
Hello all, i m runing this script on ubuntu. same prob like luca.

which code i have to put in the panel?
i put 2 times the code from wiki and the panel crashed. i had to reinstall the server. i dont want to try that again if i m not shure. i takes alot of time

for me works only this method:
in the vhost congif file.
how can i activate that global?
Code:
################################################################
# Apache VHOST configuration file
# Automatically generated by ZPanel 10.1.1
# Generated on: 18:35 17th Aug 2014 CEST
################################################################

#NameVirtualHost *:80

# Configuration for ZPanel control panel.
<VirtualHost *:80>
ServerAdmin info@domain.eu
DocumentRoot "/etc/zpanel/panel/"
ServerName domain.eu
ErrorLog "/var/sentora/logs/sentora-error.log"
CustomLog "/var/sentora/logs/sentora-access.log" combined
CustomLog "/var/sentora/logs/sentora-bandwidth.log" common
AddType application/x-httpd-php .php
<Directory "/etc/zpanel/panel/">
Options FollowSymLinks -Indexes
   AllowOverride All
   Order allow,deny
   Allow from all
</Directory>

# Custom settings are loaded below this line (if any exist)
##################################################
# Apache VHOST configuration file
# Automatically generated by Sentora 10.0.2
# Generated on: 12:25 2nd Jun 2013 WIT
##################################################

Redirect Permanent / https://root.domain.eu/
</VirtualHost>
Listen 443
<VirtualHost *:443>
# Configuration for Sentora control panel.

SSLEngine on
SSLProtocol SSLv3
SSLCertificateFile /etc/apache2/ssl/Sentora.crt
SSLCertificateKeyFile /etc/apache2/ssl/Sentora.key
ServerAdmin info@domain.eu
DocumentRoot "/etc/zpanel/panel/"
ServerName domain.eu

</VirtualHost>
################################################################
# ZPanel generated VHOST configurations below.....
################################################################
Reply
Thanks given by: ashok
#6
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
I will update the wiki clean how to for SSL
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by:
#7
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
(12-07-2014, 05:59 AM)Me.B Wrote: I will update the wiki clean how to for SSL

it will be nice. i m fighting since hours now to fix this problem.
i m waiting for the how to. hope today Smile thx.
Reply
Thanks given by:
#8
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
In few lines the best solution is:

1. create a new conf file that contain your SSL host that will look like this

Quote:<virtualhost *:443>
ServerName ssl.domain.com
ServerAlias ssl.domain.com
ServerAdmin you@domain.com
DocumentRoot "/var/zpanel/hostdata/zadmin/public_html/ssl.domain.com"
php_admin_value open_basedir "/var/zpanel/hostdata/zadmin/public_html/ssl.domain.com:/var/zpanel/temp/"
php_admin_value suhosin.executor.func.blacklist "passthru, show_source, shell_exec, system, pcntl_exec, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, escapeshellarg, exec"
ErrorLog "/var/zpanel/logs/domains/zadmin/ssl.domain.com-error.log"
CustomLog "/var/zpanel/logs/domains/zadmin/ssl.domain.com-access.log" combined
CustomLog "/var/zpanel/logs/domains/zadmin/ssl.domain.com-bandwidth.log" common
<Directory />
Options FollowSymLinks Indexes
AllowOverride All
Order Allow,Deny
Allow from all
</Directory>
AddType application/x-httpd-php .php3 .php
ErrorDocument 403 /_errorpages/403.html
ErrorDocument 510 /_errorpages/510.html
ErrorDocument 500 /_errorpages/500.html
ErrorDocument 404 /_errorpages/404.html
DirectoryIndex index.html index.htm index.php index.asp index.aspx index.jsp index.jspa index.shtml index.shtm
SSLEngine On
SSLCertificateFile /var/zpanel/logs/domains/zadmin/ssl/secure1.pem
SSLCertificateKeyFile /var/zpanel/logs/domains/zadmin/ssl/secure1.key
</virtualhost>

All zpanel path's should be replaced by sentora.

You will need first to create a normal ssl.domain.com ( sub domain) could a be domain so replace ssl.domain.com with the correct URL you will use.

Notice the path for the SSL certificates that you can change.

Once you create this config file as ssl.domain.com.conf place it in
/etc/zpanel/config/apache/ ( or /etc/sentora/ )

Then check your apache main config file & add include the new conf file you created.

Restart apache. If your SSL certficate is ok ( take care to remove the password or apache will request it after each restart), you should now have
http://ssl.domain.com working &
https://ssl.domain.com both pointing same root.

Then add a .htaccess to enforce https only if you need that or you can keep both working.

I think the old way in the wiki should not be used & hope in next release we auto generate the ssl host instead of having this manual setup. The wiki how to fail to explain the need for override. As once you enable ssl the default domain/subdomain with SSL will no longer work on HTTP & this is why you will be required to add a vhost port override to avoid nasty errors. My way will allow both SSL & non SSL working but require a lot more manual admin off panel.

This topic is FOR EXPERIENCED ADMIN.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by: soap , Blooddarkness , Cantalupo , stiuvert0007
#9
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
hello, thank you for your support. iis it possible to post a clear solution for self signedssl for the sentora panel? this is the problem that i have actually. thx
Reply
Thanks given by:
#10
[Not Solved] RE: SSL as per Wiki not working on Ubuntu, my solution provided
Yep it should work fine same as certficates by startcom.com ( they are free !). Follow the wiki & create your own SSL certificates using openSSL then follow my guide for the setup.

M B
No support using PM (Auto adding to IGNORE list!), use the forum. 
How to ask
Freelance AWS Certified Architect & SysOps// DevOps

10$ free to start your VPS

Reply
Thanks given by: soap


Possibly Related Threads...
Thread Author Replies Views Last Post
OS - Ubuntu 18.04 or Centos 8 Qrash 1 2 201 01-18-2021, 07:48 PM
Last Post: Jettaman
Ubuntu 18.04 vaxition 1 2 520 08-06-2020, 11:03 AM
Last Post: Jettaman
Php5.6 on ubuntu possible? lorenaustin 0 1 374 06-11-2020, 01:01 AM
Last Post: lorenaustin

Forum Jump:


Users browsing this thread: 1 Guest(s)